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1 Introduction

1.1 Welcome to tiBase

Introduction

tiBase  is a program for administrating analysis data on the basis of PC/LIMS
reports. These reports can be read from the corresponding Metrohm instru-
ments.

Overview of the main program features

￭ User interface: easy to operate and configure
￭ Application
￭ Comprehensive online help
￭ Program versions
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1.2 Application

tiBase  is a database program for administrating data on the basis of PC/
LIMS reports. The reports from the corresponding Metrohm instruments
(Titrino, Titrino Plus, Titrando and Dosimat plus) can be read into tiBase.

1.3 Operation 

Introduction

The modern user interface makes it simple for the user to find his/her way
around tiBase . The bar on the left edge of the screen gives you access to
the two basic elements of tiBase :

Database Configura-
tion

Depending on the access rights, these buttons are either visible or invisible.
The menu bar is in the upper part of the screen. It is also possible for the
individual commands to be masked out, depending on the access rights.

In the center of the screen there are the subwindows with determination
overviews, curves information or results. This view can be set individually for
each user with the aid of the new Layout Manager. This means that the users
only see the buttons needed for their work. This reduces the introductory
period for routine users to a minimum; incorrect operation as a result of
overcrowded screens are also a thing of the past.
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1.4 Connecting devices

Introduction

PC/LIMS reports of the following instruments can be read into
tiBase :

￭ Titrando
808, 809, 835, 836, 841, 842, 855, 857, 888, 890, 901, 902, 904, 905,
906, 907

￭ Titrino
702, 716, 718, 719, 720, 721, 736, 751, 758, 784, 785, 794, 795, 798,
799

￭ Titrino plus
848, 862, 870, 877

￭ Dosimat plus
865, 876

1.5 Database

Introduction

tiBase  is based on an object-oriented database, that has proven itself
in practice. In the configuration database, all program settings, user
administration, methods and templates are stored and in the determina-
tion databases defined by the user, the determination data. These data-
bases can be installed locally on the computer reserved for measurements
and make up a simple measurement system. tiBase  is however scalable
and grows with operational requirements. As soon as data security and
central data management make it necessary, tiBase  is installed as a Client/
Server configuration. The tiBase  database is then installed on a server.
All measurement and office computers work as clients. All results are stored
centrally in this network and can be accessed and processed by all Client
PCs. All clients also access the same pool of methods.

The new database has all the major tools necessary for management of,
searching for and grouping of results. Quick filters allow the user to search
through thousands of determinations within seconds and to display the
result clearly. Chart plots give a fast overview of the sequence of results
based on time.

All options for reprocessing are available to the user.

Overview of functions

￭ Object-oriented Client/Server database (see Chapter 3.2.3.1, page
91).

￭ Layout manager for the database view (see Chapter 4.1.7, page 115).
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￭ Quick filter (see Chapter 4.5.2.4.3, page 210).
￭ Efficient search functions (see Chapter 4.5.2.3, page 207).
￭ Access rights control for every database (see Chapter 4.3.5.3, page

124).
￭ Automatic database backup (see Chapter 4.3.5.4, page 124).
￭ Control cards (see Chapter 4.5.2.16, page 248).
￭ Reprocess determinations (see Chapter 4.5.2.6, page 220).

1.6 Communication

Introduction

The decisive factor for acceptance is easy and economical integration in
existing laboratory information systems, central databases and long-term
archiving systems.

tiBase  is communicative. Data generated in tiBase  can be exported in
XML and CSV format. Connection to LIMS systems on the market is thus not
difficult. Export to long-term archiving systems such as NuGenesis SDMS or
Scientific Software Cyberlab is also supported.

The Report generator provides a simple and flexible solution for creating
analysis reports. The report generator allows you to freely define the report.
It is therefore possible at any time to display one or more determinations in
a choice of PDF layouts or as a printout.

Overview of functions

￭ Import of PC/LIMS reports (see Chapter 3.4.3, page 103)
￭ Various export formats , e.g. XML, CSV, SLK (see Chapter 4.4.4.2.1, page

174).
￭ Report designer (see Chapter 4.4.1.4.1.1, page 131).
￭ E-mail functions for security settings (see Chapter 3.2.2.7, page 89).
￭ Sending determinations by E-mail (see Chapter 4.5.2.7, page 242).

1.7 Conformity 

Introduction

With regard to GMP and GLP requirements, tiBase  sets new standards.
The latest quality standards and validation procedures were implemented in
developing and programming the software. A centralized user administra-
tion defines the access rights for program functions and determinations,
whereby any number of users with freely definable access profiles are pos-
sible. The system administrator can conveniently access the user adminis-
tration from any tiBase  client. Access to the software is password-protected
and there is a choice of tiBase  or Windows login.
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The use of digital signatures makes it possible to sign determinations.
There are two signatures available with differing properties. With the first
signature (Level 1, Review) the user confirms that he has programmed the
method correctly or carried out the analysis correctly. With the second sig-
nature (Level 2, Release) the method or result is released and protected
against further modifications. It is thus possible to mirror customized work-
flows in tiBase .

All data is organized according to the version and protected against unau-
thorized access, modification or deleting in the database. The database itself
controls access to the data in network operation and provides archiving and
restore functions.

Conformity relevant properties of tiBase 1.0

￭ Conformity is priority in development and validation.
￭ Centralized user administration (see Chapter 3.2.1.1, page 74).
￭ Detailed access rights (see Chapter 3.2.1.2.2, page 77).
￭ Password protection under tiBase  or Windows (see Chapter 3.2.2.2,

page 83).
￭ Digital signature on two levels (see Chapter 2.3, page 11).
￭ One signature each for methods and results.
￭ Documentation of all determination modifications (see Chapter

4.5.2.13, page 246)

1.8 Versions

Introduction

tiBase  is available in the following sales versions, which differ with regard
to scope and functions. An upgrade is possible at any time.

 tiBase 1.0
full

tiBase 1.0
multi

Upgrade

Product 6.6063.102 6.6063.103 6.6063.108

User administration • •  

Security settings • •  

Client/Server support •  

Number of licenses 1 3  

Additional licenses as
an option

 •  

XML data export to
LIMS

• •  

Upgrade possible • •  
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1.9 Online help

Introduction

Calling up the Help

tiBase  has an extensive and detailed online help that can be requested in
two ways:

￭ General request With the menu item Help ▶ tiBase Help, or the sym-

bol  the online help with the topic Welcome to tiBase is opened. From
there you can jump via Contents, Index, Search or personal Favor-
ites to the desired topic.

￭ Context-sensitive request With the function key [F1] on the keyboard
you can jump directly to the topic which will show information on the
active element in tiBase  (dialog window, tab).

Symbols and conventions

The following symbols and styles are used in this documentation:

Configuration Link to another help topic in which information is
shown for the marked term.

Database Dialog text

Designation for names of parameters, menu items,
tabs and dialog windows in the software.

100 Designation for parameter values in input fields.

File ▶ New Menu or menu item; Path needed to reach a certain
point in the program.

[Continue] Button

Formula editor

Formulae can be entered in fields with this symbol, and
the formula editor opens when you click on the symbol
(see Chapter 2.4, page 17).

Instruction step

Carry out these steps in the sequence shown.

Caution

This symbol draws attention to a possible risk of dam-
age to instruments or instrument parts.

Note

This symbol marks additional information and tips.
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2 General program functions

2.1 Program parts

2.1.1 Program parts
General program functions

tiBase  has two different program parts which can be opened by clicking on
the corresponding symbol in the vertical bar on the left. The symbol for the
opened program part is shown in color, the symbol for the other program
part in black and white. The menus, symbol bars and content of the main
window depend on the program part currently opened.

Database program part

￭ Opening/closing databases
￭ Managing databases
￭ Reprocessing
￭ Creating report templates

Configuration program part

￭ Configuration of data import, login, backup etc.
￭ Security settings
￭ User administration
￭ Program administration

Note

Access to a program part can be deactivated in the user administration.
In this case the corresponding symbol is disabled.

2.1.2 Database - Desktop
Program part: Database

Database symbol

Clicking on the database symbol in the vertical bar on the left opens the
program part Database while, at the same time the database symbol is
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shown in color. The upper left corner of the symbol contains a black field
displaying the number of databases currently opened (see Chapter 4.2.2,
page 119).

Elements

The desktop of the program part Database comprises the following ele-
ments:

￭ Database-specific menu bar.
￭ Database-specific toolbar.
￭ Main window in which up to 6 subwindows can be displayed.

2.1.3 Configuration - Desktop
Program part: Configuration

Configuration symbol

By clicking on on the configuration symbol in the vertical bar at the left-hand
margin the program part Configuration is opened, at the same time the
configuration symbol is shown in color.

Elements

The desktop of the program part Configuration comprises the following
elements:

￭ Configuration-specific menu bar.
￭ Configuration specific toolbar.
￭ Main window in which 2 subwindows are displayed.

2.2 Login/password protection

2.2.1 General information on Login/Password protection 
Program part: Configuration / Database

Login into tiBase

tiBase  can be configured so that all users have to log in with their user
name and password and this data is automatically checked. This requires
a user administration to be set up and the corresponding security set-
tings to be made. This data is saved in the configuration database. In the
case of client/server systems, this is on the server and applies globally for all
clients (central user administration).
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Recommended settings

On the tab Login/Password protection in the dialog window Security
settings the button [Set] has to be pressed in order to set the settings. The
following conditions are therefore complied with:

￭ A login with user name and password is required each time the
program is started.

￭ Depending on the setting the password administration is carried out
in tiBase  or Windows.

￭ User names must be unique. Users entered once cannot be deleted.
￭ Passwords must be unique per user. None of the expired passwords

already used once by the user may be reused.
￭ Passwords must comprise a minimum number of characters.
￭ Passwords must be changed according to a defined validity period.
￭ The number of incorrect login attempts to enter the password is

limited. If this number is exceeded, the user will automatically be set to
the status inactive.

Actions

If the login is activated, the following actions can be performed:

￭ Log in at program start
￭ Manual logout
￭ Automatic logout
￭ Change password

2.2.2 Login
Program parts: Configuration / Database

If both the options Enforce login with user name and Enforce login
with password are activated in the Security settings, the dialog window
Login will appear every time the program is started and after each time the
user logs out.

User

Entering a short name for the user.

Input 24 characters

Password

Password entry.

Input 24 characters
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Note

Users who log in for the first time or users whose status has been reset
from inactive or removed back to active, must log in with the Start
password(see Chapter 3.2.1.3.1, page 80) specified by the adminis-
trator. Afterwards, the window Change password will automatically be
opened, in which a new password has to be entered.

[Change password]

Opens the window Change password, in which the new password has to
be entered and confirmed.

[Cancel]

The login is canceled, the program is terminated.

2.2.3 Log out manually 
Menu item: Configuration / Database ▶ File ▶ Logout

A logged in user can logout at any time with the menu item File ▶ Log-
out. The logout options defined in the Security settings apply. After the
logout the Login appears, allowing a new user to log in.

2.2.4 Log out automatically
Program part: Configuration

If the automatic logout is activated in the Security Settings, the user will
then automatically be logged out after a definite waiting time if he does not
perform any operating functions via the keyboard or mouse. Afterwards the
Login window opens, in which however only the same user or the members
of the same user group can log in.

Note

Users with administrator rights can always log in.

2.2.5 Changing password
Dialog window: Log in ▶ [Change password] ▶ Change password

Note

In tiBase, the password can only be changed if the option Password
monitoring by tiBase is set in the security settings.
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[Change password]

This button in the dialog window Login opens the window Change pass-
word, in which the new password has to be entered and confirmed.

Note

The password always has to be changed before the Validity of the pass-
word expires. For users who are logging in for the first time or users whose
status has been reset from inactive or removed back to active, this
window is automatically opened after logging in with the Start Pass-
word. For Old Password you also need to enter the Start Password
specified by the Administrator.

Old password

Entry of the previous password.

Input 24 characters

New password

Entry of the new password. The password options are defined in the Secur-
ity settings on the tab Login/Password protection.

Input 24 characters

Confirm password

Confirmation of the new password.

Input 24 characters

2.3 Electronic signatures

2.3.1 Rules for electronic signatures
Program part: Database

In tiBase  determinations can be electronically signed at two levels. The
following rules apply for this:

￭ Signature levels
Signature levels for determinations can be signed at two levels (Signature
Level 1 and Signature Level 2) by entering the user name and password.

￭ Multiple signing
Determinations can be signed several times at each level.

￭ Sign at Level 1
If Level 2 has been signed then no more signatures are possible at Level
1.
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￭ Sign at Level 2
Level 2 can only be signed if signatures already exist at Level 1.

￭ Different users
The same user may only sign on either Level 1 or Level 2.

￭ Reason and comment
Each signature must be accompanied by a reason selected from prede-
fined default reasons. A further comment can also be entered.

￭ Saved data
The signature date, user name, full name, reason and comments are
saved for each signature.

￭ Deleting signatures 1
Signatures at Level 1 are automatically deleted again when compiling a
new version.

￭ Deleting signatures 2
Signatures at Level 2 can only be deleted by users who have the appro-
priate rights.

￭ Signature options
The options for electronic signatures are set in the Signatures tab in the
Security settings dialog window.

2.3.2 Procedure for electronic signatures
Program part: Database

Determinations exhibit one of the following three states in relation to sig-
natures (see flow diagram):

￭ Not signed
Determinations which are not signed can be deleted and changed, a new
version being created at each change.

￭ Signed (1)
When signing determinations at Level 1, no new versions are generated.
If determinations signed at Level 1 are changed, a new version is gener-
ated, which no longer contains any signatures. Determinations signed at
Level 1 can be deleted.

￭ Signed (2)
When signing determinations at Level 2, no new versions are generated.
Determinations signed at Level 2 can neither be changed nor deleted.
However, it is possible to delete the signatures (2), whereby the signa-
tures (1) are retained.
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Modify

Modify

Not sigend

Sign (1)

Signed 1

Sign (2)

Sigend 2

Delete signatures 2

DeleteCreate

Delete

Modify

Delete

2.3.3 Signature Level 1

Dialog window:Database ▶ Determinations ▶ Sign ▶ Signature
1... ▶ Signature Level 1

Determinations can be signed at Level 1 in the Signature Level 1 window.

Note

Determinations which have been signed at Level 1 can be changed and
deleted. If the altered method or determination is saved as a new version
then all existing signatures will be deleted automatically, i.e. the method
or determination must be signed again.

Info

Information display for signing and deleting signatures. The following mes-
sages are possible:

Selection Signature possible | Signature 1 not possible
(signature 2 exists) | Signature not possible
(accessed by other client) | Signature not pos-
sible for multiple determinations

Signature possible
The selected determination can be signed.
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Signature 1 not possible (signature 2 exists)
The selected determination can no longer be signed at Level 1 as it has
already been signed at Level 2.

Signature not possible (accessed by other client)
The selected determination cannot be signed as it is already marked to
be signed on a different client.

Signature not possible for multiple determinations
Several determinations have been selected, they may however only be
signed individually.

User

Entry of the user name (short name).

Input 24 characters

Password

Password entry.

Input 24 characters

Reason

Selection from the Default reasons defined in the Security Settings dia-
log window for the category Signature level 1.

Selection Selection from the Default reasons

Comment

Entry of comment on the signature.

Input 1000 characters

[Sign]

Sign determination. The window remains open.

Note

Determinations can only be signed at level 1 if the user belongs to a user
group with the corresponding authorization .

2.3.4 Signature Level 2

Dialog window:Database ▶ Determinations ▶ Sign ▶ Signature
2... ▶ Signature Level 2

Determinations can be signed at Level 2 in the Signature Level 2 window.
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Note

Determinations that can be signed at level 2 are blocked, i.e. they can
neither be modified nor deleted. In order to be able to edit such deter-
minations again the signatures at level 2 must first be deleted .

Info

Information for signing and deleting signatures is displayed in this box. The
following messages are possible:

Selection Signature possible | Signature 2 not possible
(signature 1 missing) | Signature not possible
(accessed by other client)

Signature possible
The selected determination can be signed.

Signature 2 not possible (signature 1 missing)
The selected determination cannot be signed at Level 2 as it has not yet
been signed at Level 1.

Signature not possible (accessed by other client)
The selected determination cannot be signed as it is already marked to
be signed on a different client.

User

Entry of the user name (short name).

Input 24 characters

Password

Password entry.

Input 24 characters

Reason

Selection from the Default reasons defined in the Security Settings dia-
log window for the category Signature level 2.

Selection Selection from the Default reasons

Comment

Entry of comment on the signature.

Input 1000 characters

[Sign]

Sign determination. The window remains open.
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Note

Determinations can only be signed at level 2 if the user belongs to a user
group with the corresponding authorization .

2.3.5 Delete Signature Level 2

Dialog window:Database ▶ Determinations ▶ Sign ▶ Delete signa-
tures 2... ▶ Delete Signatures Level 2

The Delete Level 2 signatures window allows you to delete all signatures
on Level 2 for the selected methods or determination.

User

Entry of the user name (short name).

Input 24 characters

Password

Password entry.

Input 24 characters

Reason

Selection from the Default reasons defined in the Security Settings dia-
log window for the category Signature level 2.

Selection Selection from the Default reasons

Comment

Entry of comment on the signature.

Input 1000 characters

[Delete]

Delete Signatures 2.

Note

Signatures 2 can only be deleted if the user belongs to a user group with
the corresponding authorization.
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2.4 Formula editor

Dialog window: Formula editor

The Formula editor serves as a support when entering formulas for calcu-
lating results. It has an automatic Syntax check, which is activated when
applying the formula. The general rules of priority apply for the calculation
operations.

The Formula Editor dialog window contains the following elements:

￭ Input field
Entry of the calculation formula (see Chapter 2.4.1, page 17).

￭ Function buttons
Buttons for the rapid entry of operators and parentheses (see Chapter
2.4.1, page 17).

￭ Operators/functions
Selection of the operators and functions variables available for the cal-
culation formula (see Chapter 2.4.4.1, page 32).

￭ Description
Description of the selected variables, operators or functions.

2.4.1 Input field
Dialog window: Formula editor

The calculation formula is entered in the input field of the Formula Editor.
The following options are available for the entry:

Entry via keyboard

￭ Numbers
Numbers as well as mathematical functions can be entered directly via
the keyboard.

￭ Text
Text must be enclosed in quotation marks " (e.g. "my text").

￭ Variables
Variables must be entered and ended with an apostrophe ' (e.g. 'MV.my
variable').

￭ time
Time indications must always be made with the aid of the Time( ) func-
tion.

Entry using the function buttons

Mathematical operators and parentheses can simply be added to the for-
mula using the corresponding buttons. A space is automatically added
before and after the sign.

Addition Equal to Logic AND
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Subtraction Greater than Logic OR

Multiplication Less than
 

Round parentheses

Division Not equal to
 

 

Potentiation Less than or equal to Molar mass calculator

  Greater than or equal to Undo last action

    Redo last action

Entry via selection

The element selected in the fields Variables or Operators can be added
to the formula by double clicking or [Insert].

2.4.2 Calculation algorithms
Dialog window: Formula editor

Numerical format

The standard IEEE 754 (1985) for binary floating point arithmetic is imple-
mented in "double precision" (64 Bit) in the software.

Rounding off process

Measured values and results are rounded off symmetrically (commercial
rounding). In so doing, 1, 2, 3, 4 are always rounded down and 5, 6, 7,
8, 9 always rounded up.

Examples

2.33 yields 2.3

2.35 yields 2.4

2.47 yields 2.5

-2.38 yields -2.4

-2.45 yields -2.5

Statistics

The mean value, absolute and relative standard deviation of results R are
calculated using the following formula:

Mean value
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Absolute standard
deviation

Relative standard devi-
ation (in %)

The statistical calculations of the software have been implemented so that
they can be checked to as great a degree as possible by the user. The indi-
vidual values are therefore incorporated in the statistics with full accuracy.

It is not the number of decimal places which is decisive for the accuracy of
the calculations, but rather the number of significant digits of the decimal
numbers displayed. The binary 64 bit numerical format implemented on the
basis of the IEEE 754 standard means that the decimal numerals resulting
from this have 15 certain significant decimal places.

You can influence the number of significant digits by selecting the unit and
the number of decimal places. As the result unit to be set sometimes contains
the prefix "Milli" as well as the actual physical unit, the number of significant
places changes accordingly by three places during such a conversion.

Example

The result displayed 1234.56789158763 mg/L has 15 certain places. It
should be rounded off to three decimal places according to the above
rounding procedure:

1234.568 mg/L (7 significant places, 3 of them decimal places)

The unit "g/L" means that the same result 1.23456789158763 g/L is also
rounded off to three decimal places:

1.235 g/L (4 significant places, 3 of them decimal places)

The number of significant digits has now been reduced by three to four digits
by omitting the prefix "milli".

Note

The above losses of accuracy by rounding off in the area of the maximum
certain places are only relevant theoretically. Most of the time they are
lower by several orders of magnitude than – as an example – the uncer-
tainties resulting from weighing out the sample.
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2.4.3 Variables

2.4.3.1 Variables - Overview  
Dialog window: Formula editor

Variables are automatically generated by the program during or at the end
of the determination. You can use the formula editor to access these and
either use the values for further calculations or output them as a result.

Variable types

The following types of variables are differentiated:

Name Syntax Description

Method vari-
ables

'MV.Variable
name'

Method variables include the varia-
bles FCT and DIV

Sample data
variables

'MV.Variable
name'

Sample data variables include the var-
iables Sample size, Unit, Sample
position, ID1 and ID2.

Command
variables

'Command
name.Variable
name'

Command variables are variables
which are generated by the individual
commands in the method run. The
command variables are displayed in
the order determined by the com-
mands executed in the method run.

Result varia-
bles

'RS.Result
name.Variable
identification'

Result variables are special command
variables which are generated by
CALC commands and which are
available under a designation of their
own.

Determina-
tion varia-
bles

'DV.Variable
identification'

Determination variables are general
variables and cannot be assigned to
individual commands.

System vari-
ables

'SV.Variable
identification'

System variables are general variables
which are adopted in the determina-
tion at the start of the determination.

Common
variables

'CV.Name' Common variables are global varia-
bles. Depending on the device, the
names are set or can be defined by
the user.

Enter variables

Variables must always be entered and ended with an apostrophe ' (e.g.
'MV.myVariable').
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Note

When using variables, always observe their data type (Number, Text or
Date/Time).

2.4.3.2 Method variables

Tab: Database ▶ Determinations ▶ Reprocessing ▶ Variables

Method variables include the variables FCT (factor) and DIV (divisor).

Syntax

'MV.Variable name'

Examples: 'MV.FCT' and 'MV.DIV'

Occurence

These two variables occur in the formula saved in the 870 KF Titrino plus.
By modifying these variables the result can be indicated as different con-
centration units (mg/mL, ppm etc.).

Method variables

Variable
name

Description Data type

FCT Conversion factor for the calculation for-
mula

Number

DIV Divisor for the calculation formula Number

Conversion table of the formula for KF titration

Result unit Sample size
in...

Factor Divisor

% g 0.1 1

% mg 100 1

% mL 0.1 Density of the
sample in g/
mL

ppm g 1000 1

ppm mL 1000 Density of the
sample in g/
mL
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ppm µ L 1 Density of the
sample in g/
mL

mg/mL g Density of the
sample in g/
mL

1

mg/mL mL 1 1

mg 1 1 1

mL 1 1 Density of H

2O in g/mL

mg/piece Pieces 1 1

2.4.3.3 Sample data variables

Dialog window: Formula editor ▶ Sample data variables

Sample data variables include the variables Sample size, Unit, Sample
position, ID1 and ID2.

In the field Variables of the formula editor all sample data variables are
listed.

Syntax

'MV.Variable name'

Examples: 'MV.Sample Size' , 'MV.Sample Unit' , 'MV.ID1'

You can select the sample data variables directly in the formula editor under
Variables ▶ Sample data variables in order to avoid syntax errors.

Sample data variables

Variable
name

(PC-Con-
trol)

Variable name

( tiBase 1.0 )

Description Data type

CI1 ID1 Sample identification 1 Number

CI2 ID2 Sample identification 2 Number

C00 Sample Size Sample size Number

 Sample Unit Sample unit Text
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Note

If the PC/LIMS report contains a negative value for the sample size (from
reweighing), it will be converted during the import into tiBase 1.0 . The
variable COO becomes Abs MV.Sample.Size in tiBase 1.0

2.4.3.4 Command variables

Dialog window: Formula Editor ▶ Variables

The command variables are method-specific. They depend on which com-
mands are used in the method. Included among the command variables are
also solution and sensor variables, which are applied automatically from the
corresponding tables in the Configuration for the device-dependent com-
mands at the time the determination is started and which are allocated to
the individual commands. The Variables field of the Formula editor lists all
Command variables which are available for the current method.

Syntax

'Command name.Variable identification'

Examples: 'DET U 3.SME' , 'Liquid Handling 4.CONC'

You can select the command variables directly in the formula editor under
Variables ▶ Command Variables in order to avoid syntax errors.

If a method run before the calculation contains more than one data gener-
ating command (titrations, measurements, calibrations, monitored dosing,
evaluations, calculations), then there is a command identification before the
variable.

M. for titration mode, measuring mode and monitored dosing

<E. for EVAL

C. for CALC

Command variables

Unless marked otherwise, all of the variables listed here in alphabetical order
are of the Number type.

Note

In the case of variables with Index {x}, the desired number 1…9 must be
entered for x (e.g. .EP{3}.ERC for the third endpoint).

If no index is specified, then the last index will be used automatically
(e.g. .EP.ERC for the last endpoint).
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Variable
name

(PC-Control)

Variable
name

( tiBase 1.0 )

Description Command

.BM# .BP{x}.MEA Measured value for the break
point x (1…9) in the unit of the
measured value

DET, MET, MEAS (without
T/Flow)

.BT# .BP{x}.TEM Temperature for the break point x
(1…9) in °C

DET, MET, MEAS (without
T/Flow)

.BD# .BP{x}.TIM Time for the break point x (1…9)
in s

DET, MET, MEAS (without
T/Flow)

.BP# .BP{x}.VOL Volume for the break point x (1…
9) in mL

DE, MET

.CONC .CONC Concentration of the solution
used for the command (number)

DET, MET, SET, KFT, STAT,
STDADD, ADD, DOS, LQH

.MCD .DBL Duration command (total dura-
tion for the processing of the
command) in s

DET, MET, SET, KFT, KFC,
STAT, MEAS, CAL MEAS,
STDADD, DOS

.MDC .DRI Current and/or last drift for drift
correction in mL/min

SET, KFT, KFC

.MSD .DSC Duration start conditions (time for
processing all start conditions) in
s

DET, MET, SET, KFT, STAT

.DDC .DTI Time for drift correction (time
from the start of the titration to
the end of the command) in s

SET, KFT, KFC

.MCM .EME End measured value (measured
value after processing of the com-
mand) in the unit of the measured
value

DET, MET, SET, KFT, KFC,
STAT, MEAS, CAL MEAS,
STDADD, DOS

.MEN .ENP Electrode zero point for the sen-
sor used for the command
(dimensionless for pH sensor or in
mV for the ISE sensor, number)
and/or electrode zero point calcu-
lated from the calibration (for
STDADD and CAL LOOP)

DET pH, DET U, MET pH,
MET U, SET pH, SET U,
STAT, MEAS pH, MEAS U,
MEAS T, MEAS Conc, CAL
LOOP, DOS, STDADD

 .EP{x}.DME Measured value differential for
the endpoint x (1…9)

MET

.EF# .EP{x}.ERC ERC for the endpoint x (1…9) DET

.EM# .EP{x}.MEA Measured value for the endpoint
x (1…9) in the unit of the meas-
ured value

DET, MET, SET, KFT, KFC
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Variable
name

(PC-Control)

Variable
name

( tiBase 1.0 )

Description Command

.ESI# .EP{x}.MEP Marking for the endpoint x (1...9);
1 = 1 endpoint, 2 = 2 or more
endpoints

DET, MET, SET, KFT

.EP# .EP.QTY Measured value (water) for the
endpoint in mg

KFC

.ET# .EP{x}.TEM Temperature for the endpoint x
(1...9) in °C

DET, MET, SET, KFT

.ED# .EP{x}.TIM Time for the endpoint x (1...9) in
s

DET, MET, SET, KFT, KFC

.EP# .EP{x}.VOL Volume for the endpoint x (1…9)
in mL

DET, MET, SET, KFT

.MCT .ETE End temperature (temperature
following processing of the com-
mand) in °C

DET, MET, SET, KFT, KFC,
STAT, MEAS (without T/
Flow), CAL MEAS, STDADD,
DOS

.MCV .EVT End volume (total dosed volume
at the end of the command) in mL

DET, MET, SET, KFT, STAT,
DOS

.FM# .FP{x}.MEA Measured value for the fixed end-
point x (1…9) in the unit of the
measured value

DET, MET, SET, KFT, STAT

 .FP{x}.QTY Measured value (water) for the
fixed endpoint x (1...9) in mg

KFC

.FT# .FP{x}.TEM Temperature for the fixed end-
point x (1…9) in °C

DET, MET, SET, KFT, STAT,
MEAS (without T/Flow)

.FD# .FP{x}.TIM Time for fixed endpoint x (1…9)
in s

DET, MET, SET, KFT, KFC,
STAT, MEAS (without T/
Flow)

.FP# .FP{x}.[VOL] Volume for the fixed endpoint x
(1...9) in mL

DET, MET, SET, KFT, STAT

.HM# .HP{x}.MEA Measured value for HNP x (1...9)

in mV 1)

DET, MET

.HT# .HP{x}.TEM Temperature for HNP x (1...9) in
°C

DET, MET

.HD# .HP{x}.TIM Time for HNP x (1...9) in s DET, MET

.HP# .HP{x}.[VOL] Volume for HNP (half neutraliza-
tion potential) x (1...9) in mL

DET, MET

#M.MIM .IME Initial measured value (measured
value before start conditions are
processed) in the unit of the
measured value (number)

DET, MET, SET, KFT, STAT,
MEAS, CAL MEAS,
STDADD, DOS
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Variable
name

(PC-Control)

Variable
name

( tiBase 1.0 )

Description Command

.MIT .ITE Initial temperature (temperature
before start conditions are pro-
cessed) in °C

DET, MET, SET, KFT, STAT,
MEAS (without T/Flow),
CAL MEAS, STDADD, DOS

.XAM .MA.MEA Maximum measured value in the
unit of the measured value

DET, MET, SET, KFT, STAT,
MEAS

.XAT .MA.TEM Temperature for the maximum
measured value in °C

DET, MET, SET, KFT, STAT,
MEAS

.XAD .MA.TIM Time for the maximum measured
value in s

DET, MET, SET, KFT, STAT,
MEAS

.XAP .MA.[VOL] Volume with maximum measured
value in mL

DET, MET, SET, KFT, STAT

 .MI.GFL Minimum gas flow rate in
mL/min

MEAS T/Flow

.XIM .MI.MEA Minimum measured value in the
unit of the measured value

DET, MET, SET, KFT, STAT,
MEAS

.XIT .MI.TEM Temperature for minimum meas-
ured value in °C

DET, MET, SET, KFT, STAT,
MEAS

.XID .MI.TIM Time for the minimum measured
value in s

DET, MET, SET, KFT, STAT,
MEAS

.XIP .MI.[VOL] Volume for minimum measured
value in mL

DET, MET, SET, KFT, STAT

.RMC .MR.MRC Correlation coefficient for mean
dosing rate for the whole range

STAT, DOS

.RMS .MR.MRS Standard deviation for mean dos-
ing rate for the whole range in
mL/min

STAT, DOS

.RM .MR.MRT Mean dosing rate for the whole
range in mL/min

STAT, DOS

.MTM .MTE Temperature measurement with
sensor; 1 = on, 0 = off)

DET, MET, SET, KFT, STAT,
MEAS (without T/Flow),
CAL MEAS, STDADD, DOS

.MMP .NMP Number of measuring points
(number of measuring points in
the measuring point list)

DET, MET, SET, KFT, KFC,
STAT, MEAS, CAL MEAS,
DOS

.RDC# .RE{x}.DRC Correlation coefficient for mean
dosing rate in window x (1…9)

STAT

.RDS# .RE{x}.DRS Standard deviation for mean dos-
ing rate in window x (1…9) in
mL/min

STAT
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Variable
name

(PC-Control)

Variable
name

( tiBase 1.0 )

Description Command

.RD# .RE{x}.[DRT] Mean dosing rate in window x
(1…9) in mL/min

STAT

.MCM .RES Result calculated from the stand-
ard addition curve (concentration
of the selected unit)

STDADD

.MSL .SLO Electrode slope of the sensor used
for the command (in % for pH
sensor or mV for ISE sensor, num-
ber) or electrode slope calculated
from the calibration (for CAL
LOOP)

DET pH, DET U, MET pH,
MET U, SET pH, SET U,
STAT, MEAS pH, MEAS U,
MEAS T, MEAS Conc, CAL
LOOP, DOS, STDADD

.MSM .SME Start measured value (measured
value after processing the start
conditions) in the unit of the
measured value

DET, MET, SET, KFT, KFC,
STAT

.MST .STE Start temperature (temperature
after processing of the start con-
ditions) in °C

DET, MET, SET, KFT, KFC,
STAT

.MTS .STY Type of stop with which the com-
mand was stopped: 1 = normal;
0 = manual or after error

DET, MET, SET, KFT, STAT,
MEAS, CAL MEAS,
STDADD, DOS

.MSA .SVA Start volume absolute (volume
that was added according to the
start condition "start volume") in
mL

DET, MET, SET, KFT, STAT

.MSP .SVM Start volume measured value (vol-
ume which was added according
to the start measured value given
in the start conditions) in mL

DET, MET

.MSS .SVS Start volume measured value (vol-
ume that was added according to
the start condition "start slope") in
mL

DET, MET

.MSV .SVT Total start volume (volume that
was added in dependence on all
three start conditions) in mL

DET, MET, SET, KFT, STAT

.TITER .TITER Titer value of the solution used for
the command (number)

DET, MET, SET, KFT, STAT,
STDADD dos, STDADD
auto, ADD, DOS, LQH

.MVA .VAR Variance of the result calculated
from the standard addition curve

STDADD

.MCV .VOL Dosed volume STDADD, ADD, LQH
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1) HNP = Half neutralization potential

2.4.3.5 Result variables

Dialog window: Formula Editor ▶ Variables

Result variables are method-specific and are defined in the CALC command
of the method. The Variables field of the Formula editor lists all Result
variables which are available for the current method.

Syntax

'RS.Result name.Variable identification'

Examples: 'RS.RS01.VAL' (='RS.RS01'), 'RS.testTime.UNI'

You can select the method variables directly in the formula editor under
Variables ▶ Result Variables in order to avoid syntax errors.

Result variables

Variable
name

(PC-Control)

Variable
name

( tiBase 1.0 )

Description Command

.R1 to .R9 [.VAL] Result value ( .VAL  optional;
number)

CALC

SSA# .ASD Absolute standard deviation for
the result (number)

CALC

SMN# .MNV Mean value of the result (number) CALC

SNR .NSR Statistics actual counter for the
result (number)

CALC

SSD .NST Statistics setpoint counter for the
result (number)

CALC

SSR# .RSD Relative standard deviation for the
result (number)

CALC

SNT .STS Statistics status for the result
(number 1 = Statistics on, 0 = Sta-
tistics off)

CALC

#C.R# unit .UNI Result unit (Text) CALC

2.4.3.6 Determination variables

Dialog window: Formula Editor ▶ Variables

Determination variables are general variables that are generated in the
method run. They are not assigned to individual commands. The Varia-
bles field of the Formula editor lists the determination variables which
are available for the current method, sorted according to name.

Syntax

'DV.Variable name'
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Examples: 'DV.DUR', 'DV.STT'

You can select the determination variables directly in the formula editor
under Variables/Determination variables in order to avoid syntax errors.

Available determination variables

Variable
name

(PC-Control)

Variable
name

( tiBase 1.0 )

Description Data
type

DD DUR Duration of the determination in s Number

 STT Time point at which the determi-
nation was started

Date/
Time

2.4.3.7 System variables

Dialog window: Formula Editor ▶ Variables

System variables are general variables which are adopted in the determina-
tion at the start of the determination. They are assigned neither to individual
commands nor to determinations. The Variables field of the Formula editor
lists all System variables which are available for the current method.

Syntax

'SV.Variable name'

Examples: 'SV.SIN', 'SV.SLI'

You can select the system variables directly in the formula editor under
Variables/System variables in order to avoid syntax errors.

Available system variables

Variable
name

(PC-Control)

Variable
name

( tiBase 1.0 )

Description Data type

%AC .ACC Autostart actual counter. Number

%AD .ACE Autostart setpoint counter. Number

%RN .RUN Sample number. Number

%SE .SEN Indication whether the end of the
sample table has been reached
(1 = yes, 0 = no).

Number

%AS .SIN Indication whether the determi-
nation has been started as a single
determination or within a series
(1 = single determination, 0 =
series determination).

Number

%SL SLI Sample table actual line. Number
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Variable
name

(PC-Control)

Variable
name

( tiBase 1.0 )

Description Data type

SNT .STA Indication whether the statistics is
activated (1 = yes, 0 = no.

Number

%SC .STC Start counter Number

%SS  Sample table status

1 = Sample table on

0 = Sample table off

Number

2.4.3.8 Common variables

Dialog window: Formula Editor ▶ Variables

Common variables are global variables, which are adopted from the corre-
sponding table of the program part Configuration, where the common
variables can be defined, at the start of the determination and assigned to
the determination. The Variables field of the Formula editor lists all Com-
mon Variables which are available for the current method, sorted accord-
ing to name.

Syntax

'CV.Variable name.Variable name'

Examples: 'CV.TestDate', 'CV.TestTime.VAL', 'CV.Average-
Temp.UNI'

You can select the common variables directly in the formula editor under
Variables/Common Variables in order to avoid syntax errors.

Available Common Variables

Variable
name

(PC-Control)

Variable
name

( tiBase 1.0 )

Description Data type

CV01...CV25 [.VAL] Value of common variables (num-
ber).

Text, number or date/time

Usage

870 KF Titrino Plus

With this instrument the two common variables, CV01 and CV02, are
defined for blind values.

877 Titrino Plus, 848 Titrino Plus, 862 Titrosampler

With these instruments there can be defined up to five method-independent
common variables, CV01 to CV05. Common variables are e.g useful for the
following applications:
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￭ Determination of a blank value which will be taken into account during
the content determination of the sample.

￭ Determination of the content of a standard solution, which will be taken
into account during the content determination of the sample.

2.4.3.9 Alphabetical command overview

￭ BRC
Coulometric bromine number determination

￭ CAL Cond
Determination of cell constants of conductivity sensors with the aid of a
known standard solution.

￭ CAL MEAS Conc
Measuring of calibration buffers for the calibration of ion-selective elec-
trodes.

￭ CAL MEAS pH
Measuring of calibration buffers for the calibration of pH sensors.

￭ DET pH
Potentiometric pH measurement with pH electrodes (measured quantity
pH).

￭ DET U
Potentiometric voltage measurement with metal electrodes (measured
quantity voltage U).

￭ DET Ipol
Voltametric measurement with selectable polarization current (measured
quantity voltage U).

￭ DET Upol
Amperometric measurement with selectable polarization voltage (meas-
ured value current I).

￭ DOS pH
Dosing of a specified volume with a solution (measured quantity pH)

￭ DOS U
Dosing of a specified volume with a solution (measured quantity voltage
U).

￭ KFC
Coulometric Karl Fischer titration with voltametric measurement.

￭ KFT Ipol
Volumetric Karl Fischer titration with voltametric measurement (selecta-
ble polarization current).

￭ KFT Upol
Volumetric Karl Fischer titration with amperometric measurement (select-
able polarization current).

￭ MEAS Conc
Concentration measurement (direct measurement).

￭ MEAS Cond
Conductivity measurement.
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￭ MEAS Ipol
Voltametric measurement with selectable polarization current

￭ MEAS pH
Potentiometric pH measurement with pH electrodes.

￭ MEAS T
Temperature measurement.

￭ MEAS U
Potentiometric voltage measurement.

￭ MEAS Upol
Amperometric measuremen with selectable polarization current.

￭ MET Ipol
Monotonic equivalence point titration with voltametric measurement
(selectable polarization current).

￭ MET pH
Monotonic equivalence point titration with potentiometric pH measure-
ment.

￭ MET U
Monotonic equivalence point titration with potentiometric voltage meas-
urement.

￭ MET Upol
Monotonic equivalence point titration with amperometric measurement
(selectable polarization voltage).

￭ SET pH
Endpoint titration with potentiometric pH measurement.

￭ SET U
Endpoint titration with potentiometric voltage measurement.

￭ SET Ipol
Endpoint titration with voltametric measurement (selectable polarization
current).

￭ SET Upol
Endpoint titration with amperometric measurement (selectable polariza-
tion voltage).

￭ STAT pH
STAT titration by keeping the measured value pH constant.

￭ STAT U
STAT titration by keeping the measured value U constant.

2.4.4 Operators/functions

2.4.4.1 Operators/functions - Overview

Dialog window: Formula editor ▶ Operators/Functions
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Overview of the operators and functions

Operators Functions

Arithmetic:

￭ Addition (+)
￭ Subtraction (-)
￭ Multiplication (*)
￭ Division (/)
￭ Potentiation (^)

Arithmetic:

￭ Exponential function (Exp)
￭ Natural logarithm (Ln)
￭ Common logarithm (Log)
￭ Square root (Sqrt)
￭ Absolute value (Abs)
￭ Fraction (Frac)
￭ Integer (Int)
￭ Round integer (Round)
￭ Sign (Sign)
￭ Quantiles of the Student's t-distribution (Tinv)

Logic:

￭ AND
￭ OR

Date/Time:

￭ Time()
￭ Time(Date)
￭ Time(Date+Time)

Comparison:

￭ Equal to (=)
￭ Greater than (>)
￭ Greater than or equal to (>=)
￭ Less than (<)
￭ Less than or equal to (<=)
￭ Not equal to (<>)

Type conversion:

￭ NumberToText
￭ NumberToTime
￭ TextToNumber
￭ TextToTime
￭ TimeToNumber
￭ TimeToText

Text:

￭ TextPosition
￭ SubText
￭ Trim

 Miscellaneous:

￭ Error
￭ Case

Priority rules of the operators

The operators are evaluated in the order in which they are listed in the table
below. In order to attain the required order, it may be necessary to place
operators in parentheses.

 Operators

Arithmetic ^

*, /

+, -

Comparison <, <=, >, >=

Logic AND, OR
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2.4.4.2 Arithmetical operators

2.4.4.2.1 Addition

Dialog window: Formula editor ▶ Operators/Functions

Syntax

Operand1 + Operand2

The operands can be entered either directly or as a variable and can be of
the type Text, Number or Date/Time.

Examples

Operand1 Operand2 Result Example Remark

both operands of the same type:

Number Number Number 1.2 + 3 = 4.2 -

Text Text Text "Metrohm" + "AG" =
"Metrohm AG"

If the maximum permissible length
(65 536 characters) of the character
string is exceeded by addition of the
operands, the surplus characters
will be removed from the second
operand.

Time Time Number Time(1998;04;06) +
Time(1964;02;03) = 59300.875 (for
UTC+1)

Result: Number of days calculated
from December 1899, dependent
on the system time

Operand of different type: The operand which does not correspond to the result type is converted to the relevant
result type before the operation.

Number Text Text 1.2 + "Metrohm" = "1.2Metrohm" -

Text Number Text "Metrohm" + 1.2 = "Metrohm1.2" -

Number Time Number 2.0 + Time(1999;11;7) = 36472.96
(for UTC+1)

Result: Number of days calculated
from December 1899, dependent
on the system time

Time Number Number Time(1999;10;7) + 2.0 = 36441.92
(for UTC+2)

Result: Number of days calculated
from December 1899, dependent
on the system time

Text Time Text "Metrohm" + Time(1999;10;7) =
"Metrohm1999-10-07 00:00:00
UTC+2"

Before the operation, the operand
of the type Date/Time is converted
to Text.

Time Text Text Time(1999;01;7) + "Metrohm" =
"1999-01-07 00:00:00 UTC
+1Metrohm"

The same rules apply here as for the
previous operation.



￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭ 2 General program functions

tiBase 1.0 ￭￭￭￭￭￭￭￭ 35

2.4.4.2.2 Subtraction

Dialog window: Formula editor ▶ Operators/Functions

Syntax

Operand1 - Operand2

The operands can be entered either directly or as a variable and can be of
the type Text, Number or Date/Time.

Examples

Operand1 Operand2 Result Example Remark

both operands of the same type:

Number Number Number 1.2 - 3 = -1.8 -

Text Text Text "Metrohm" - "AG" = invalid This operation is not allowed.

Time Time Number Time(1998;01;06) -
Time(1964;12;03) = 12'087.00 (for
UTC+1)

Result: Number of days calculated
from December 1899, dependent
on the system time

Operand of different type: The operand which does not correspond to the result type is converted to the relevant
result type before the operation.

Number Text Text 1.2 - "Metrohm" = invalid This operation is not allowed.

Text Number Text "Metrohm" - 1.2 = not valid This operation is not allowed.

Number Time Number 2.0 - Time(1999;10;7) =
-36'437.917 (for UTC+2)

Result: Number of days calculated
from December 1899, dependent
on the system time

Time Number Number Time(1999;10;7) - 2.5 =
36'437.917 (for UTC+2)

Result: Number of days calculated
from December 1899, dependent
on the system time

Text Time Text "Metrohm" - Time(1999;10;7) =
invalid

This operation is not allowed.

Time Text Text Time(1999;10;7) - "Metrohm" =
invalid

This operation is not allowed.

2.4.4.2.3 Multiplication 

Dialog window: Formula editor ▶ Operators/Functions

Syntax

Operand1 * Operand2

The operands can be entered either directly or as a variable and can be of
the type Text, Number or Date/Time.
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Examples

Operand1 Operand2 Result Example Remark

Operands of the same type:

Number Number Number 1.2 * 3 = 3.6 -

Text Text Text "Metrohm" * "AG" = invalid This operation is not allowed.

Time Time Number Time(1998;05;06) * Time(1902;02;03)
= 27'478'004.545 (for UTC+1 or +2 for
summer time)

Result: Number of days calcula-
ted from December 1899,
dependent on the system time

Operand of different type: The operand which does not correspond to the result type is converted to the relevant
result type before the operation.

Number Text Text 2 * "Metrohm" = "MetrohmMetrohm" -

Text Number Text "Metrohm" * 2 = "MetrohmMetrohm" -

Number Time Number 2.0 * Time(1999;10;7) = 72'879.833
(for UTC+2)

Result: Number of days calcula-
ted from December 1899,
dependent on the system time

Time Number Number Time(1999;10;7) * 2.0 = 72'879.833
(for UTC+2)

Result: Number of days calcula-
ted from December 1899,
dependent on the system time

Text Time Text "Metrohm" * Time(1999;10;7) = inva-
lid

This operation is not allowed.

Time Text Text Time(1999;10;7) * "Metrohm" = inva-
lid

This operation is not allowed.

2.4.4.2.4 Division

Dialog window: Formula editor ▶ Operators/Functions

Syntax

Operand1 / Operand2

The operands can be entered either directly or as a variable and can be of
the type Text, Number or Date/Time.

Examples

Operand1 Operand2 Result Example Remark

Operands of the same type:

Number Number Number 1.2 / 3 = 0.4 Operand2 must not be zero!

Text Text Text "Metrohm" / "AG" = invalid This operation is not allowed.

Time Time Number Time(1998;04;06) /
Time(1964;02;03) = 1.533 (for UTC
+1 or +2 for summer time)

Result: Number of days calculated
from December 1899, dependent
on the system time
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Operand1 Operand2 Result Example Remark

Operand of different type: The operand which does not correspond to the result type is converted to the relevant
result type before the operation.

Number Text Text 1.2 / "Metrohm" = invalid This operation is not allowed.

Text Number Text "Metrohm" / 1.2 = invalid This operation is not allowed.

Number Time Number 10'000 / Time(1999;10;7) = 274 (for
UTC+2)

Result: Number of days calculated
from December 1899, dependent
on the system time

Time Number Number Time(1999;02;17) / 10'000 = 3.621
(for UTC+1)

Result: Number of days calculated
from December 1899, dependent
on the system time

Text Time Text "Metrohm" / Time(1999;10;7) =
invalid

This operation is not allowed.

Time Text Text Time(1999;10;7) / "Metrohm" =
invalid

This operation is not allowed.

2.4.4.2.5 Potentiation

Dialog window: Formula editor ▶ Operators/Functions

Syntax

Operand1 ^ Operand2

The operands can be entered either directly or as a variable and can be of
the type Text, Number or Date/Time.

Examples

Operand1 Operand2 Result Example Remark

Operands of the same type:

Number Number Number 1.2 ^ 3 = 1.728 Complex results (which com-
prise +bi, i.e. a real and an
imaginary component) are dis-
played as an error.

Text Text Text "Metrohm" ^ "AG" = invalid This operation is not allowed.

Time Time Number Time(1900;01;05) ^ Time(1900;01;02)
= 196.371 (for UTC+1)

Result: Number of days calcu-
lated from December 1899,
dependent on the system time

Operand of different type: The operand which does not correspond to the result type is converted to the relevant
result type before the operation.

Number Text Text 1.2 ^ "Metrohm" = invalid This operation is not allowed.

Text Number Text "Metrohm" ^ 1.2 = invalid This operation is not allowed.

Number Time Number 1.2 ^ Time(1900;02;03) = 586.198 (for
UTC+1)

-
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Operand1 Operand2 Result Example Remark

Time Number Number Time(1999;10;7) ^ 2.5 =
253479847878.04 (for UTC+2)

-

Text Time Text "Metrohm" ̂  Time(1999;10;7) = invalid This operation is not allowed.

Time Text Text Time(1999;10;7) ̂  "Metrohm" = invalid This operation is not allowed.

2.4.4.3 Logical operators

2.4.4.3.1 AND

Dialog window: Formula editor ▶ Operators/Functions

Syntax

Operand1 AND Operand2

The operands can be entered either directly or as a variable and can be of
the type Text, Number or Date/Time. The result type is always a number
(1 = true, 0 = false). The following cases are possible:

Operand1 Operand2 Result

1 1 1

0 1 0

1 0 0

0 0 0

Examples

Oper-
and1

Oper-
and2

Result Example Remark

Operands of the same type:

Number Number Number 5 AND 4 --> 1

4 AND 0 --> 0

Numbers greater than 0 are interpreted as
1 (true).

Text Text Number "Metrohm" AND "AG" --> 1

"" AND "AG" --> 0

An empty character string ("") is interpre-
ted as 0 (false), everything else as 1 (true).
The first operation therefore corresponds
to 1 AND 1 --> 1.

Time Time Number Time(1999;10;07) AND
Time(1999;10;07) --> 1

Time(): see Time(Date)

Operands of a different type:
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Oper-
and1

Oper-
and2

Result Example Remark

Number Text Number 1.2 AND "1.2" --> 1

0 AND "1" --> 1

0 AND "0" --> 1

0 AND "" --> 0

Before the operation, the operand of the
type Number is converted to the type
Text, as a conversion from Text to Num-
ber is not advisable. During the second
operation, the 0 is therefore converted to
"0", which corresponds to the logical value
1 (true), as every character string that is not
empty is interpreted as 1.

Text Number Number "Metrohm" AND 1.2 --> 1 The same rules apply here as for the previ-
ous operation.

Number Time Number 2.0 AND Time(1999;10;7) --> 1

0 AND Time(1999;10;07) --> 0

Before the operation, the operand of the
type Date/Time is converted to Number
and all data from December 30, 1899 are
interpreted as 1 (true).

Time Number Number Time(1999;10;7) AND 2.5 --> 1 The same rules apply here as for the previ-
ous operation.

Text Time Number "Metrohm" AND
Time(1999;10;7) --> 1

"" AND Time(1999;10;07) --> 0

Before execution of the operation, the
operand of the type Date/Time is conver-
ted to the type Text and every character
string that is not empty is interpreted as 1
(true).

Time Text Number Time(1999;10;7) AND
"Metrohm" --> 1

The same rules apply here as for the previ-
ous operation.

2.4.4.3.2 OR

Dialog window: Formula editor ▶ Operators/Functions

Syntax

Operand1 OR Operand2

The operands can be entered either directly or as a variable and can be of
the type Text, Number or Date/Time. The result type is always a number
(1 = true, 0 = false). The following cases are possible:

Operand1 Operand2 Result

1 1 1

0 1 1

1 0 1

0 0 0

Examples

Operand1 Operand2 Result Example Remark

Operands of the same type:
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Operand1 Operand2 Result Example Remark

Number Number Number 5 OR 4 --> 1

4 OR 0 --> 1

Numbers greater than 1 are automatically
interpreted as 1 (true)

Text Text Number "Metrohm" OR "AG" --> 1

"" OR "Metrohm" --> 1

"" OR "" --> 0

An empty character string ("") is interpre-
ted as 0 (false), everything else as 1 (true).
The first operation therefore corresponds
to 1 OR 1 --> 1

Time Time Number Time(1999;10;07) OR
Time(1964;02;03) --> 1

Time(): see Time(Date)

Operand of different type: The operand which does not correspond to the result type is converted to the relevant
result type before the operation.

Number Text Number 1.2 OR "1.2" --> 1

0 OR "" --> 1

Before the operation, the operand of the
type Number is converted to the type
Text, as a conversion from Text to
Number is not advisable. During the sec-
ond operation, the 0 is therefore conver-
ted to "0", which corresponds to the
logical value 1 (true), as every character
string that is not empty is interpreted as
1.

Text Number Number "Metrohm" OR 1.2 --> 1 The same rules apply here as for the pre-
vious operation.

Number Time Number 2.0 OR Time(1999;10;7) --> 1

0 OR Time(1964;02;03) --> 1

Before the operation, the operand of the
type Date/Time is converted to Num-
ber and all data from December 30, 1899
are interpreted as 1 (true).

Time Number Number Time(1999;10;7) OR 2.5 --> 1 The same rules apply here as for the pre-
vious operation.

Text Time Number "Metrohm" OR
Time(1999;10;7) --> 1

Before execution of the operation, the
operand of the type Date/Time is con-
verted to the type Text and every char-
acter string that is not empty is interpre-
ted as 1 (true).

Time Text Number Time(1999;10;7) OR
"Metrohm" --> 1

The same rules apply here as for the pre-
vious operation.

2.4.4.4 Relational operators

2.4.4.4.1 Equal to

Dialog window: Formula editor ▶ Operators/Functions

Syntax

Operand1 = Operand2
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The operands can be entered either directly or as a variable and can be of
the type Text, Number or Date/Time. The result type is always a number
(1 = true, 0 = false).

Examples

Oper-
and1

Oper-
and2

Result Example Remark

Operands of the same type:

Number Number Number 5 = 5 --> 1

4 = 5 --> 0

-

Text Text Number "Metrohm" = "AG" --> 0

"aG" = "AG" --> 0

When making a comparison between two
texts the ASCII value of the character
sequence is compared (see Chapter 2.4.4.10,
page 65). Attention: Uppercase and low-
ercase letters have different values!

Time Time Number Time(1998;04;06) =
Time(1964;02;03) --> 0

(see Chapter 2.4.4.6.2, page 53)

Operands of a different type:

Number Text Number 1.2 = "1.2" --> 11.2 =
"Metrohm" --> 0

Before the relational operation, the Number
is converted to Text, afterwards the texts are
compared according to ASCII value (see
Chapter 2.4.4.10, page 65).

Text Number Number "Metrohm" = 1.2 --> 0 The same rules apply here as for the previous
operation.

Number Time Number 2.0 = Time(1999;10;07) --> 0 Before the operation, the operand of the type
Date/Timeis converted to Number. During
execution of the operation, the exact value is
always used after this conversion, even if max-
imum 5 places after the comma can be dis-
played (see Chapter 2.4.4.7.5, page 58).

Time Number Number Time(1999;10;7) = 2.0 --> 0 The same rules apply here as for the previous
operation.

Text Time Number "Metrohm" =
Time(1999;10;07) --> 0

Before the operation, the operand is conver-
ted from the type Date/Time to Text (here
thus: "1999-10-07 00:00:00 UTC+2"),
afterwards the texts are compared according
to ASCII value (see Chapter 2.4.4.10, page
65).

Time Text Number Time(1999;10;07) =
"Metrohm" --> 0

The same rules apply here as for the previous
operation.
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2.4.4.4.2 Greater than

Dialog window: Formula editor ▶ Operators/Functions

Syntax

Operand1 > Operand2

The operands can be entered either directly or as a variable and can be of
the type Text, Number or Date/Time. The result type is always a number
(1 = true, 0 = false).

Examples

Oper-
and1

Oper-
and2

Result Example Remark

Operands of the same type:

Number Number Number 5 > 4 --> 1

4 > 5 --> 0

-

Text Text Number "Metrohm" > "AG" --> 1

"Aarau" > "Zug" --> 0

When making a comparison between two
texts the ASCII value of the character
sequence is compared (see Chapter
2.4.4.10, page 65). Attention: Upper-
case and lowercase letters have different
values!

Time Time Number Time(1998;04;06) >
Time(1964;02;03) --> 1

(see Chapter 2.4.4.6.2, page 53)

Operands of a different type:

Number Text Number 1.2 > "Metrohm" --> 01.23 >
"1.2" --> 1

Before the relational operation, the Num-
ber is converted to Text, afterwards the
texts are compared according to ASCII
value (see Chapter 2.4.4.10, page 65).

Text Number Number "Metrohm" > 1.2 --> 1 The same rules apply here as for the previ-
ous operation.

Number Time Number 2.0 > Time(1999;10;07) --> 0 Before the comparison, the operand is con-
verted from the type Date/Time to a Num-
ber.

Time Number Number Time(1999;10;07) > 2.0 --> 1 The same rules apply here as for the previ-
ous operation.

Text Time Number "Metrohm" >
Time(1999;10;07) --> 1

Before the operation, the operand is con-
verted from the type Date/Time to Text
(here thus: "1999-10-07 00:00:00 UTC
+2"), afterwards the texts are compared
according to ASCII value (see Chapter
2.4.4.10, page 65).

Time Text Number Time(1999;10;7) >
"Metrohm" --> 0

The same rules apply here as for the previ-
ous operation.
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2.4.4.4.3 Greater than or equal to

Dialog window: Formula editor ▶ Operators/Functions

Syntax

Operand1 >= Operand2

The operands can be entered either directly or as a variable and can be of
the type Text, Number or Date/Time. The result type is always a number
(1 = true, 0 = false).

Examples

Oper-
and1

Oper-
and2

Result Example Remark

Operands of the same type:

Number Number Number 5 >= 4 --> 1

4 >= 5 --> 0

-

Text Text Number "Metrohm" >= "AG" --> 1 When making a comparison between two
texts the ASCII value of the character
sequence is compared (see Chapter
2.4.4.10, page 65). Attention: Upper-
case and lowercase letters have different
values!

Time Time Number Time(1998;04;06) >=
Time(1964;02;03) --> 1

(see Chapter 2.4.4.6.2, page 53)

Operands of a different type:

Number Text Number 1.2 >= "1.2" --> 11.2 >=
"Metrohm" --> 0

Before the relational operation, the Num-
ber is converted to Text, afterwards the
texts are compared according to ASCII
value (see Chapter 2.4.4.10, page 65).

Text Number Number "Metrohm" >= 1.2 --> 1 The same rules apply here as for the previous
operation.

Number Time Number 2.0 >= Time(1999;10;07) -->
0

Before the comparison, the operand is con-
verted from the type Date/Time to a Num-
ber.

Time Number Number Time(1999;10;07) >= 2.0 -->
1

The same rules apply here as for the previous
operation.

Text Time Number "Metrohm" >=
Time(1999;10;07) --> 1

Before the operation, the operand is con-
verted from the type Date/Time to Text
(here thus: "1999-10-07 00:00:00 UTC
+2"), afterwards the texts are compared
according to ASCII value (see Chapter
2.4.4.10, page 65).

Time Text Number Time(1999;10;7) >=
"Metrohm" --> 0

The same rules apply here as for the previous
operation.
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2.4.4.4.4 Less than 

Dialog window: Formula editor ▶ Operators/Functions

Syntax

Operand1 < Operand2

The operands can be entered either directly or as a variable and can be of
the type Text, Number or Date/Time. The result type is always a number
(1 = true, 0 = false).

Examples

Oper-
and1

Oper-
and2

Result Example Remark

Operands of the same type:

Number Number Number 5 < 4 --> 0

4 < 5 --> 1

-

Text Text Number "Metrohm" < "AG" --> 0 When making a comparison between two
texts the ASCII value of the character
sequence is compared (see Chapter
2.4.4.10, page 65). Attention: Upper-
case and lowercase letters have different
values!

Time Time Number Time(1998;04;06) <
Time(1964;02;03) --> 0

(see Chapter 2.4.4.6.2, page 53)

Operands of a different type:

Number Text Number 1.2 < "Metrohm" --> 11.2 <
"1" --> 0

Before the relational operation, the Num-
ber is converted to Text, afterwards the
texts are compared according to ASCII
value (see Chapter 2.4.4.10, page 65).

Text Number Number "Metrohm" < 1.2 --> 0 The same rules apply here as for the previous
operation.

Number Time Number 2.0 < Time(1999;10;07) --> 1 Before the comparison, the operand is con-
verted from the type Date/Time to a Num-
ber.

Time Number Number Time(1999;10;07) < 2.0 --> 0 The same rules apply here as for the previous
operation.

Text Time Number "Metrohm" <
Time(1999;10;07) --> 0

Before the operation, the operand is con-
verted from the type Date/Time to Text
(here thus: "1999-10-07 00:00:00 UTC
+2"), afterwards the texts are compared
according to ASCII value (see Chapter
2.4.4.10, page 65).

Time Text Number Time(1999;10;7) <
"Metrohm" --> 1

The same rules apply here as for the previous
operation.
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2.4.4.4.5 Less than or equal to 

Dialog window: Formula editor ▶ Operators/Functions

Syntax

Operand1 <= Operand2

The operands can be entered either directly or as variables and can be of the
type Text, Number or Date/Time. The result type is always a number (1
= true, 0 = false).

Examples

Oper-
and1

Oper-
and2

Result Example Remark

Operands of the same type:

Number Number Number 5 <= 4 --> 0

4 <= 5 --> 1

-

Text Text Number "Metrohm" <= "AG" --> 0 When making a comparison between two
texts the ASCII value of the character
sequence is compared (see Chapter
2.4.4.10, page 65). Attention: Uppercase
and lowercase letters have different values!

Time Time Number Time(1998;04;06) <=
Time(1964;02;03) --> 0

(see Chapter 2.4.4.6.2, page 53)

Operands of a different type:

Number Text Number 2 <= "1.2" --> 01.2 <=
"Metrohm" --> 1

Before the relational operation, the Num-
ber is converted to Text, afterwards the
texts are compared according to ASCII
value (see Chapter 2.4.4.10, page 65).

Text Number Number "Metrohm" <= 1.2 --> 0 The same rules apply here as for the previous
operation.

Number Time Number 2.0 <= Time(1999;10;07) -->
1

Before the comparison, the operand is con-
verted from the type Date/Time to a Num-
ber.

Time Number Number Time(1999;10;07) <= 2.0 -->
0

The same rules apply here as for the previous
operation.

Text Time Number "Metrohm" <=
Time(1999;10;07) --> 0

Before the operation, the operand is conver-
ted from the type Date/Time to Text (here
thus: "1999.10.07"), afterwards the texts
are compared according to ASCII value (see
Chapter 2.4.4.10, page 65).

Time Text Number Time(1999;10;7) <=
"Metrohm" --> 1

The same rules apply here as for the previous
operation.
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2.4.4.4.6 Not equal to 

Dialog window: Formula editor ▶ Operators/Functions

Syntax

Operand1 <> Operand2

The operands can be entered either directly or as a variable and can be of
the type Text, Number or Date/Time. The result type is always a number
(1 = true, 0 = false).

Examples

Oper-
and1

Oper-
and2

Result Example Remark

Operands of the same type:

Number Number Number 5 <> 4 --> 1

5 <> 5 --> 0

-

Text Text Number "Metrohm" <> "AG" --> 1 When making a comparison between two
texts the ASCII value of the character
sequence is compared (see Chapter
2.4.4.10, page 65). Attention: Upper-
case and lowercase letters have different
values!

Time Time Number Time(1998;04;06) <>
Time(1964;02;03) --> 1

(see Chapter 2.4.4.6.2, page 53)

Operands of a different type:

Number Text Number 1.2 <> "1.2" --> 01.2 <>
"Metrohm" --> 1

Before the relational operation, the Num-
ber is converted to Text, afterwards the
texts are compared according to ASCII
value (see Chapter 2.4.4.10, page 65).

Text Number Number "Metrohm" <> 1.2 --> 1 The same rules apply here as for the previous
operation.

Number Time Number 2.0 <> Time(1999;10;07) -->
1

Before the comparison, the operand is con-
verted from the type Date/Time to a Num-
ber.

Time Number Number Time(1999;10;07) <> 2.5 -->
1

The same rules apply here as for the previous
operation.

Text Time Number "Metrohm" <>
Time(1999;10;07) --> 1

Before the operation, the operand is con-
verted from the type Date/Time to Text
(here thus: "1999-10-07 00:00:00 UTC
+2"), afterwards the texts are compared
according to ASCII value (see Chapter
2.4.4.10, page 65).

Time Text Number Time(1999;10;7) <>
"Metrohm" --> 1

The same rules apply here as for the previous
operation.
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2.4.4.5 Arithmetical functions

2.4.4.5.1 Exponential function

Dialog window: Formula editor ▶ Operators/Functions

Syntax

y = Exp(number)

Calculates e ̂  number. Other notation for y = e(number), whereby e is the Euler
number (e = 2.71828…).

Parameters

Number 　 Exponent

The parameter can be indicated either directly as a number or as a variable
of the type Number. If the parameter does not correspond to the expected
type, it will automatically be converted to this. If this is not possible, the
result of this operation is given as invalid.

Examples

Exp(1.5) = 4.48169

Exp('CV.AverageTemp') = Power of the exponent (common variable
CV.AverageTemp) for base e

2.4.4.5.2 Natural logarithm 

Dialog window: Formula editor ▶ Operators/Functions

Syntax

y = Ln(number)

Gives the logarithm of the entered number for base e. Alternative notation
for y = loge(number), whereby e is the Euler number (e = 2.71828…).

Parameters

Number 　 > 0

The parameter can be indicated either directly as a number or as a variable
of the type Number. If the parameter does not correspond to the expected
type, it will automatically be converted to this. If this is not possible, the
result of this operation is given as invalid.

Examples

Ln(3) = 1.09861

Ln('CV.AverageTemp') = Natural logarithm of the value of the common
variable CV.AverageTemp for base e



2.4 Formula editor ￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭

48 ￭￭￭￭￭￭￭￭ tiBase 1.0

2.4.4.5.3 Common logarithm

Dialog window: Formula editor ▶ Operators/Functions

Syntax

y = Log(number)

Gives the logarithm of the entered number for base 10. Alternative notation
for y = log10(number).

Parameters

Number 　 >  0

The parameter can be indicated either directly as a number or as a variable
of the type Number. If the parameter does not correspond to the expected
type, it will automatically be converted to this. If this is not possible, the
result of this operation is given as invalid.

Examples

Log(10) = 1

Log('CV.AverageTemp') = Common logarithm of the value of the com-
mon variable CV.AverageTemp

2.4.4.5.4 Square root 

Dialog window: Formula editor ▶ Operators/Functions

Syntax

y = Sqrt(number)

Gives the square root of the entered number. Alternative notation for y =
√ number or y = 2√ number.

Parameters

Number 　 ≥  0

The parameter can be indicated either directly as a number or as a variable
of the type Number. If the parameter does not correspond to the expected
type, it will automatically be converted to this. If this is not possible, the
result of this operation is given as invalid.

Examples

Sqrt(33) = 5.745

Sqrt('CV.AverageTemp') = Square root of the value of the common var-
iable CV.AverageTemp
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2.4.4.5.5 Absolute value

Dialog window: Formula editor ▶ Operators/Functions

Syntax

y = Abs(number)

Gives the absolute value of the entered number, i.e. the value of the number
irrespective of its sign.

Parameters

Number

The parameter can be indicated either directly as a number or as a variable
of the type Number. If the parameter does not correspond to the expected
type, it will automatically be converted to this. If this is not possible, the
result of this operation is given as invalid.

Examples

Abs(-55.3) = 55.3

Abs('CV.AverageTemp') = Value of the common variables CV.Average-
Temp without signs

2.4.4.5.6 Fraction

Dialog window: Formula editor ▶ Operators/Functions

Syntax

y = Frac(number)

Gives the fraction of the entered number.

Note

In the results properties, the number Decimal places of the result must
always be given, as otherwise the fraction cannot be displayed.

Parameters

Number

The parameter can be indicated either directly as a number or as a variable
of the type Number. If the parameter does not correspond to the expected
type, it will automatically be converted to this. If this is not possible, the
result of this operation is given as invalid.

Examples

Frac(-55.325) =0.325

Frac('CV.AverageTemp') = Value of the common variable CV.Average-
Temp without sign
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2.4.4.5.7 Integer

Dialog window: Formula editor ▶ Operators/Functions

Syntax

y = Int(number)

Gives the integer of the entered number.

Parameters

Number

The parameter can be indicated either directly as a number or as a variable
of the type Number. If the parameter does not correspond to the expected
type, it will automatically be converted to this. If this is not possible, the
result of this operation is given as invalid.

Examples

Int(-55.325) = -55

Int('CV.AverageTemp') = Integer of the value of the common variable
CV.AverageTemp

2.4.4.5.8 Rounding integer 

Dialog window: Formula editor ▶ Operators/Functions

Syntax

y = Round(number)

Gives the rounded value of the entered number as a whole number.

Note

If the first decimal place is 5 or greater, the number is rounded up to the
next whole number (commercial rounding).

Parameters

Number

The parameter can be indicated either directly as a number or as a variable
of the type Number. If the parameter does not correspond to the expected
type, it will automatically be converted to this. If this is not possible, the
result of this operation is given as invalid.

Examples

Round(-55.5259) = -56

Round('CV.AverageTemp') = Rounded value of the common variable
CV.AverageTemp
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2.4.4.5.9 Sign

Dialog window: Formula editor ▶ Operators/Functions

Syntax

y = Sign(number)

Gives the sign of the entered number: 1 for a positive number, -1 for a
negative number.

Parameters

Number

The parameter can be indicated either directly as a number or as a variable
of the type Number. If the parameter does not correspond to the expected
type, it will automatically be converted to this. If this is not possible, the
result of this operation is given as invalid.

Examples

Sign(-55.3) = -1

Sign(26.115) = 1

Sign('CV.AverageTemp') = Sign of the value of the common variable
CV.AverageTemp

2.4.4.5.10 Quantiles of the Student's t-distribution

Dialog window: Formula editor ▶ Operators/Functions

Syntax

ts = Tinv(Probability; Degrees of freedom)

Calculates the quantiles of the Student's t-distribution for two-sided inter-
vals.

The result describes the half interval length as a multiple of the standard
deviation of a sampling totality with given degrees of freedom within
which, with the indicated probability, the mean value of the distribution
lies, when the interval is centered on the mean value of the sampling totality.

Parameters

Probability

Type number, value range: 0 ... 1. Direct entry as number or as formula
providing a number. If the type of value is non-permitted, then the result
will become invalid. This is to indicate the probability with which the
unknown mean value of the t-distributed result is expected to lie within the
two-sided interval.

Degrees of freedom
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Type number, value range: 1 ... n. Direct entry as number or as formula
providing a number. If the type of value is non-permitted, then the result
will become invalid. The number of independent samplings for calculating
the standard deviation, reduced by the number of adjusted parameters for
the model to which the standard deviation refers, must be specified as
degrees of freedom (Degrees of freedom = Number of samplings − Number
of parameters).

Examples

Tinv(0.95; 9) = 2.26 : With a 10-fold determination (e.g. of a titer) half
the interval length corresponds to 2.26 times the standard deviation.

Calculation of the confidence interval for a mean value of sam-
pling: A variance-homogenous sampling with a range n for a normally
distributed quantity with an expected value µ has the mean value xm, the

standard deviation s and the freedom degrees v = n − 1. Half the interval
length ts ⋅  s/√ n then indicates how high the absolute difference between

the mean value xm and the expected value µ maximally is within the given

probability. The confidence interval is the full interval length, centered to
the mean value: µ = xm ± ts ⋅ s/√ n.

Titer determination: 0.991, 1.021, 0.995, 1.003, 1.007, 0.993, 0.998,
1.015, 1.003, 0.985

Mean value = 1.001

Standard deviation = 0.0111

Student's t-quantiles for a probability of 95% = 2.26

Confidence interval of the titer = 1.001 ±  0.008

2.4.4.6 Date/time functions

2.4.4.6.1 Time()

Dialog window: Formula editor ▶ Operators/Functions

Syntax

y = Time()

Gives the current date and the current time.

Parameters

none

Return value

Current date and current time in the format yyyy-mm-dd hh:mm:ss UTC
±xx
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Note

UTC = Universal Time , from which the times in the various time zones of
the earth are derived. CET (Central European Time) is equal to UTC plus 1
hour, in the summer time UTC plus 2 hours.

2.4.4.6.2 Time(Date)  

Dialog window: Formula editor ▶ Operators/Functions

Syntax

y = Time(year; month; day)

Gives the entered figures in the format Date/Time.

Parameters

year 00…99 or 1000…9999

month 1…12

day 1…31

A parameter can be indicated either directly as a number or as a variable of
the type Number. If the parameter does not correspond to the expected
type, it will automatically be converted to this. If this is not possible, the
result of this operation is given as invalid.

Note

Only the integral part is used for all parameters.

A variable of the type Date/Time cannot be transferred as a parameter
here.

Both for the automatic and explicit conversion of a Time to the type
Number, the number of days are counted since December 30, 1899
at 01 hours.

Attention: December 30, 1899 01 hour = 0.00000 days, this number is
rounded off to 5 decimal places, but a relational operation for example
is carried out with the exact value!

Return value

Date/Time in the format yyyy-mm-dd hh:mm:ss UTC ±xx
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Note

UTC = Universal Time , from which the times in the various time zones of
the earth are derived. CET (Central European Time) is equal to UTC plus 1
hour, in the summer time UTC plus 2 hours.

Examples

Time(2004;02;02) = 2004-02-02 00:00:00 UTC +1 (dependent on the
system time)

Time('CV.Test year';'CV.Test month';'CV.Test day') = Date comprised
of the common variables

2.4.4.6.3 Time(Date + Time)

Dialog window: Formula editor ▶ Operators/Functions

Syntax

y = Time(year; month; day; hour; minute; second)

Gives the entered numbers in the format Date/Time.

Parameters

year 00…99 or 1000…9999

month 1…12

day 1…31

hour 0…23

minute 0…59

second 0…59

A parameter can be indicated either directly as a number or as a variable of
the type Number. If the parameter does not correspond to the expected
type, it will automatically be converted to this. If this is not possible, the
result of this operation is given as invalid.
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Note

Only the integral part is used for all parameters.

A variable of the type Date/Time cannot be transferred as a parameter
here.

Both for the automatic and explicit conversion of a Time to the type
Number, the number of days are counted since December 30, 1899
at 01 hours.

Attention: December 30, 1899 01 hour = 0.00000 days, this number is
rounded off to 5 decimal places, but a relational operation for example
is carried out with the exact value!

Return value

Date/Time in the format yyyy-mm-dd hh:mm:ss UTC ±xx

Note

UTC = Universal Time , from which the times in the various time zones of
the earth are derived. CET (Central European Time) is equal to UTC plus 1
hour, in the summer time UTC plus 2 hours.

Examples

Time(2004;06;02;10;30;25) = 2004-06-02 10:30:25 UTC +2
(dependent on the system time)

Time('CV.TestYear';'CV.TestMonth';'CV.TestDay';'CV.Tes-
tHour';'CV.TestMin';'CV.TestSek') = Date comprised of the common
variables

2.4.4.7 Type Conversion functions

2.4.4.7.1 NumberToText

Dialog window: Formula editor ▶ Operators/Functions

Syntax

y = NumberToText(numberl)

Gives the entered number as Text.

Parameters

Number

The parameter can be indicated either directly as a number or as a variable
of the type Number.
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Examples

NumberToText(-55.3) = -55.3

NumberToText('CV.AverageTemp') = Vale of the common variable
(AverageTemp) als Text

2.4.4.7.2 NumberToTime

Dialog window: Formula editor ▶ Operators/Functions

Syntax

y = NumberToTime(number)

Gives the entered number as Date/Time, whereby the number is interpre-
ted as the number of days since December 30, 1899 at 01 hours.

Parameters

Number

The parameter can be indicated either directly as a number or as a variable
of the type Number.

Examples

NumberToTime(35545.526) = 1997-05-25 14:37:26 UTC+2
(dependent on the system time)

NumberToTime(35780.55) = 1997-12-16 14:12:00 UTC+1 (Number-
ToTime(35545.526) = 1997-05-25 14:37:26 UTC+2 (dependent on the
system time)

NumberToTime('CV.TestDate') = Value of the common variable (Test-
Date) as Date/Time

2.4.4.7.3 TextToNumber

Dialog window: Formula editor ▶ Operators/Functions

Syntax

y = TextToNumber(Text)

Gives the entered text as a number.

Parameters

Text

The parameter may only contain numerical characters or variables of the
type Text, as otherwise a type conversion is not possible. The result of this
conversion or the calculation would then be invalid. In addition, text must
be marked by inverted commas.

Examples

TextToNumber("-55.3") = -55.3
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TextToNumber('CV.DurchschnTemp') = Value of the variables (Avera-
geTemp) as Number

TextToNumber('MV.ID1') = entered text of ID 1 as Number

2.4.4.7.4 TextToTime 

Dialog window: Formula editor ▶ Operators/Functions

Syntax

y = TextToTime(Text;Format)

Gives the entered text as a Date/Time.

Parameters

Text

The parameter may only contain numerical characters or variables of the
type Text, as otherwise a type conversion is not possible (Result = inva-
lid). As a delimiter betwen Year, Month etc. you can use the following
characters: slash (/), full stop (.), minus (-), semi-colon (;), colon (:), space and
comma. You can determine the order of the individual data yourself, but
must indicate this in the Format parameter.

Format

Indicates in which format or order the text has been entered. This parameter
must be marked by inverted commas and can comprise the following code
characters:

Characters Significance

y Year

M Month

d Day

H Hour 0…23

h Hour AM/PM

m Minute

s Second

a AM/PM marking

Note

If you indicate the time in the format AM/PM, it is necessary in addition
to the formatting character h to use the AM/PM marking a (see first
example below).
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Examples

TextToTime("2004-12-3 5:22:01 PM";"yMdhmsa") = 2004-12-03
17:22:01 UTC+1 (dependent on the system time)

TextToTime("12-15-01 2001:3:5";"HmsyMd") = 2001-03-05
12:15:01 UTC+1 (dependent on the system time)

TextToTime('CV.TestDate';'CV.TestFormat') = Values of the common
variables in the time format indicated

TextToTime('MV.ID1';'CV.TestFormat') = entered text of ID1 in the
time format indicated

2.4.4.7.5 TimeToNumber

Dialog window: Formula editor ▶ Operators/Functions

Syntax

y = TimeToNumber(Time)

Gives the entered number as a Number.

Note

Both for the automatic and explicit conversion of a Time to the type
Number the number of days are counted since December 30, 1899
at 01 hours.

Attention: December 30, 1899 01 hours = 0.00000 days, this number
is rounded off to 5 decimal places, but a relational operation for example
is carried out with the exact value.

Parameters

Time

This parameter can be indicated either in the form of a time function or as
a variable of the type Time.

Examples

TimeToNumber(Time()) = current date and current time represented as
Number (in days since December 1899)

TimeToNumber(Time(1999;12;31;23;59;59)) = 36525.95832

TimeToNumber(Time('TestYear';'TestMonth';'TestTag')) = Value of
the common variables as number of days as a Number
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2.4.4.7.6 TimeToText

Dialog window: Formula editor ▶ Operators/Functions

Syntax

y = TimeToText(Time)

Gives the time entered as Text.

y = TimeToText(Time;Format)

Gives the time entered as Text in the required format.

Parameters

Time

This parameter can be indicated either in the form of a time function or as
a variable of the type Date/Time.

Format

Indicates in which format or order the time is to be output as text. This
parameter can comprise the following code characters and must be marked
by inverted commas:

Characters Significance Example

y two-digit year number 03

yyyy four-digit year number 1999

M one or two-digit month number 4, 12

MM two-digit month number 04, 12

MMM Month name short form Jul, Aug

MMMM Month name July, August

d one or two-digit day number 2, 25

dd two-digit day number 02, 25

h one-digit or two-digit hour number
(1…12 AM/PM)

5, 11

hh two-digit hour number (1…12 AM/
PM)

05, 11

H one-digit or two-digit hour number
(0…23)

8, 17

HH two-digit hour number (0…23) 08, 17

m one or two-digit minute number 2, 25

mm two-digit minute number 02, 25

s one or two-digit second number 3, 55

ss two-digit second number 03, 55
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Characters Significance Example

E Weekday short form Mon, Tue, Wed

EEEE Weekday Monday, Tuesday

D one, two or three-digit number of the
day in the year

2, 35, 142

DD two or three-digit number of the day
in the year

02, 35, 142

DDD three-digit number of the day in the
year

002, 035, 142

F one-digit number of the weekday in
the month, e.g. the 2nd Monday in
May

2

w one or two-digit number of the week
in the year

5, 25

ww two-digit number of the week in the
year

05, 25

W one-digit number of the week in the
month

3

a Format AM/PM AM, PM

' Inverted commas for entering any text  

'' Entry of ' '

Note

If you wish to indicate the time in the format AM/PM, it is necessary in
addition to the formatting character h to use the AM/PM marking a (see
last example below).

Examples

TimeToText(Time()) = current date and current time (system) as Text

TimeToText(Time(2004;05;04)) = 2004-05-04 00:00:00 UTC+2
(dependent on the system time)

TimeToText('CV.TestZeit') = Value of the common variable (type Time)
as Text

TimeToText(Time(2000;12;31);"EEEE', 'dd'.'MMMM' 'yyyy") = Sun-
day, December 31, 2000

TimeToText(Time(1997;05;22);"M'/'d'/'yyyy', 'ha") = 5/22/1997,
12PM
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2.4.4.8 Text functions

2.4.4.8.1 TextPosition

Dialog window: Formula editor ▶ Operators/Functions

Syntax

y = TextPosition(Text ; sample text)

Gives the Index which indicates at which point the sample text appears
for the first time in the Text. The numbering of the index begins at 1!

Parameters

Text

The parameter can be indicated either directly or as a variable of the type
Text, Number or Date/Time.

Sample text

The parameter can be indicated either directly or as a variable of the type
Text, Number or Date/Time. If the types of the two parameters do not
coincide, the type is converted from Sample text to the type Text. If the
Sample text is not included in the Text, the status invalid is given.

Note

Entries of the type Number are always provided with a decimal place.

Example: TexPosition("12345";3) = invalid, as the 3 is converted to
3.0 before the operation in 3.0 and this is not included in the text.

Examples

TextPosition("Citric acid";"acid") = 9, the word "acid" occurs in the text
from index number 9 onwards

TextPosition("Citric acid";"Acid") = invalid, the word "Acid" (capital-
ized) does not occur in the text

TextPosition("Citirc acid";"salt") = invalid, the word "salt" does not
occur in the text

TextPosition(Time(2004;05;05);"5") = 7

TextPosition(3362.14;"6") = 3

TextPosition('MV.ID2';"Carbonate") = Index in which the word part
"Carbonate" begins for the first time in the ID2
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2.4.4.8.2 SubText

Dialog window: Formula editor ▶ Operators/Functions

Syntax

y = SubText(Text ; Position ; Length)

Gives that part of the text from Text which begins at the index Position
and which has the length Length.

Parameters

Text

The parameter can be indicated either directly as text or as a variable of the
type Text. If the parameter does not correspond to the expected type, it
will automatically be converted to this. If this type conversion is not possible,
the result of this operation is given as invalid.

Position

The numbering of the Position begins at 1. The parameter can be indicated
either directly as a number or as a variable of the type Number. If the
parameter does not correspond to the expected type, it will automatically
be converted to this. If a type conversion is not possible or the position does
not exist, the result of this operation is given as invalid.

Length

The parameter can be indicated either directly as a number or as a variable
of the type Number. If the parameter does not correspond to the expected
type, it will automatically be converted to this. It a type conversion is not
possible or the length indicated here is greater than the length of the subtext,
invalid is given

Examples

SubText("Citric acid";9;5) = acid

SubText("Citric acid";9;6) = invalid, only five characters exist from posi-
tion 9 onwards

SubText('MV.ID2';1;3) = the first three chracters of the identification 2

2.4.4.8.3 Trim

Dialog window: Formula editor ▶ Operators/Functions

Syntax

y = Trim(Text)

Gives the Text without spaces before and after.

y = Trim(Text ; sample text)

Gives the Text without Sample text.
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Parameters

Text

The parameter can be indicated either directly or as a variable of the type
Text, Number or Date/Time.

Sample text

The parameter can be indicated either directly or as a variable of the type
Text, Number or Date/Time. If the types of the two parameters do not
coincide, the type is converted from Sample text to the type Text.

Note

Entries of the type Number are always provided with a decimal place.

Example: Trim("12345";3) = 12345, as the 3 is converted to 3.0 before
the operation and this is not included in the text.

Examples

Trim(" Citric acid ") = "Citric acid"

Trim("Citric acid";"acid") = Lemons

Trim("Citric acid";"salt") = Citric acid

2.4.4.9 Miscellaneous functions

2.4.4.9.1 Case

Dialog window: Formula editor ▶ Operators/Functions

Syntax

y = Case(Condition ; value_true ; value_false)

y = Case(Condition ; value_true ; value_false ; value_error)

Gives value_true if the condition is true. Otherwise value_false is given.
If an error occurs in the condition (result invalid), value_error is given.

Parameters

Condition 　 Number

Any variable (type Number) can be entered here, or a relational or logic
operation can be performed whose operators can be transferred either
directly or as a variable. These can be of the type Text, Number or Date/
Time.

Value_true

If condition <> 0, this parameter is saved as a result of the function. This
parameter can be transferred either directly or as a variable and can be of
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the type Text, Number or Date/Time. Entire operations can also be trans-
ferred here.

Value_false

If condition = 0, this parameter is saved as a result of the function. This
parameter can be transferred either directly or as a variable and can be of
the type Text, Number or Date/Time. Entire operations can also be trans-
ferred here.

Value_error

If condition = invalid, this parameter is saved as a result of the function.
This parameter can be transferred either directly or as a variable and can be
of the type Text, Number or Date/Time. Entire operations can also be
transferred here.

Examples

Case('MV.ID1' = "";"ID1 empty";"ID1 not empty") = if no entry has
been made for ID1 in the run window, the text ID1 empty, otherwise ID1
not emptywill be saved in the result.

Case('RS.IntermediateRes' > 5.5;"Intermediate result too
high";'RS.IntermediateRes' * 26.5;"Error occurred") = If the result
"IntermediateRes" is greater than 5.5, the text "Intermediate result too
high" will be written into the result, otherwise the intermediate result will
be multiplied by 26.5. If an error occurs during the comparison ('RS.Inter-
mediateRes' > 5.5), "Error occurred" will be saved as a result of this
operation.

2.4.4.9.2 Error

Dialog window: Formula editor ▶ Operators/Functions

Syntax

y = Error(value)

Gives +1 if the value is invalid (error) or 0 if the valie is valid. This function
can be used e.g. to check variables for their existence or validity.

Parameters

Value

The variable to be tested.

Examples

Error('RS.IntermediateRes') = 0: the intermediate result was able to be
calculated.

Error('RS.ZwischenRes') = 1: the intermediate result is invalid.
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2.4.4.10 ASCII table
Dialog window: Formula editor

Only characters that can be printed are listed in the table below:

ASCII value

(dec)

Characters ASCII value

(dec)

Characters ASCII value

(dec)

Characters

32 Space 64 At sign (@) 96 Accent grave (`)

33 Exclamation
mark (!)

65 A 97 a

34 Quotation mark
(")

66 B 98 b

35 Hash mark (#) 67 C 99 c

36 Dollar ($) 68 D 100 d

37 Percent (%) 69 E 101 e

38 Commercial
"and" (&)

70 F 102 f

39 Inverted comma
(')

71 G 103 g

40 Opening paren-
theses (()

72 H 104 h

41 Closing paren-
theses ())

73 I 105 i

42 Multiplication
sign (*)

74 J 106 j

43 Addition sign (+) 75 K 107 k

44 Apostrophe (´) 76 L 108 l

45 Subtraction sign
(-)

77 M 109 m

46 Point (.) 78 N 110 n

47 Slash mark (/) 79 O 111 o

48 0 80 P 112 p

49 1 81 Q 113 q

50 2 82 R 114 r

51 3 83 S 115 s

52 4 84 T 116 t

53 5 85 U 117 u

54 6 86 V 118 v



2.4 Formula editor ￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭

66 ￭￭￭￭￭￭￭￭ tiBase 1.0

ASCII value

(dec)

Characters ASCII value

(dec)

Characters ASCII value

(dec)

Characters

55 7 87 W 119 w

56 8 88 X 120 x

57 9 89 Y 121 y

58 Colon (:) 90 Z 122 z

59 Semi-colon (;) 91 Square paren-
theses ([)

123 Curly parenthe-
ses ({)

60 Less than (<) 92 Backslash (\) 124 Vertical stroke (¦)

61 Equals (=) 93 Square paren-
theses (])

125 Curly parenthe-
ses (})

62 Greater than (>) 94 Circumflex (^) 126 Tilde (~)

63 Question mark
(?)

95 Underscore (_)   

2.4.5 Molar mass calculator
Dialog window: Molar mass calculator

The dialog window molar mass calculator is used for the simple entry of

molar masses into the formula editor and is opened with the button .

Mode of operation

The molecular formula of any chemical compound can be entered in the
Molecular formula field, after which pressing [OK] will cause the molar
mass of the compound to be calculated and entered directly into the formula
editor.

The molecular formula can be entered either directly or by clicking on the
symbols of the periodic system.

Examples

Molecular for-
mula

Molar mass

H2SO4 98.0734

Ca(OH)2 74.09268

AlCl3*6H2O 238.43174
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2.5 Editing

2.5.1 Select date
Dialog window: Select date

The dialog window Select date serves for entering a date in a field and is

opened with the button .

Selects the month

Selects the year

Selects the day

Selected date

2.5.2 Text editor
Dialog window: Text editor

The text editor serves for entering formatted text in text fields and is opened

with the button .

The toolbar of the text editor includes the following functions:

Cut selected text and copy it to the clipboard.

Copy selected text to the clipboard.

Paste text from the clipboard.

Open editor for entering a hyperlink (see Chapter 2.5.3, page 68).
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Open formula editor for entering calculation formulas .(see Chapter 2.4,
page 17)

Note

In order for results of formulas of the type Date to be output correctly,
they must be converted for text windows with the function TimeTo-
Text(see Chapter 2.4.4.7.6, page 59) to Text.

Font size in pt.

Select font color.

Bold.

Italic.

Underlined.

Left-justified.

Centered.

Right-justified.

2.5.3 Hyperlink
Dialog window: Hyperlink

The dialog window Hyperlink serves for entering a hyperlink in a field and

is opened with the button .

Displayed text

Designation of the hyperlink that is displayed.
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Link target

Address of the link target to which the hyperlink refers (Web site, E-mail
address, file,...).

The button opens a selection dialog in order to link a file as a link target.
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3 Configuration

3.1 Configuration - General

3.1.1 Configuration - Definition
Program part: Configuration

Definition

In tiBase, configuration is to be understood as settings for data import,
security settings, user administration, program administration and tem-
plates.

Organization

All configuration data is saved in the configuration database. In the local
server systems (tiBase full) these are stored in the program directory of the
computer on which the program has been installed. In client/server systems
(tiBase multi) the configuration database is stored centrally on the server
and saves and contains all the configuration data of all computers (clients)
that are connected to this server.

3.1.2 Configuration - Desktop
Program part: Configuration

Configuration symbol

By clicking on on the configuration symbol in the vertical bar at the left-hand
margin the program part Configuration is opened, at the same time the
configuration symbol is shown in color.

Elements

The desktop of the program part Configuration comprises the following
elements:

￭ Configuration-specific menu bar.
￭ Configuration specific toolbar.
￭ Main window in which 2 subwindows are displayed.
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3.1.3 Configuration - Menu bar

3.1.3.1 Configuration - Main menus
Program part: Configuration

The menu bar in the program part Configuration includes the following
main menu items:

￭ File
Export, import, backup, restore configuration data.

￭ View
Switch toolbar on and off.

￭ Tools
User administration, security settings, program administration, options.

￭ Help
Open program help, display program information.

3.1.3.2 Configuration - Menu File
Program part: Configuration

Export… Exports configuration data (see Chapter 3.3.1.1, page 95).

Import… Imports configuration data (see Chapter 3.3.1.2, page 96).

Backup ▶

Automatically Backup configuration data automatically (see Chapter 3.3.2.1, page 97).

Manual Backup configuration data manually (see Chapter 3.3.2.2, page 98).

Print (PDF)... ▶

User administra-

tion Outputs user administration data as PDF file (see Chapter 3.2.1.1, page 74).

Security settings Outputs security settings as PDF file (see Chapter 3.2.2.1, page 82).

Logout... Logout user (see Chapter 2.2.3, page 10)

Exit End program.

3.1.3.3 Configuration - Menu View
Program part: Configuration

Toolbar Switch toolbar display on/off.
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3.1.3.4 Configuration - Menu Tools
Program part: Configuration

User administra-

tion…
Manages users and groups of users with access rights, signature rights and options
(see Chapter 3.2.1.1, page 74).

Security settings… Options for login, password protection, Audit Trail and electronic signature (see
Chapter 3.2.2.1, page 82).

Program administra-

tion...
General settings for local/server and client/server settings (see Chapter 3.2.3.1,
page 91).

Options… Sets program options (see Chapter 3.3.3.1, page 100).

3.1.3.5 Help Menu
Program part: Configuration / Database

tiBase Help Open tiBase help.

About Displays information about the program and the installation.

3.1.4 Configuration - Toolbar
Program part: Configuration

User administra-

tion…
Manages users and groups of users with access rights, signature rights and options
(see Chapter 3.2.1.1, page 74).

Security settings… Options for login, password protection, Audit Trail and electronic signature (see
Chapter 3.2.2.1, page 82).

Logout... Logout user (see Chapter 2.2.3, page 10).

tiBase Help Open tiBase help.

3.1.5 Configuration - Subwindows    
Program part: Configuration

Selection

The following subwindows are displayed in the main window:

￭ Import processes
Shows the details for reading-in PC/LIMS reports of different analysis
instruments in tabular form.

￭ Import protocol
Shows the log entries since the last program start.
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Presentation

The subwindows can be enlarged or made smaller to suit by dragging the
separating bar between the windows.

By clicking on the button  above at the right, the subwindows can be
maximized so that only one subwindow is displayed in the main window.
The original view of all subwindows is restored when the  button in the
maximized subwindow is clicked on again.

3.1.6 Configuration - Functions
Program part: Configuration

In the program part Configuration the following functions can be carried
out:

Views

￭ Toolbar

User administration

￭ Manage user groups
￭ Access rights
￭ Signatures
￭ Options
￭ Users

Security settings

￭ Login/Password protection
￭ Electronic signature
￭ Default reasons

Program administration

￭ Backup directories
￭ Clients
￭ Licenses

Export/Import of configuration data

￭ Export configuration data
￭ Import configuration data

Backup/Restore configuration data

￭ Backup configuration data automatically
￭ Backup configuration data manually
￭ Restore configuration data

Options

￭ General program properties
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3.1.7 View

3.1.7.1 Views - General
Program part: Configuration

Definition

The term View defines the contents and design of the main window in the
program parts Configuration and Database. In contrast to the program
part Database, the program part Configuration only has one view.

Function

￭ Toolbar
Enable or disable the toolbar.

Automatic load

At the program start the view with the following subwindows is opened:

Import processes, Import protocols

Export/Import

Views can also be exported and imported. In this way these views can be
exchanged between different client / server systems.

3.1.7.2 Toolbar

Menu item: Configuration ▶ View ▶ Toolbar

With the menu item Configuration ▶ View ▶ Toolbar the toolbar can be
enabled or disabled.

3.2 Administration

3.2.1 User administration

3.2.1.1 User administration

Dialog window: Configuration ▶ Tools ▶ User administration

Overview

User groups and their users can be managed in the dialog window User
administration. For each user group, access rights can be defined for menu
items and functions, signature rights and default views for the individual
program parts. For client/server systems, the user administration is globally
valid for all connected clients (central user administration).

During installation, the three user groups Administrators (with the user
Admin1), Users and Removed users (each without any users) are auto-
matically generated. All groups can be renamed; the Administrators group
is the only group that cannot be deleted.
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The user administration data can be exported and imported. In this way this
data can be exchanged between different client/server systems.

The user administration data can be output as PDF file using the menu item
File ▶ Print (PDF) ▶ User administration.

Structure

The dialog window User administration is divided into two parts, the size
of which can be modified with the mouse. In the left-hand part the user
groups with their assigned users are listed in tree-form, the right-hand side
shows details of the selected items.

Each user group, with the exception of the Removed users group, contains
the following items:

￭ Access rights
Assigns access rights to the four program parts and their menu bars.

￭ Signatures
Assigns signature rights for methods and determinations.

￭ Options
Defines the view for the individual program parts.

￭ Users
Details of the users.

Functions

In the dialog window User administration the following functions can be
carried out:

￭ Add user groups
￭ Copy user groups
￭ Rename user groups
￭ Delete user groups
￭ Define access rights for user groups
￭ Define signature rights for user groups
￭ Define options for user groups
￭ Add user
￭ Set start password for new user
￭ Deactivate user
￭ Activate user
￭ Remove user
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3.2.1.2 User groups

3.2.1.2.1 User groups - Details

Dialog window: Configuration ▶ Tools ▶ User administration

If a user group is selected in the left-hand side of the User administra-
tion dialog window then details of this user group will be shown on the
right-hand side together with a table containing all its members.

Group data

Group name

Shows the name of the user group.

Description

Description of the user group.

Input 256 characters

[Rename group]

Renames selected user group.

[Delete group]

Deletes selected user group.

[Copy group]

Copies selected user group.

[Add group]

Adds new user group.

User group members

The table showing the group members contains information about all mem-
bers of the selected user group. The table can neither be edited nor sorted.

User

Short name of the user.

Full name

Full name of the user.

Status

Current user status.

Selection active | inactive

active
The user can log in as usual.
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inactive
The user can no longer log in. The Administrator must first assign him/
her the status activated and provide a new Start password.

[Add user]

Adds new user to user group.

3.2.1.2.2 User administration - Access rights   

Dialog window: Configuration ▶ Tools ▶ User administration

If in the left-hand part of the dialog window User administration the item
Access rights is marked for a user group then the access rights of this group
for program parts, menu items and functions will be shown in tree-form in
the right-hand side of the window and can be modified there. If one item
is deactivated, then all the subitems belonging to it will also be automatically
deactivated. If a subitem, e.g. the menu Tools, is deactivated in the con-
figuration then the box for the configuration is colored gray. Blocked
functions are deactivated for the particular user, i.e. shown in gray.

Meaning of the symbols:

Enlarge view P Program part

Reduce view M Menu item

Full access to function(s) F Function

Limited access to function(s)   

No access to function(s)   

Note

In the Administrators group all access rights are switched on as standard
and cannot be modified.

3.2.1.2.3 User administration - Signatures      

Dialog window: Configuration ▶ Tools ▶ User administration

If in the left-hand part of the dialog window User administration the item
Signatures is marked for a user group, then the rights of this group will be
shown in the right-hand part and can be modified there.

Permissions for determinations

Signature Level 1

If this check box is enabled then users in this user group can electronically
sign determinations at Level 1.
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Selection off | on
Default value off

Signature Level 2 (lock)

If this check box is enabled then users in this user group can electronically
sign determinations at Level 2 and at the same time lock them against further
modifications.

Selection off | on
Default value off

Delete signatures Level 2

If this check box is enabled then users in this user group can delete all sig-
natures at Level 2. The method can be edited again.

Selection off | on
Default value off

3.2.1.2.4 User administration - Options    

Dialog window: Configuration ▶ Tools ▶ User administration

If in the left-hand part of the dialog window User administration the item
Options is marked for a user group then options for this group will be shown
in the right-hand part and can be modified there.

Default database view

Selection of the view that will open in the program part Database as stand-
ard when the user logs in.

Selection Selection of the defined database views

Default configuration view

Selection of the view that will open in the program part Configuration as
standard when the user logs in.

Selection Selection of the defined configuration views

3.2.1.2.5 Add user group

Dialog window: Configuration ▶ Tools ▶ User administration ▶ [Add group] ▶ Add
group

In order to add a new user group with standard settings an existing group
must be selected and either the context-sensitive menu item Add group
then opened or the [Add group] button must be pressed. This opens the
dialog window Add group.

Group name

Name of new group.
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Input 24 characters

With [OK] a new group is generated under this name with standard settings;
it does not contain any users. The Description field and the table of group
members are empty.

3.2.1.2.6 Copy user group

Dialog window: Configuration ▶ Tools ▶ User administration ▶ [Copy group] ▶ Copy
group

Dialog window:

In order to copy a user group and save it under a new name, an existing
group must be selected and either the context-sensitive menu item Copy
group or the [Copy group] button must be pressed. This opens the dialog
window Copy group.

Group name

Name of new group.

Input 24 characters

With [OK] a new group is generated under this name with same properties
(access rights, signature rights, etc.) as the selected group; it does not con-
tain any users. The Description field and the table of group members are
empty.

3.2.1.2.7 Rename user group

Dialog window: Configuration ▶ Tools ▶ User administration ▶ [Rename

group] ▶ Rename group

In order to rename a selected user group either the context-sensitive menu
item Rename group or the [Rename group] button must be pressed. This
opens the dialog window Rename group.

Group name

Enter the new group name.

Input 24 characters

3.2.1.2.8 Delete user group

Function: Configuration ▶ Tools ▶ User administration ▶ [Delete group]

In order to delete a selected user group either the context-sensitive menu
item Delete group or the [Delete group] button must be pressed. The
group is then deleted.
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Note

It is only possible to delete a user group when the group no longer con-
tains any users.

3.2.1.3 User

3.2.1.3.1 User - Details     

Dialog window: Configuration ▶ Tools ▶ User administration

If in the left-hand side of the dialog window User administration a user
in a user group has been selected, then details of the user will be shown at
the right-hand side.

User

Shows the short name of the user that must be entered in the field User.
This name is defined when a new user is entered for the first time and cannot
be subsequently modified.

Input 24 characters

Full name

Full name of the user.

Input 256 characters

Status

Shows the current status of the user. Only users of the group Administra-
tors can modify the status.

Selection active | inactive | removed

active
Users with the status enabled can log in in the usual way. An exception
is the first login after a change in status from disabled or removed to
enabled. In this case a Start password must be issued with which this
user can then log in.

inactive
Users with the status disabled can no longer log in. They are automat-
ically given this status as soon as the number of incorrect login attempts
defined in the Security settings has been exceeded.
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removed
Users with the status removed can no longer log in. If the status of a
user is changed from activated or deactivated to removed, then the
user is automatically moved to the group Removed users. If a removed
user is subsequently again given the status activated or deactivated
then a dialog window appears for selecting the group to which the user
is to be assigned.

Start password

The invisible start password is shown with 6 * characters and must be
entered the first time that a new user logs in or after a change in status from
deactivated or removed to activated. The Administrator must issue a
new start password when adding a new user or after a change in status to
activated. If the user has logged in with the start password and then
entered a new password, then the start password is deleted again.

Input 50 characters

[Set start password]

Opens the dialog window Start password. This button is enabled only for
users with the status activated. If a user has forgotten his/her password
then the Administrator can issue a new start password here.

User group

Current user group. The administrator can modify the group assignment of
the user. The user is automatically moved to the new group. A user can also
be moved to a new group with Drag&Drop.

Selection Selection of the defined user group

Remarks

Optional entry of additional information for the user (e.g. function, address).

Input 1000 characters

3.2.1.3.2 Add user

Dialog window: Configuration ▶ Tools ▶ User administration ▶ [Add user] ▶ Add
user

There are two ways of adding a new user:

￭ Select user group and the context-sensitive menu item Add user.
￭ Select user group and press the [Add user] button.

In both cases this opens the dialog windowAdd user.
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User

Short name of new user that must be used to log in at program start. After
the name has been entered a Start password must be issued with which
the user is entered in the list of users.

Input 24 characters

3.2.1.3.3 Set start password

Dialog window: Configuration ▶ Tools ▶ User administration ▶ [Set start pass-

word] ▶ Set start password

Using the [Set start password] button in the dialog window User admin-
istration a start password can be issued for the selected user. It is enabled
only for newly added users or for those who have once again achieved
activated status. The dialog window Start password opens:

Start password

Enter a new start password. Password options are not used for the start
password.

Input 50 characters

Confirm password

Confirms the start password.

Input 50 characters

3.2.2 Security settings

3.2.2.1 Security settings

Dialog window: Configuration ▶ Tools ▶ Security settings

Overview

In the dialog window Security settings the parameters for log-in, pass-
word protection and electronic signatures can be configured.

With client/server systems the security settings are globally valid for all con-
nected clients.

Security settings can be exported and imported. This means that these set-
tings can be exchanged between different client/server systems.

The security settings can be put out as PDF file using the menu item
File ▶ Print (PDF) ▶ Security settings.

Tabs

The security settings are configured on the following tabs:

￭ Login/Password protection
Settings for login and password protection.
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￭ Modifications
Enable/Disable comments when determinations are modified.

￭ Signatures
Options for electronic signatures.

￭ Default reasons
Definition of reasons for signing and modifying methods, determinations
and sample data.

3.2.2.2 Login/Password protection

Tab: Configuration ▶ Tools ▶ Security settings ▶ Login/Password protection

On the tab Login/Password protection is defined whether the user must
log in with his/her name or with name and password, and how the password
is to be monitored and constructed.

Settings according to 21 CFR 11

[Set]

Sets the parameters to default settings for FDA-compliant work.

Login policies

Enforce login with user name

If this check box is enabled then every time that the program starts, the
login window will appear in which the user must enter his/her user name.
If this check box is disabled no login is necessary and the user logged in
under Windows will be adopted as user name. In this case all subsequent
parameters are deactivated.

Selection on | off
Default value off

FDA default: on

Enforce login with password

If this check box is enabled then every time that the program starts, the
login window will appear in which the user has to enter a password as well
as his/her user name. If this option is disabled, then all subsequent param-
eters are deactivated.

Selection on | off
Default value off

FDA default: on

Password monitoring by tiBase

If this option is enabled then the password will be monitored by tiBase
according to the following parameters.
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Selection on | off
Default value off

FDA default: on

Password monitoring by Windows

If this option is enabled then the password will be monitored according to
the parameters defined in Windows. In this case the parameters for pass-
word protection are deactivated.

Selection on | off
Default value off

FDA default: off

Caution

When using password monitoring through Windows, to avoid an unwan-
ted login by the standard defined user Guest in Windows, this must also
either be provided with a password or (preferably) be deactivated.

Note

With Windows 2000, proceed as follows for password monitoring by
Windows:

1. Run/Execute "secpol.msc".
2. Under "Local Policies/User Rights Assignment", switch on the guide-

line "Act as part of the operating system" for all desired user groups.
3. Restart computer.

Maximum number of incorrect login attempts

If this check box is activated then a user will be given the status deacti-
vated as soon as the number of incorrect login attempts defined here has
been exceeded. A user with the status deactivated can no longer start the
program. The counter for incorrect login attempts is reset to zero for all users
at each new start.

Selection on | off
Default value off

FDA default: off

Range 2 ... 5 
Default value 3 

FDA default: 3
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Message by E-mail

If this check box is activated then an E-mail will be sent to the address
defined under [E-mail] as soon as the defined number of incorrect login
attempts has been exceeded.

Selection on | off
Default value off

FDA default: off

[E-mail]

This button opens the dialog window Send E-mail(see Chapter 3.2.2.7,
page 89) for defining the E-mail parameters.

Logout policies

New login only for same user

If this check box is activated then for manual logout a renewed login is
only possible for the same user. Users with administrator rights can always
log in. If this option is enabled then the subsequent option is automatically
enabled and deactivated.

Selection on | off
Default value off

FDA default: off

Note

If the automatic logout is enabled (see below) only the same user or a
user with administrator rights can log in again independent of these
option settings.

No editing of workplaces in 'BUSY' status

If this check box is activated then, after a user has logged out manually, a
newly logged-in user on the workplaces still open with running determina-
tions can neither edit data or trigger actions. Such workplaces will only be
available again when all determinations are finished. For running determi-
nations the old user name always applies (Audit Trail entries, Save, Export,
etc.). Exceptions are the stop of a determination with [Stop] and the emer-
gency stop, which are always possible for all running determinations and
series.

If this check box is deactivated then the newly logged-in user will have all
the rights for the opened workplaces that his/her group assignment author-
izes him/her to. For running determinations the new user name applies
immediately (Audit Trail entries, Save, Export, etc.).
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Selection on | off
Default value off

FDA default: off

Automatic logout after

If this check box is activated then the user will be logged out automatically
when no operating functions have been carried out with the keyboard or
the mouse within this time. After this automatic logout, only a member of
the same user group as the one to which the previously logged-off user
belongs or a user with administrator rights can log in again.

Selection on | off
Default value off

FDA default: off

Range 1 ... 60 min
Default value 10 min

FDA default: 10 min

Note

The immediate termination of all determinations on all activated work-
places with the emergency stop button still remains possible after an
automatic logout.

Password policies

Enforce unique password

If this check box is activated then this ensures that a user can use a given
password only once.

Selection on | off
Default value off

FDA default: on

Enforce use of special characters

If this check box is activated then this ensures that the password must
contain at least one special character (@, #, ~ etc.).

Selection on | off
Default value off

FDA default: off

Minimum password length

If this check box is activated then this ensures that the password must
contain the indicated number of characters.
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Selection on | off
Default value off

FDA default: on

Range 1 ... 10 Characters
Default value 6 Characters

FDA default: 6 characters

Validity

If this check box is activated then this ensures that the user must enter a
new password before the validity period expires. When a user logs in whose
password will expire within the next 10 days a corresponding message will
appear. If the validity period has expired, the user can only log in if he
changes the password.

Selection on | off
Default value off

FDA default: on

Range 1 ... 999 days
Default value 365 days

FDA default: 365 days

3.2.2.3 Test login for password monitoring by Windows

Tab: Configuration ▶ Tools ▶ Security settings ▶ Login/Password protection ▶ Test
login

The user's Windows password must be entered in this dialog window when
enabling the option Password monitoring by Windows(see Chapter
3.2.2.2, page 83). The test login will be used to check whether the user
name matches the Windows user name.

User

Shows the current user name.

Windows password

Entry of the Windows password.

It is only if when the test login is successful that the Password monitoring
by Windows can be used.

3.2.2.4 Modifications

Tab: Configuration ▶ Extras ▶ Security settings ▶ Modifications

On the tab Modifications it can also be defined whether a modification
reason or comment must be given on the modifications to determinations.

Recommended settings
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[Set]

Sets the parameters to the default settings.

Comment on modification of determinations

If this check box is activated then each time that a determination is modified
a modification reason and a modification comment must be entered; these
are saved in the determination and shown in the database in the subwindow
Information on the tab Determination.

Selection on | off
Default value off

3.2.2.5 Signatures

Tab: Configuration ▶ Tools ▶ Security settings ▶ Signatures

On the tab Signatures the parameters for the electronic signatures can be
configured.

Recommended settings

[Set]

Sets the parameters to the default settings.

Inactivity delay

on | off (Default value: off)

If this check box is activated then the dialog window for signing will be
automatically closed when the entered time limit has expired.

Range 1 ... 60 min
Default value 10 min

Remove password after signature

on | off (Default value: off)

If this check box is activated then the password must be entered again after
each signature.

Sign each determination separately

on | off (Default value: off)

If this check box is activated then each determination contained in the
determination overview must be signed individually.
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3.2.2.6 Default reasons 

Tab: Configuration ▶ Tools ▶ Security settings ▶ Default reasons

On the tab Default reasons the reasons are defined that have to be entered
when determinations have to be signed or when determinations have to be
modified.

Category

Selection of the category for which the reasons are to be defined.

Selection Signature Level 1 | Signature Level 2 | Modifi-
cation of determination

Default value Signature Level 1

Reasons

Shows the reasons defined for the selected category.

Input 50 characters

Moves text upward (modifies sequence).

Moves text downward (modifies sequence).

[New]

Adds a new reason.

[Edit]

Edits the selected reason.

[Delete]

Deletes the selected reason.

3.2.2.7 Sending E-mail 

Dialog window: Configuration ▶ Tools ▶ Security settings ▶ Login/Password pro-

tection ▶ [E-mail...] ▶ Send E-mail

E-mail address

E-mail address of the recipient.

Input 200 characters

Subject

Title for describing the message.

Input 200 characters
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Message

The message defined here will be transmitted as an E-mail if the maximum
permitted number of incorrect login attempts is exceeded.

The Text editor for entering or changing the message is opened with 
or by double-clicking into the text field.

Selection Text (unlimited)

Sender

E-mail address

E-Mail address of the sender.

Input 200 characters

SMTP server

Address of SMTP mail server.

Input 200 characters

Port

Port number of the SMTP mail server.

Range 1 ... 65536 
Default value 25 

Authentication

on | off (Default value: off)

Check box for activating the authentication of the sender when sending the
E-mail or selection of the authentication method.

Selection SMTP | SMTP after POP
Default value SMTP

POP server

Address of POP mail server.

Input 200 characters

Port

Port number of the POP mail server.

Range 1 ... 65536 
Default value 110 
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User

Name of the user for access to mail server. The name need not agree with
the Windows user name.

Input 200 characters

Password

Password for the access to the mail server. This password does not neces-
sarily have to be identical to the Windows password.

Input 200 characters

3.2.3 Program administration

3.2.3.1 Program administration

Dialog window: Configuration ▶ Tools ▶ Program administration

Overview

In the dialog window Program administration backup directories and
licenses can be managed.

Tabs

The parameters for program administration are defined on the following
tabs:

￭ Backup directories
List of the defined backup directories.

￭ Clients
List of computers on whichtiBase  is installed.

￭ Licenses
List of installed licenses with number of clients. This tab is only shown on
the server of a client/server installation.

3.2.3.2 Backup directories

3.2.3.2.1 Backup directories

Tab: Configuration ▶ Tools ▶ Program administration ▶ Backup directories

Table with the defined backup directories. With a click on the column title
the table can be sorted according to the selected column in either increasing
or decreasing sequence. The directory Default backup directory is gen-
erated during installation.

Note

The following buttons are activated only when tiBase  is running on the
server; they are deactivated for the individual clients.
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[New]

Adds a new backup directory (see Chapter 3.2.3.2.2, page 92).

[Edit]

Edits the selected backup directory (see Chapter 3.2.3.2.3, page 93).

[Delete]

Deletes the selected backup directory.

Note

The Default backup directory cannot be deleted.

3.2.3.2.2 Create new backup directory

Dialog window: Configuration ▶ Tools ▶ Program administration ▶ Backup direc-

tories ▶ [New] ▶ New backup directory

Name

Name for the backup directory.

Input 50 characters

Directory

Entry or selection (with ) of the path for the backup directory.

Input 1000 characters

Note

If the backup directory is on a network drive the saving date should be
added manually to the Backup name because the saving date informa-
tion is not available when the directory is restored.

Note

Make sure that you have read and write access rights on the selected
directory.
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3.2.3.2.3 Edit backup directory

Dialog window: Configuration ▶ Tools ▶ Program administration ▶ Backup direc-

tories ▶ [Edit] ▶ Edit backup directory

Name

Name for the backup directory.

Input 50 characters

Note

The Default backup directory generated during installation cannot be
renamed.

Directory

Entry or selection (with ) of the path for the backup directory.

Input 1000 characters

Note

If the backup directory is on a network drive the saving date should be
added manually to the Backup name because the saving date informa-
tion is not available when the directory is restored.

Note

Make sure that you have read and write access rights on the selected
directory.

3.2.3.3 Clients

Tab: Configuration ▶ Tools ▶ Program administration ▶ Clients

Table with information about the computers on whichtiBase  is installed.
The table cannot be edited. With a click on the column title the table can
be sorted according to the selected column in either increasing or decreasing
sequence.

Client ID

Shows the ID for the client that has been entered for the client/server instal-
lation.
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Computer name

Shows the name of the computer on which the client has been installed.

Status

Shows whether tiBase  has been started (active) or not (inactive).

Note

The contents of the tab Clients can be displayed, even if tiBase is not

running, by using the shortcut  in the directory ..\\Metrohm\
\tiBase\\bin (only available on the server).

3.2.3.4 Add licenses

Dialog window: Configuration ▶ Tools ▶ Program administration ▶ Licenses ▶ [Add
licenses]

The menu Tools ▶ Program administration ▶ Licenses ▶ [Add licen-
ses] in the program part Configuration opens the dialog window Add
licenses in which the new license code can be entered.

License code

Entry of the license code.

3.2.3.5 Licenses   

Tab: Configuration ▶ Tools ▶ Program administration ▶ Licenses

Note

In client/server systems this tab is only visible on the server and only for
members of the Administrators user group.

License code

Shows the entered license code.

Number of licenses

Shows the number of clients to have been enabled with the license code.

[Add licenses]

Adds new, additional licenses. The dialog window Add licenses opens.

License code

Entry of the license code.
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3.3 Configuration data

3.3.1 Export/Import

3.3.1.1 Export configuration data

Dialog window: Configuration ▶ File ▶ Export… ▶ Export configuration data

With File ▶ Export... the dialog window Export configuration data
opens, in which the following parts of the configuration database can be
selected for export:

 

Configuration views

on | off (Default value: on)

Exports saved configuration views (see Chapter 4.1.7, page 115).

Database views

on | off (Default value: on)

Exports saved database views (see Chapter 4.1.7, page 115).

 

Control chart templates

on | off (Default value: on)

Exports saved control card templates (see Chapter 4.4.3.1, page 169).

Curve overlay templates

on | off (Default value: on)

Exports saved curve overlay templates (see Chapter 4.4.2.1, page 164).

Export template

on | off (Default value: on)

Export the saved export template

 

Security settings

on | off (Default value: on)

Exports saved security settings (see Chapter 3.2.2.1, page 82).
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User administration

on | off (Default value: on)

Exports saved user administration (see Chapter 3.2.1.1, page 74).

 

[OK]

The dialog window Save for saving data opens, in which the name and
directory for the export file must be entered. The selected configuration data
is then saved in a file with the extension .mcfg.

3.3.1.2 Import configuration data

Dialog window: Configuration ▶ File ▶ Import… ▶ Import configuration data

With File ▶ Import... and after selection of the file *.mcfg to be imported,
the dialog window Import configuration data opens, in which the parts
of the configuration database present in the export file can be selected for
import:

Note

Data that is not present in the export file cannot be selected.

 

Configuration views

on | off (Default value: on)

Imports saved configuration views (see Chapter 4.1.7, page 115).

Database views

on | off (Default value: on)

Imports saved database views (see Chapter 4.1.7, page 115).

 

Control chart templates

on | off (Default value: on)

Imports saved control card templates (see Chapter 4.4.3.1, page 169).

Curve overlay templates

on | off (Default value: on)

Imports saved curve overlay templates (see Chapter 4.4.2.1, page 164).
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Export template

on | off (Default value: on)

Export the saved export template

 

Security settings

on | off (Default value: on)

Imports security settings (see Chapter 3.2.2.1, page 82).

User administration

on | off (Default value: on)

Imports user administration (see Chapter 3.2.1.1, page 74).

 

[OK]

The selected data is imported.

3.3.2 Backup/Restore

3.3.2.1 Backup configuration data automatically

Dialog window: Configuration ▶ File ▶ Save ▶ Automatically ▶ Backup configuration
data automatically

Automatic backup

on | off (Default value: off)

If this check box is activated then the configuration database will be backed
up automatically in the defined backup directory at the required time inter-
val. The whole configuration database is backed up.

If this check box is deactivated then the following parameters cannot be
edited.

Last backup

Shows the date and time of the last configuration data backup.

Next backup

Date and time at which the next backup is to be carried out. The  opens
the window Next backup to select the date (see Chapter 2.5.1, page
67).

Default value 　 　 　 Last backup+ 1 month
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Interval

Entry of the time interval after which an automatic backup will take place.
After each automatic or manual backup the interval entered here will be
added to the date of the Last backup and shown in the field Next
backup.

Range 1 ... 999 
Default value 1 
Selection Day(s) | Week(s) | Month(s) | Year(s)
Default value Month(s)

Backup directory

Selection of a pre-defined backup directory (see Chapter 3.2.3.2.1, page
91).

Note

Make sure that you have read and write access rights on the selected
directory.

3.3.2.2 Backup configuration data manually

Dialog window: Configuration ▶ File ▶ Save ▶ Manually ▶ Backup configuration file
manually

Backup target

Backup directory

Selection of a pre-defined backup directory (see Chapter 3.2.3.2.1, page
91).

Note

Make sure that you have read and write access rights on the selected
directory.

Backup name

Selection of an existing name for the backup file or entry of a new name. If
an existing backup file is selected it will be overwritten.

Input 50 characters
Selection Backup names
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Note

If the backup directory is on a network drive, the backup date should be
added manually to the Backup name because the backup date infor-
mation is not available when the directory is restored.

[Start]

Start manual backup of the complete configuration database.

3.3.2.3 Restore configuration data 
Dialog window: Restore configuration data

Dialog window "Restore configuration data"

Backup directory

Selection of a directory predefined in the Program administration that con-
tains the backed up configuration database.

Selection Backup directories

Backup name

Selection of a backup file.

Selection Backup files

Backup date

Shows the time at which the configuration database was backed up. If the
backup file is located on a network drive, this information is not available.

Database name

Shows the name of the configuration database. If the backup file is located
on a network drive, this information is not available.

Size

Shows the size of the configuration database in KB.

Save as

Name under which the configuration database will be restored.

[Start]

Starts the recovery of the configuration database. After the start, a progress
bar appears in the window. When the backup has been completed the dia-
log window closes automatically.
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3.3.3 Options

3.3.3.1 Options - Overview

Dialog window: Configuration ▶ Tools ▶ Options ▶ Options

Under Tools ▶ Options, general program properties can be set on the
following tabs:

￭ General
Selects dialog language.

￭ Save
Saves settings on exiting the program.

￭ PDF
Settings for PDF files.

3.3.3.2 Options - General

Tab: Configuration ▶ Tools ▶ Options ▶ Options ▶ General

Dialog language

Dialog language

Selection of the dialog language.

Selection German | English | additional languages
(dependent on installed language patches)

Default value English

Note

For the altered setting to become effective the program must be restarted.

3.3.3.3 Options - Save

Tab: Configuration ▶ Tools ▶ Options ▶ Options ▶ Save

Save on exiting

Here you can define the settings to be saved when the program is exited. If
the corresponding check box is activated, the current view with its settings
will be saved automatically when the program is exited. If the corresponding
check box is deactivated, then any modifications that may have been made
to the view will not be saved and at the next program start the original,
manually saved view will be loaded.

Configuration settings

on | off (Default value: off)

Switches Save configuration view on/off when exiting the program.
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Database settings

on | off (Default value: off)

Switches Save database view on/off when exiting the program.

3.3.3.4 Options - PDF

Tab: Configuration ▶ Tools ▶ Options ▶ Options ▶ PDF

Security permissions for PDF files

Content copying or extraction allowed

on | off (Default value: on)

If this option is switched off none of the PDF file contents can be copied
or extracted.

Printing allowed

on | off (Default value: on)

If this option is switched off the PDF file cannot be printed out.

Adding or changing comments allowed

on | off (Default value: on)

If this option is switched off comments and form fields can neither be
added nor altered.

Modifying the document allowed

on | off (Default value: on)

If this option is switched off no changes can be made to the PDF file.

3.4 Subwindow Import processes

3.4.1 Import processes - General
Subwindow: Configuration ▶ Import processes

The subwindow Import processes shows the details for reading-in PC/
LIMS reports of different analysis instruments in tabular form. It is always
shown in the program part Configuration, and cannot be removed from
the Configuration view.

The subwindow can be enlarged or made smaller to suit by dragging the
separating bar between the windows.

By clicking on the button  above at the right, the subwindow can be maxi-
mized so that only one subwindow is displayed in the main window. The
original view of two subwindows is restored when the  button is pressed
in the maximized subwindow again.
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3.4.2 Import processes - Table
Subwindow: Configuration ▶ Import processes

Table view

The table cannot be edited directly. With a click on the column title the table
can be sorted according to the selected column in either increasing or
decreasing sequence. The table view can be adapted with the left-hand
mouse button as follows:

￭ Drag the margin between column titles:
Sets the column width

￭ Double-click on the margin between column titles:
Sets the optimal column width

￭ Drag the column title:
Moves the column to the required location

If the contents of a field is larger than the column width then the whole
contents will be shown as a Tooltip if the mouse cursor is kept on the field.

Contents

The table shows the following information about reading-in PC/LIMS reports
as standard:

Name

Name for the data import process (e.g. user group, user, devices, methods,
etc.)

Data source

Source directory with PC/LIMS reports to be read-in automatically from this
directory into a database. With the symbol  the dialog window Search
opens, in which the source directory is selected and then can be entered
into the field Directory.

Database

Name of the tiBase 1.0  database, in which the read-in reports are saved.

Comment

Optional comment.

Status

Status of the import process.

Selection started | stopped | inactive

started
The import process has been started manually or automatically. The sta-
tus is displayed in green lettering.
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stopped
The import process has been stopped manually or automatically by an
error. The status is displayed in red lettering. Additionally the background
of the line number is also shown in red.

inactive
The option Start automatically is disabled for this import process. The
import process has to be started manually. The status as well as all line
entries are displayed in gray lettering.

Functions

The menu Edit beneath the table contains the following menu items:

Start import Start import for selected data source.

Stop import Stop import for selected data source.

New… Define new import process.

Delete Delete selected import process.

Properties… Edit selected import process.

3.4.3 Import processes - Properties
Dialog window: Configuration ▶ Import processes ▶ [Edit] ▶ New / Proper-

ties... ▶ Properties Import process

In this dialog window the details for the import of PC/LIMS reports are
defined.

Name

Name for the data import process (e.g. user group, user, devices, methods,
etc.)

Data source

Source directory with PC/LIMS reports to be read-in automatically from this
directory into a database. With the symbol  the dialog window Search
opens, in which the source directory is selected and then can be entered
into the field Directory.

Database

Name of the tiBase 1.0  database, in which the read-in reports are saved.

Comment

Optional comment.
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Start automatically

on | off (Default value: on)

If this check box is activated, the data import is started automatically at the
start of the program.

File options

Delete file

If this option is enabled, the reports are deleted after the data import.

Move file

If this option is enabled, the reports are saved in a selected directory after
the data import.

Directory

Directory, in which the PC/LIMS reports are saved after having been imported
to the database. With the symbol  the dialog window Search opens, in
which the directory is selected and then can be entered into the field Direc-
tory.

3.5 Subwindow Import protocol

3.5.1 Import protocol - General
Subwindow: Configuration ▶ Import protocol

The subwindow Import protocol shows information about the data
import, error messages and warnings recorded since the last program start.
It is always shown in the program part Configuration, and cannot be
removed from the Configuration view.

The subwindow can be enlarged or made smaller to suit by dragging the
separating bar between the windows.

By clicking on the button  above at the right, the subwindow can be maxi-
mized so that only one subwindow is displayed in the main window. The
original view of two subwindows is restored when the  button is pressed
in the maximized subwindow again.

3.5.2 Import protocol - Table
Subwindow: Configuration ▶ Import protocol

Table view

The table cannot be edited directly. With a click on the column title the table
can be sorted according to the selected column in either increasing or
decreasing sequence. The table view can be adapted with the left-hand
mouse button as follows:
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￭ Drag the margin between column titles:
Sets the column width

￭ Double-click on the margin between column titles:
Sets the optimal column width

￭ Drag the column title:
Moves the column to the required location

If the contents of a field is larger than the column width then the whole
contents will be shown as a Tooltip if the mouse cursor is kept on the field.

Contents

The table shows the following information about reading-in PC/LIMS reports
as standard:

Type

 information

 warning

 error

Date

Date of the log entry

Import process

Name of the corresponding import process

Data source

Directory, from which the PC/LIMS report data has been read-in.

Database

Name of the tiBase 1.0  database, in which the read-in reports are saved.

Action

Selection OK | Import | Delete | Move

OK
The PC/LIMS report has successfully been imported, moved or deleted.

Import
tiBase cannot import the selected PC/LIMS reports.

Delete
tiBase cannot delete the selected PC/LIMS reports.

Move
tiBase cannot move the selected PC/LIMS reports.
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Details

Detailed information on the log entry.

Functions

The menu Edit beneath the table contains the following menu items:

Delete all messages Delete all messages in the window Import protocol.

Options... Open the dialog window Properties Import protocol.

3.5.3 Import protocol - Properties
Dialog window: Configuration ▶ Import protocol ▶ [Edit] ▶ Options...

Filter options

Show information

on | off (Default value: off)

If this check box is activated, information on the import process is shown in
the table.

Show warnings

on | off (Default value: off)

If this check box is activated, warnings are shown in the table.

Show errors

on | off (Default value: off)

If this check box is activated, errors during the import are shown in the table.

Maximum number of log entries

In this field the maximum number of log entries to be listed in the table
Import protocol is entered.

If the number of entries exceeds the value entered, rolling recording takes
place. This means, that the oldest entry is deleted when a new log saying is
incoming.

Range 20 ... 1000 
Default value 100 

Note

If during a rolling recording an error or warning not remedied yet has
been deleted, the warning or error will be newly logged as soon as the
corresponding import process is started again.
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4 Database

4.1 Database - General

4.1.1 Database - Definition
Program part: Database

Definition

The term Database is used in tiBase  to refer to the program part in which
the determinations saved in the databases can be displayed, managed, eval-
uated, reprocessed and printed out. The determination databases are
also referred to as databases; they can, in contrast to the configuration
database, be generated by the user and contain the determination data.
Included among such determination data is the method data used for the
determination, the measuring data generated during the determination and
the results calculated from it.

Organization

In Local Server Systems (tiBase 1.0  full) the databases are stored on
the drives administered by the computer and are only available to those users
registered on that computer who have the appropriate access rights.

In Client/Server systems (tiBase 1.0  multi) the databases are stored on
drives administered centrally by the server and are available globally through-
out the entire Client/Server system, i.e. all users with the appropriate access
rights can use these databases.

4.1.2 Database - Desktop
Program part: Database

Database symbol

Clicking on the database symbol in the vertical bar on the left opens the
program part Database while, at the same time the database symbol is
shown in color. The upper left corner of the symbol contains a black field
displaying the number of databases currently opened (see Chapter 4.2.2,
page 119).
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Elements

The desktop of the program part Database comprises the following ele-
ments:

￭ Database-specific menu bar.
￭ Database-specific toolbar.
￭ Main window in which up to 6 subwindows can be displayed.

4.1.3 Database - Menu bar

4.1.3.1 Database - Main menus
Program part: Database

The menu bar in the program part Database includes the following main
menu items:

￭ File
Open and close databases, database management, printing.

￭ Edit
Copy selected lines in the determination overview onto the clipboard,
mark all lines.

￭ View
Change layout, load view, save view, modify properties in the subwind-
ows.

￭ Determinations
Search, filter, sign, delete determinations; overlay curves, calibration
curves, reprocess, etc.

￭ Tools
Report templates, further templates.

￭ Help
Open program help, display program information.

4.1.3.2 Database - Menu File
Program part: Database

Open… Open database (see Chapter 4.2.1, page 118).

Close all Close all open databases (see Chapter 4.2.6, page 120).

Exit Close database (see Chapter 4.2.6, page 120).

Database manager... Manage determination databases (see Chapter 4.3.1, page 120).

Print ▶

Determination

overview…
PDF file output of the determination overview (see Chapter 4.5.2.11, page
244).
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Report… PDF file output of the report (see Chapter 4.5.2.12, page 245).

Logout... Logout user (see Chapter 2.2.3, page 10).

Exit End program.

4.1.3.3 Database - Menu Edit
Program part: Database

Copy Copy the selected lines in the determination overview to the clipboard.

Select all Select all lines in the current set of determinations in the determination overview.

4.1.3.4 Database - Menu View
Program part: Database

Update Update determination overview.

Change layout... Modify layout of loaded database view (see Chapter 4.1.7.2, page 116).

Load view... Load a saved database view (see Chapter 4.1.7.3, page 116).

Save view... Save the loaded database view (see Chapter 4.1.7.4, page 117).

Split vertically Split database window vertically and display two databases side by side (see Chap-
ter 4.2.4, page 120).

Split horizontally Split database window horizontally and display two databases, one above the
other (see Chapter 4.2.5, page 120).

Unsplit Undo the splitting of the database window (see Chapter 4.2.3, page 120).

Properties ▶

Column display Define column display for the Determination overview table (see Chapter
4.5.1.3, page 201).

Properties

Results Set properties for the subwindow Results (see Chapter 4.7, page 260).

Toolbar Switch toolbar display on/off.
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4.1.3.5 Database - Menu Determinations
Program part: Database

Comment... Enter comment on the selected determination (see Chapter 4.5.2.2, page 206).

Search Open the window Search for searching for determinations (see Chapter
4.5.2.3, page 207).

Filter ▶

Last filter Use last quick or special filter again (see Chapter 4.5.2.4.2, page 210).

Quick filter Use quick filter with the content of the selected table cell (see Chapter 4.5.2.4.3,
page 210).

Special filter... Open the window Special filter for the definition of user-specific filters (see
Chapter 4.5.2.4.4, page 210).

All statistics

records
Display all related statistics data sets of the focused determination (see Chapter
4.5.2.4.5, page 212).

Remove filter Removes current filter (see Chapter 4.5.2.4.6, page 212).

Sign ▶

Signature 1… Sign selected determinations on level 1 (see Chapter 2.3.3, page 13).

Signature 2… Sign selected determinations on level 2 (see Chapter 2.3.4, page 14).

Show signa-

tures…
Show all signatures for the focused determination (see Chapter 4.5.2.5.4, page
218).

Delete signa-

tures 2…
Delete signatures at level 2 of the focused determination (see Chapter 2.3.5, page
16).

Send to… Send selected determinations per E-mail (see Chapter 4.5.2.7, page 242).

Export… Export selected determinations (see Chapter 4.5.2.8, page 243).

Import… Import selected determinations (see Chapter 4.5.2.9, page 243).

Show history Show all versions of the focused determination in the determination overview (see
Chapter 4.5.2.13, page 246).

Make current Make the old version selected in the history view the current version again (see
Chapter 4.5.2.14, page 246).
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Control chart… Display control chart and statistical evaluation of the selected determination (see
Chapter 4.5.2.16, page 248).

Overlay curves… Overlay curves of the selected determinations (see Chapter 4.5.2.17, page 248).

Reprocess… Reprocess selected determinations (see Chapter 4.5.2.6.1, page 220).

Delete Delete selected determinations (see Chapter 4.5.2.10, page 243).

4.1.3.6 Database - Menu Tools
Program part: Database

Report templates ▶

New ▶

Form report Open the window Report template with an empty form report (see Chapter
4.4.1.3, page 130). This menu item is disabled as long as the database is empty.

Open… Open report template to edit (see Chapter 4.4.1.3, page 130). This menu item is
disabled as long as the database is empty.

Manager… Manage report templates (see Chapter 4.4.1.1.1, page 128).

Templates ▶

Control chart

templates… Manage templates for control charts (see Chapter 4.4.3, page 169).

Curve overlay

templates… Manage curve overlay templates (see Chapter 4.4.2.1, page 164).

Export tem-

plates… Manage export templates (see Chapter 4.4.4.1, page 173).

4.1.3.7 Help Menu
Program part: Configuration / Database

tiBase Help Open tiBase help.

About Displays information about the program and the installation.



4.1 Database - General ￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭

112 ￭￭￭￭￭￭￭￭ tiBase 1.0

4.1.4 Database - Toolbar 
Program part: Database

Open… Open database (see Chapter 4.2.1, page 118).

Exit Close database (see Chapter 4.2.6, page 120).

Database manager... Manage determination databases (see Chapter 4.3.1, page 120).

Logout... Logout user (see Chapter 2.2.3, page 10).

Copy Copy the selected lines in the determination overview to the clipboard.

Update Update determination overview.

Change layout... Modify layout of loaded database view (see Chapter 4.1.7.2, page 116).

Load view... Load a saved database view (see Chapter 4.1.7.3, page 116).

Save view... Save the loaded database view (see Chapter 4.1.7.4, page 117).

Split vertically Split database window vertically and display two databases side by side (see Chap-
ter 4.2.4, page 120).

Split horizontally Split database window horizontally and display two databases, one above the
other (see Chapter 4.2.5, page 120).

Unsplit Undo the splitting of the database window (see Chapter 4.2.3, page 120).

Comment Enter comment on the selected determination (see Chapter 4.5.2.2, page 206).

Search Open the window Search for searching for determinations (see Chapter
4.5.2.3, page 207).

Filter/Last filter Use last quick or special filter again (see Chapter 4.5.2.4.2, page 210).

Filter/Quick filter Use quick filter with the content of the selected table cell (see Chapter 4.5.2.4.3,
page 210).

Filter/Special filter… Open the window Special filter for the definition of user-specific filters (see
Chapter 4.5.2.4.4, page 210).

Filter/Remove filter Removes current filter (see Chapter 4.5.2.4.6, page 212).
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Import... Import selected determinations (*.txt or *.tdet)

Sign/Signature 1…

Sign selected determinations on level 1 (see Chapter 2.3.3, page 13).

Sign/Signature 2… Sign selected determinations on level 2 (see Chapter 2.3.4, page 14).

Show history Show all versions of the focused determination in the determination overview (see
Chapter 4.5.2.13, page 246).

Make current Make the old version selected in the history view the current version again (see
Chapter 4.5.2.14, page 246).

Control chart… Display control chart and statistical evaluation of the selected determination (see
Chapter 4.5.2.16, page 248).

Overlay curves… Overlay curves of the selected determinations (see Chapter 4.5.2.17, page 248).

Reprocess… Reprocess selected determinations (see Chapter 4.5.2.6.1, page 220).

Delete Delete selected determinations (see Chapter 4.5.2.10, page 243).

Report templates/

Open… Open report template to edit (see Chapter 4.4.1.3, page 130).

tiBase Help Open tiBase help.

4.1.5 Database - Subwindows 
Program part: Database

Selection

The following subwindows can be displayed in the main window:

￭ Determination overview
Overview of the determinations saved in the database. This subwindow
is permanently on display.

￭ Information
Display of information for focused determination.

￭ Result
Display of results for focused determination.

￭ Curves 1...5
Display of curves for focused determination.
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Presentation

The subwindows can be enlarged or made smaller to suit by dragging the
separating bar between the windows.

By clicking on the button  above at the right, the subwindows can be
maximized so that only one subwindow is displayed in the main window.
The original view of all subwindows is restored when the  button in the
maximized subwindow is clicked on again.

If you change the view in the subwindows, these changes will remain in
effect after the database is closed and reopened.

4.1.6 Database - Functions
Program part: Database

In the program part Database, the following functions can be carried out:

Views

￭ Modify the layout of the database view
￭ Load database view
￭ Save database view
￭ Rename database view
￭ Delete database view

Database manager

￭ Create new database
￭ Rename database
￭ Edit database properties
￭ Save database
￭ Restore database
￭ Delete database

Determinations

￭ Overview of functions

Templates

￭ Edit report template
￭ Edit templates for control charts
￭ Edit curve overlay templates
￭ Edit export templates
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4.1.7 Views

4.1.7.1 Views - General 
Program part: Configuration / Database

Definition

The term View defines the content and design of the main window in the
program part Database (the program part Configuration has only one
view). The following elements belong to a view:

￭ Number, arrangement, sequence and size of the subwindows.
￭ Representation within the individual subwindows, i.e. column sequence,

column width, sorting and filter.

Functions

The following functions are possible for views:

￭ Change layout
Defines the number, arrangement and sequence of the subwindows for
the current view.

￭ Save view
Save current view.

￭ Load view
Load view saved.

￭ Rename view
Rename view saved.

￭ Delete view
Delete view saved.

￭ Toolbar
Enable or disable the toolbar.

Automatic save

If in the programm part Configuration under Tools ▶ Options on the
Save tab, the respective point under Save on closing is enabled, then the
current view of the program will be saved automatically.

Automatic load

The standard procedure is that the view saved when the program is termi-
nated will be loaded automatically the next time that the program is opened.
As an alternative a standard view can be defined for each user group that is
loaded automatically the first time that the program part is opened.

The standard procedure is that the view with the following subwindow is
opened with the very first program start:

￭ Configuration
Import processes, Import protocols

￭ Database
Determination overview, Curve #, Information, Results
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Export/Import

Views can also be exported and imported. In this way these views can be
exchanged between different client / server systems.

4.1.7.2 Change layout

Dialog window: Database ▶ View ▶ Change layout… ▶ Change layout

With the symbol  or the menu item View ▶ Change Layout... the dialog
window Change layout is opened.

Select layout

Selects a graphical symbol for the number, arrangement and sequence of
the subwindows.

Selection Selection of the possible combinations

Available subwindows

Displays the subwindows that are still available for displaying the view.

Selection Subwindow selection

Displayed subwindows

Displays the subwindows that are shown in the view.

Selection Subwindow

Add the selected subwindow to the view.

Remove the selected subwindow from the view.

Move the selected subwindow upward (modifies sequence).

Move the selected subwindow downward (modifies sequence).

4.1.7.3 Load view

Dialog window: Database ▶ View ▶ Load view… ▶ Load view

With the symbol  or the menu item View ▶ Load view... the dialog
window Load view is opened.

Name

Name of the view that should be loaded.
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[Rename]

Rename the selected view.

[Delete]

Delete the selected view.

[Load]

Load the selected view.

4.1.7.4 Save view

Dialog window: Database ▶ View ▶ Save view… ▶ Save view

With the symbol  or the menu item View ▶ Save view... the dialog
window Save view is opened.

Name

Name under which the view is to be saved.

[Rename]

Rename the selected view.

[Delete]

Delete the selected view.

[Save]

Saves the view under given name. The saved views are globally valid and
available for client/server systems.

4.1.7.5 Rename view

Dialog window: Database ▶ View ▶ Rename view… ▶ Rename view

To be able to rename a view, either open the dialog window Load View
or Save View and press the [Rename] button. The Rename View window
is opened.

Rename view to

Enter a new name for the view.

Input 50 characters

4.1.7.6 Delete view

Function: Database ▶ View ▶ Load/Save view… ▶ [Delete]

To be able to delete a view, either open the dialog window Load view or
Save view and press the [Delete] button. The delete procedure must then
be confirmed.
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4.2 Database display

4.2.1 Open database
Dialog window: Database ▶ File ▶ Open… ▶ Open database

The symbol  or the menu item File ▶ Open… is used to open the Open
database window, in which one of the databases available on the server
(or on the local server) that is to be opened can be selected.

Database table

The database table contains information concerning all determination data-
bases. The table cannot be edited. With a click on the column title (Columns
Name, Number of records, Size, Last backup, Next backup, Com-
ment), the table can be sorted according to the selected column in increas-
ing or decreasing sequence.

Name

Name of the database.

Number of records

Shows the number of data sets in the database.

Size

Shows the size of the database in KB.

Editable

Shows whether or not the database can be edited by the user currently
logged in.

Comment

Shows remarks about the database.

Opening the database

Database name

Name of the method to be opened. If a database is selected from the table,
the name of the database will be entered automatically in this field. It can
however also be entered manually.

Input 50 characters

[Open]

Opens the selected database and shows its data sets in the Determination
overview. The database name is displayed in the title bar of the program,
the number of currently opened databases is displayed in the left upper
corner of the database symbol.
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Note

A maximum of 4 databases can be opened, but only 2 can be displayed
at the same time. Databases that are open at the time the program is
ended will be automatically opened the next time the program is started.

4.2.2 Select database
Program part: Database

The number of the currently opened databases is displayed in the left upper
corner of the database symbol. If 2 or more databases are opened, then
these databases, which can be displayed either next to one another or one
below the other, can be selected with the aid of the database symbol.

No database is opened. No database loaded is dis-
played in the main window.

One database is opened and is displayed in the main win-
dow.

Two databases are opened. Normally only one database
is displayed in the main window but the option exists of
displaying two databases at once, either next to the
another or one below the other.

A menu with the currently opened databases
is displayed by clicking with either the left or
right mouse button on the database symbol.
The databases displayed in the main window
are marked with a checkmark. Clicking on the
desired database displays it in the main win-
dow in the place of the previously selected
one.
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4.2.3 Display single database
Menu item: Database ▶ View ▶ Unsplit

In the default settings, the most recently opened database is displayed sin-
gularly in the main window. If the display of two windows is enabled, then

the symbol  or the menu item View ▶ Unsplit can be used to switch
back to the display of just one single database.

4.2.4 Display databases next to one another
Menu item: Database ▶ View ▶ Split vertically

With the symbol  or the menu item View ▶ Split vertically two data-
bases are displayed next to one another in the main window.

4.2.5 Display databases one below the other
Menu item: Database ▶ View ▶ Split horizontally

With the symbol  or the menu item View ▶ Split horizontally two
databases can be displayed one below the other in the main window.

4.2.6 Close database
Menu items: Database ▶ File ▶ Close / Close all

Close single database

With the symbol  or the menu item File ▶ Close can be used to close the
focused database.

Close all databases

All the opened databases are closed with the menu item File ▶ Close all.

4.3 Manage databases

4.3.1 Manage databases
Dialog window: Database ▶ File ▶ Database manager… ▶ Database manager

The symbol  or the menu item File ▶ Database manager… is used to
open the window Database manager, in which one user with corre-
sponding access rights can administer databases.

Database table

The database table contains information concerning all determination data-
bases. The table cannot be edited. With a click on the column title (Columns
Name, Number of records, Size, Last backup, Next backup, Com-
ment), the table can be sorted according to the selected column in increas-
ing or decreasing sequence.
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Name

Name of the database.

Number of records

Shows the number of data sets in the database.

Size

Shows the size of the database in KB.

Last backup

Shows the date and time of the last database backup.

Next backup

Shows the date and the time at which the next backup is to be carried out.

Comment

Shows remarks about the database.

Window menus and functions

The menu [Edit] beneath the database table contains the following menu
items:

New… Create new database (see Chapter 4.3.2, page 122).

Delete Delete the selected database (see Chapter 4.3.4, page 122).

Rename… Rename the selected database (see Chapter 4.3.3, page 122).

[Properties]

Opens the window Database manager for editing the database selected
in the table (see Chapter 4.3.5.1, page 123).

[Backup]

Opens the window Backup the database for backing up the database
selected in the table (see Chapter 4.3.6, page 126).

[Restore:]

Opens the window Restoration of databases for restoring backed-up
databases (see Chapter 4.3.7, page 127).

[Exit]

Closes the window Database manager.
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4.3.2 Create new database
Dialog window: Database ▶ File ▶ Database manager… ▶ Database man-

ager ▶ [Edit] ▶ New... ▶ New database

The menu item [Edit] ▶ New... can be used to open the window New
database, in which a name for the new database must be entered.

Name

Name of the new database.

Input 50 characters
Default value New database #

Note

The database name must be unambiguous in the whole Client/Server sys-
tem.

Clicking on [OK] will open the window Database properties for editing
the database properties.

4.3.3 Rename database
Dialog window: Database ▶ File ▶ Database manager… ▶ Database man-

ager ▶ [Edit] ▶ Rename... ▶ Rename database

The menu item [Edit] ▶ Rename... is used to open the window Rename
database for renaming the selected database.

Rename database 'Name' to

Entry of the new database name.

Input 50 characters

Note

The database name must be unambiguous in the whole Client/Server sys-
tem.

4.3.4 Delete database
Menu item: Database ▶ File ▶ Database manager… ▶ Database man-

ager ▶ [Edit] ▶ Delete

The menu item [Edit] ▶ Delete is used to delete the selected database.
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Note

Databases that are open cannot be deleted.

4.3.5 Database properties

4.3.5.1 Database properties - Overview

Dialog window: Database ▶ File ▶ Database manager... ▶ Database man-

ager ▶ [Properties] ▶ Properties - Database - 'Database name'

The properties for a database are set on the following tabs:

￭ General
General information about the database.

￭ Access rights
Access rights to the database for user groups.

￭ Backup
Definition of backup monitoring and automatic backups.

￭ Monitoring
Defines database monitoring.

4.3.5.2 Database properties - General

Tab: Database ▶ File ▶ Database manager... ▶ Database manager ▶ [Proper-

ties] ▶ Properties - Database - 'Database name' ▶ General

General information about the database.

Comment

Freely definable remarks about the database.

Input 250 characters

Number of records

Shows the number of data sets in the database.

Size

Shows the size of the database in KB.

Created

Shows the date and time of the creation of the database.

Created by

Full name of the user who created the database.

Modified

Shows the date and time of the last modification of the database properties.
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Modified by

Shows the name of the user (abbreviation) who carried out the modifica-
tions.

4.3.5.3 Database properties - Access rights

Tab: Database ▶ File ▶ Database manager... ▶ Database manager ▶ [Edit] ▶ Prop-

erties - Database -'Database name' ▶ Access rights

Access rights to the database for user groups.

User group

Shows the user groups defined in the user manager.

Read

on | off (Default value: on)

Enables/disables the right to open the database. The database can only be
displayed, but not modified (records cannot be deleted or reprocessed).

Edit

on | off (Default value: off)

Enables/disables the right to edit the database. Records can be revised or
deleted.

Note

If access for editing is enabled, then access rights for reading will also
automatically be enabled. If access for editing is disabled, then access
rights for reading will also automatically be disabled.

4.3.5.4 Database properties - Backup

Tab: Database ▶ File ▶ Database manager... ▶ Database manager ▶ [Proper-

ties] ▶ Properties - Database - 'Database name' ▶ Backup

Definition of backup monitoring and automatic backups.

Backup monitoring

on | off (Default value: off)

Enables/disables the backup monitoring for the selected database. If the
check box Backup monitoring is enabled, then the field Next backup in
the database table will be marked in red when the interval time elapses.

Last backup

Shows the date and time of the last database backup.
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Next backup

Date at which the next backup must take place. The date can be selected

by pressing  in the dialog window Select date.

Input Date selection
Default value Last backup + 1 month

Interval

Entry of the interval for the backup monitoring. After each automatically or
manually triggered backup, the interval entered here will be added auto-
matically to the Last backup and the field Next backup will be automat-
ically adjusted accordingly.

Range 1 ... 999 
Default value 1 
Selection day(s) | week(s) | month(s) | year(s)
Default value month(s)

Start backup automatically

on | off (Default value: off)

Automatic start of the backup for the database in the defined Backup
directory.

Backup directory

Selection of a folder predefined in the Program administration for the
automatic backup.

Selection Selection of the backup directory | Default
backup directory

Default value Default backup directory

Note

Make sure that you have read and write access rights on the selected
directory.

4.3.5.5 Database properties - Monitoring 

Tab: Database ▶ File ▶ Database manager... ▶ Database manager ▶ [Proper-

ties] ▶ Properties - Database - 'Database name' ▶ Monitoring

Defines database monitoring.



4.3 Manage databases ￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭

126 ￭￭￭￭￭￭￭￭ tiBase 1.0

Monitoring size

on | off (Default value: off)

Enables/disables size monitoring for the selected database. If this check box
is activated then the field Size in the Database table will be shown in red
when the limit value has been exceeded. A corresponding message also
appears when the database is opened.

Maximum size

Maximum permitted database size in MB.

Range 1 ... 2147483647 MB
Default value 500 MB

Monitoring number of records

on | off (Default value: off)

Enables/disables the monitoring of the number of data sets for the selected
database. If this check box is activated then the field Number in the Data-
base table will be shown in red when the limit value has been exceeded. A
corresponding message also appears when the database is opened.

Maximum number

Maximum permitted number of data sets for database.

Range 1 ... 2147483647 
Default value 1000 

4.3.6 Backup database manually
Dialog window: Database ▶ File ▶ Database manager… ▶ Database man-

ager ▶ [Backup] ▶ Database backup

[Backup] is used to open the dialog window Backup database:

Backup target

Backup directory

Selection of a folder predefined in Program administration for the
backup.

Selection Selection of the backup directory | Default
backup directory

Default value Default backup directory
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Note

Make sure that you have read and write access rights on the selected
directory.

Backup name

Selection of an existing name for the backup file or entry of a new name. If
an existing backup file is selected it will be overwritten.

Input 50 characters
Default value Backup-##

Note

If the backup directory is on a network drive, the backup date should be
added manually to the Backup name because the backup date infor-
mation is not available when the directory is restored.

[Start]

Starts manual database backup.

4.3.7 Restore database 
Dialog window: Database ▶ File ▶ Database manager… ▶ Database man-

ager ▶ [Restore] ▶ Restoring databases

[Restore] is used to open the dialog window Restore databases:

Backup directory

Selection of a directory predefined in the Program administration that
contains the backed up databases.

Selection Selection of the backup directory | Default
backup directory

Default value Default backup directory

Backup name

Selection of a backup file.

Selection Select backup files

Backup date

Shows the time at which the database was backed up. If the backup file is
located on a network drive, this information is not available.
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Database name

Shows the name of the database. If the backup file is located on a network
drive, this information is not available.

Number of records

Shows the number of data sets in the database. If the backup file is located
on a network drive, this information is not available.

Size

Shows the size of the database in KB.

Save as

Name under which the database is to be restored.

Input 50 characters
Default value New database ##

[Start]

Start database recovery. After the start, a progress bar appears in the win-
dow. When the backup has been completed the dialog window closes
automatically.

Note

Existing databases cannot be overwritten, i.e. they must first be deleted
so that the database can be recovered under its old name.

4.4 Templates

4.4.1 Report templates

4.4.1.1 Manage report templates

4.4.1.1.1 Report template manager

Dialog window: Database ▶ Tools ▶ Report templates ▶ Manager… ▶ Report tem-
plate manager

The menu item Tools ▶ Report templates ▶ Manager… is used to open
the window Report template manager.

List of report templates

The list of report templates contains information about all the saved report
templates. The table cannot be edited. With a click on the column title (Col-
umn Name, Saved, Saved by, Comment) the table can be sorted accord-
ing to the selected column in increasing or decreasing sequence.
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Name

Name of report template.

Saved

Date and time when the report template was saved.

Saved by

Short name of the user who saved the report template.

Comment

Comment on the report template.

Window menus

The menu [Edit] below the list of report templates contains the following
menu items:

Rename… Rename the selected report template (see Chapter 4.4.1.1.2, page 129).

Copy Copy the selected report template(s) (see Chapter 4.4.1.1.3, page 130).

Delete… Delete the selected report template(s) (see Chapter 4.4.1.1.4, page 130).

Export… Export the selected report template(s) (see Chapter 4.4.1.1.5, page 130).

Import… Import report templates (see Chapter 4.4.1.1.6, page 130).

4.4.1.1.2 Rename report templates

Dialog window: Database ▶ Tools ▶ Report templates ▶ Manager… ▶ Report tem-

plate manager ▶ [Edit] ▶ Rename… ▶ Rename report template

With the menu item Edit ▶ Rename... in the window Report template
manager, the window Rename report template opens for renaming the
selected report template.

Rename report template 'Name' to

Entry of  the new name for the report template.

Input 50 characters

Note

The name of the report template must be unambigous in the whole Client/
Server system.
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4.4.1.1.3 Copy report template

Menu item: Database ▶ Tools ▶ Report templates ▶ Manager... ▶ Report template

manager ▶ [Edit] ▶ Copy

With the menu item Edit ▶ Copy in the window Report template man-
ager the selected report templates are copied under the name Copy of
'Report template name'.

4.4.1.1.4 Delete report templates

Menu item: Database ▶ Tools ▶ Report templates ▶ Manager... ▶ Report template

manager ▶ [Edit] ▶ Delete...

With the menu item Edit ▶ Delete... in the window Report template
manager the selected report templates are deleted.

4.4.1.1.5 Export report templates

Dialog window: Database ▶ Tools ▶ Report templates ▶ Manager… ▶ Report tem-

plate manager ▶ [Edit] ▶ Export… ▶ Select directory for export

With the menu item Edit ▶ Export... in the window Report template
manager the selected report templates are each exported in a file with the
name 'Name'.mrep. The window Select directory for export opens in
which the directory for export must be selected.

4.4.1.1.6 Import report templates

Dialog window: Database ▶ Tools ▶ Report templates ▶ Manager… ▶ Report tem-

plate manager ▶ [Edit] ▶ Import… ▶ Select files for import

With the menu item Edit ▶ Import... in the window Report template
manager the dialog window Select files for import opens in which the
report templates to be imported must be selected. The report templates are
then imported.

4.4.1.2 Create new report template

Menu item: Database ▶ Tools ▶ Report templates ▶ New

New form report

With the menu item Tools ▶ Report templates ▶ New ▶ Form report
the program window Report template - New form report opens with
an empty report template, which can then be edited.

4.4.1.3 Open report template

Dialog window: Database ▶ Tools ▶ Report templates ▶ Open… ▶ Open report tem-
plate

With the symbol  or the menu item Tools ▶ Report tem-
plates ▶ Open... the window Open report template opens in which one
of the globally available report templates can be selected and opened.
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List of report templates

The list of report templates contains information about all the saved report
templates. The table cannot be edited. With a click on the column title (Col-
umn Name, Saved, Saved by, Comment) the table can be sorted accord-
ing to the selected column in increasing or decreasing sequence.

Name

Name of report template.

Saved

Date and time when the report template was saved.

Saved by

Short name of the user who saved the report template.

Comment

Comment on the report template.

Open report template

Name

Name of the report template to be opened. If a report template is selected
from the table, the name will be entered automatically in this field. It can
however also be entered manually.

Input 50 characters

[Open]

Opens the program window Report template, in which the selected report
template is shown and can be edited.

4.4.1.4 Edit report template

4.4.1.4.1 Report template - General

4.4.1.4.1.1 Report template - Overview

Program window: Database ▶ Report template

Which determination data and which other items (e.g. text fields, images,
graphics elements) are to be produced in a report are defined in report tem-
plates. The templates can be created or edited in their own program window
and then saved globally under a unique name. They are used for the auto-
matic production of reports in determinations or for manual report produc-
tion from the database.

There are two basically different types of report template:
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￭ Form report
In the Form report the report section always includes the whole area
between the header and the footer. This means that for each determi-
nation at least one page will always be produced.

￭ Tabular report
In the Tabular report the report section can be set with the mouse. For
each data set one such report section will be filled with data and placed
on the page row by row. In this way tabular reports can be created from
several determinations.

4.4.1.4.1.2 Report template - Desktop

Program window: Database ▶ Report template

Elements

The desktop of the program window Report template has the following
elements:

￭ Menu bar
￭ General toolbar
￭ Module-specific toolbar
￭ Module bar
￭ Main window

4.4.1.4.1.3 Report template - Menu bar

4.4.1.4.1.3.1 Report template - Main menu 

Program window: Database ▶ Report template

The menu bar in the program window Report template has the following
main menu items:

￭ File
Save report template, page setup, page preview, close window.

￭ Edit
Undo, redo, cut, copy, paste, delete, enter comment.

￭ View
Update view, page navigation.

￭ Insert
Insert pages.

￭ Tools
Options.

￭ Help
Open Program Help.
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4.4.1.4.1.3.2 Report template - Menu File

Program window: Database ▶ Report template

Save Save an opened report template (see Chapter 4.4.1.4.2.11, page 144).

Save as Save an opened report template under a new name (see Chapter 4.4.1.4.2.11,
page 144).

Page setup... Set up the layout for the report template (see Chapter 4.4.1.4.2.2, page 136).

Page preview Set up the layout for the report template (see Chapter 4.4.1.4.2.8, page 142).

Exit Close the program window Report template.

4.4.1.4.1.3.3 Report template - Menu Edit

Program window: Database ▶ Report template

Undo: Undo the last action.

Restore: Restore the undone action.

Cut Cut selected items and copy them to the clipboard (see Chapter 4.4.1.4.2.6, page
141).

Copy Copy the selected items to the clipboard (see Chapter 4.4.1.4.2.6, page 141).

Insert Insert marked items from the clipboard (see Chapter 4.4.1.4.2.6, page 141).

Delete Delete the marked items (see Chapter 4.4.1.4.2.6, page 141).

Comment Enter comments on the report template (see Chapter 4.4.1.4.2.9, page 143).

4.4.1.4.1.3.4 Report template - Menu View

Program window: Database ▶ Report template

Update Update the view.

First page Show the first page of the report template (see Chapter 4.4.1.4.2.4, page 139).

Previous page Show the previous page of the report template (see Chapter 4.4.1.4.2.4, page
139).

Next page Show the next page of the report template (see Chapter 4.4.1.4.2.4, page
139).
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Last page Shows the last page of the report template (see Chapter 4.4.1.4.2.4, page 139).

4.4.1.4.1.3.5 Report template - Menu Insert

Program window: Database ▶ Report template

Page before Insert a new page in front of the shown page (see Chapter 4.4.1.4.2.4, page
139).

Page after Inserts a new page after the shown page (see Chapter 4.4.1.4.2.4, page 139).

4.4.1.4.1.3.6 Report template - Menu Tools

Program window: Database ▶ Report template

Options... Set options for the report template (see Chapter 4.4.1.4.2.10, page 143).

4.4.1.4.1.3.7 Report template - Menu Help

Program window: Database ▶ Report template

tiBase Help Open tiBase help.

4.4.1.4.1.4 Report template - General toolbar 

Program window: Database ▶ Report template

Save Save an opened report template (see Chapter 4.4.1.4.2.11, page 144).

Page preview Set up the layout for the report template (see Chapter 4.4.1.4.2.8, page 142).

Print (PDF)… Show the report template with the data of the selected determination as a PDF-
file.

Undo: Undo the last action.

Restore: Restore the undone action.

Cut Cut selected items and copy them to the clipboard (see Chapter 4.4.1.4.2.6, page
141).

Copy Copy the selected items to the clipboard (see Chapter 4.4.1.4.2.6, page 141).

Insert Insert marked items from the clipboard (see Chapter 4.4.1.4.2.6, page 141).

Delete Delete the marked items (see Chapter 4.4.1.4.2.6, page 141).
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Select zoom level (see Chapter 4.4.1.4.2.7, page 142).

Grid Switch the grid display on and off (see Chapter 4.4.1.4.2.10, page 143).

Snap to grid Switch snap at grid on and off (see Chapter 4.4.1.4.2.10, page 143).

4.4.1.4.1.5 Report template - Module-specific toolbar 

Program window: Database ▶ Report template

Depending on the module selected in the report template, other symbols
and input fields are shown below the general toolbar, with which the prop-
erties of these modules can be directly edited (see Chapter 4.4.1.4.1.6, page
135).

4.4.1.4.1.6 Report template - Module bar 

Program window: Database ▶ Report template

Select modules If this option is enabled then modules in the report template can be selected,
reduced/enlarged and moved (see Chapter 4.4.1.4.2.6, page 141).

Text field If this option is enabled then text fields can be inserted in the report template
(see Chapter 4.4.1.4.3.1, page 145).

Data field If this option is enabled then data fields can be inserted in the report template
(see Chapter 4.4.1.4.3.2, page 147).

Date field If this option is enabled then date fields can be inserted in the report template
in which the actual date is entered (see Chapter 4.4.1.4.3.3, page 149).

Time field If this option is enabled then time fields can be inserted in the report template
in which the actual time is entered (see Chapter 4.4.1.4.3.4, page 150).

Page number If this option is enabled then fields can be inserted in the report template in which
the page number is entered (see Chapter 4.4.1.4.3.5, page 152).

Number of pages If this option is enabled then fields can be inserted in the report template in which
the number of pages is entered (see Chapter 4.4.1.4.3.6, page 154).

Fixed report If this option is enabled then fixed reports can be inserted in the report template
(see Chapter 4.4.1.4.3.7, page 155).
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Group field If this option is enabled then group fields can be inserted in the report template
(see Chapter 4.4.1.4.3.8, page 157).

Image If this option is enabled then images can be inserted in the report template (see
Chapter 4.4.1.4.3.9, page 158).

Line If this option is enabled then lines can be inserted in the report template (see
Chapter 4.4.1.4.3.10, page 159).

Rectangle If this option is enabled then rectangles can be inserted in the report template
(see Chapter 4.4.1.4.3.11, page 160).

Curve If this option is enabled then curves can be inserted in the report template (see
Chapter 4.4.1.4.3.12, page 161).

Calibration curve If this option is enabled then calibration curves can be inserted in the report
template (see Chapter 4.4.1.4.3.13, page 163).

4.4.1.4.2 Report template - Functions

4.4.1.4.2.1 Report template - Function overview

Program window: Database ▶ Report template

In the program window Report template the following functions can be
executed:

￭ Page setup
￭ Define sections in main window
￭ Insert report pages
￭ Insert modules
￭ Edit modules
￭ Zooming
￭ Show page preview
￭ Enter comment on report template
￭ Define options for report template
￭ Save report template

4.4.1.4.2.2 Report template - Page setup  

Dialog window: Report template ▶ File ▶ Page setup… ▶ Page setup

With the menu item File ▶ Page setup... in the window Report tem-
plate the dialog window Page setup opens in which the report format
settings can be made.

General

only for form report
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Settings

Selection Apply to current page | Apply to all pages
Default value Apply to current page

Apply to current page
The page settings are only applied for the currently selected report page.

Apply to all pages
The page settings are applied for all report pages.

Page format

Page format

Selection of the page format. The width and height of the paper can be
defined with User-defined.

Selection A4 | Letter | Legal | User-defined
Default value A4

Width

Width of the page format. This parameter can only be edited for Page for-
mat= User-defined

Range 0.0 ... 499.0 mm
Default value 210.0 mm

Height

Height of the page format. This parameter can only be edited for Page
format= User-defined

Range 0.0 ... 499.0 mm
Default value 297.0 mm

Orientation

Selection of the page format.

Selection Portrait | Landscape
Default value Portrait

Page margins

Top

Upper page margin.

Range 0.0 ... 499.0 mm
Default value 15.0 mm

Bottom

Lower page margin.
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Range 0.0 ... 499.0 mm
Default value 15.0 mm

Left

Left-hand page margin.

Range 0.0 ... 499.0 mm
Default value 20.0 mm

Right

Right-hand page margin.

Range 0.0 ... 499.0 mm
Default value 20.0 mm

Layout

Header

Height of header.

Range 0.0 ... 499.0 mm
Default value 15.0 mm

Footer

Height of footer.

Range 0.0 ... 499.0 mm
Default value 15.0 mm

Determination height

Height of the section for a single determination on a tabular report.

only for tabular report
Range 0.0 ... 499.0 mm
Default value 25.0 mm

4.4.1.4.2.3 Report template - Define sections  

Program window: Database ▶ Report template

Define sections for form report

The header, footer and report sections can be enlarged and reduced with
the left mouse button.



￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭ 4 Database

tiBase 1.0 ￭￭￭￭￭￭￭￭ 139

Defining sections for tabular report

The header, footer and report sections can be enlarged and reduced with
the left mouse button.

4.4.1.4.2.4 Report template - Insert pages 

Menu item: Report template ▶ Insert ▶ Page before / Page after

Note

It is not possible to insert pages in templates for tabular reports.

Inserting page before

With the menu item Insert ▶ Page before in the program window Report
template a new empty report report page is inserted before the report page
shown.

Insert page after

With the menu item Insert ▶ Page after in the program window Report
template a new empty report report page is inserted after the report page
shown.
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Navigating

In report templates with several pages the navigation bar can be used to
switch to the required page.

Jumps to first page.

Jumps to previous page.

Jumps to next page.

Jumps to last page.

4.4.1.4.2.5 Report template - Insert modules 

Program window: Database ▶ Report template

In order to insert a module in a report template the corresponding symbol
must be selected on the module bar and then placed on the report template
by creating a field with the left mouse button. The Properties window of the
corresponding module then opens automatically.

Form report

The following modules can be inserted in a form report:

￭ Header
Text field, Data field, Date field, Time field, Page number, Number of
pages, Image, Line, Rectangle, Curve, Calibration curve

￭ Report section
Text field, Data field, Date field, Time field, Fixed report, Group field,
Image, Line, Rectangle, Curve, Calibration curve

￭ Footer
Text field, Data field, Date field, Time field, Page number, Number of
pages, Image, Line, Rectangle, Curve, Calibration curve

Tabular report

The following modules can be inserted in a tabular report:

￭ Header
Text field, Date field, Time field, Page number, Number of pages,
Image, Line, Rectangle

￭ Report section
Text field, Data field, Date field, Time field, Group field, Image, Line,
Rectangle,
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￭ Footer
Text field, Date field, Time field, Page number, Number of pages,
Image, Line, Rectangle

4.4.1.4.2.6 Report template - Edit modules 

Program window: Database ▶ Report template

Enable selection

This symbol in the Module bar must be switched on in order to be able to
select modules in a report template for editing.

Select a single module

Single modules are selected with a click of the left mouse button. This auto-
matically shows the corresponding properties of the module below the
toolbar.

Select several modules

Several modules are selected by drawing a frame around the required mod-
ules with the left mouse button.

Moving, reducing, enlarging modules

When this cursor symbol appears then the selected modules can be moved
about on the report template with the left mouse button pressed down.

  
When one of these cursor symbols appears then the selected modules can
be reduced and enlarged respectively on the report template with the left
mouse button pressed down.

Cutting, copying, pasting, deleting modules

Cut the selected modules and copy them to the clipboard.

Copy the selected modules to the clipboard.

Paste modules from the clipboard.

Delete the selected module.
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Edit module properties

Open the properties window for the selected module. Alternatively the
properties can also be edited directly below the toolbar.

4.4.1.4.2.7 Report template - Zoom

Program window: Database ▶ Report template

With this list box on the toolbar the required zoom step for showing the
report template can be selected in steps of 25% from 25% to 400%.

4.4.1.4.2.8 Report template - Page preview 

Preview window: Report template ▶ File ▶ Page preview ▶ Report preview

With the symbol  or the menu item File ▶ Page preview in the program
window Report template the window Report preview opens in which
a page preview of the report template is shown with the data of the deter-
minations selected in the determination overview.

Functions

Produces displayed report as PDF-file.

Selects the required zoom step for displaying the report preview, range
25% to 400% in steps of 25%.

Select report page

In report templates with several pages the navigation bar Page can be used
to switch to the required page.

Jumps to first page.

Jumps to previous page.

Jumps to next page.

Jumps to last page.
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Selecting determination

If several determinations have been selected for the report display then the
navigation bar Determination can be used to switch to the required deter-
mination.

Jumps to first determination.

Jumps to previous determination.

Jumps to next determination.

Jumps to last determination. 

4.4.1.4.2.9 Report template - Comment

Dialog window: Report template ▶ Edit ▶ Comment ▶ Comment

With the symbol  or the menu item Edit ▶ Comment in the program
window Report template the window Comment on report template
opens in which comments on the opened report template can be entered.

Comment

Enter comment on the report template that is shown in the List of report
templates.

Input 1000 characters

4.4.1.4.2.10 Report template - Options   

Dialog window: Report template ▶ Tools ▶ Options...

With the menu item Tools, Options in the program window Report tem-
plate the window Options for report templates opens in which various
settings for the report template can be defined.

Unit

Unit

Select the size unit for the report template.

Selection mm | cm | inch
Default value mm
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Grid

X distance

Grid distance in X-direction.

Range 1.0 ... 100.0 mm
Default value 5.0 mm

Y distance

Grid distance in Y-direction.

Range 1.0 ... 100.0 mm
Default value 5.0 mm

Display grid

on | off (Default value: off)

Enable/Disable the grid display on the report template.

Snap at grid

on | off (Default value: off)

Enable/Disable snapping at grid on the report template.

Default font

Font

Select the default font for the report templates.

Selection Arial | Windows fonts
Default value Arial

4.4.1.4.2.11 Report template - Save

Dialog window: Report template ▶ File ▶ Save/Save as ▶ Save report template

With the symbol  or the menu item File ▶ Save an existing opened report
template will be saved again under its own name without opening the win-
dow Save report template.

When saving a newly created report template with the menu item
File ▶ Save or when saving an existing report template with the menu item
File ▶ Save as the window Save report template opens in which a name
for the report template can be entered or selected.

List of report templates

The list of report templates contains information about all the saved report
templates. The table cannot be edited. With a click on the column title (Col-
umn Name, Saved, Saved by, Comment) the table can be sorted accord-
ing to the selected column in increasing or decreasing sequence.
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Name

Name of report template.

Saved

Date and time when the report template was saved.

Saved by

Short name of the user who saved the report template.

Comment

Comment on the report template.

Save report template

Name

Name under which the report template is to be saved.

Input 50 characters

Note

The name of the report template must be unambigous in the whole Client/
Server system.

[Save]

Save the report template under the required name.

4.4.1.4.3 Report template - Modules

4.4.1.4.3.1 Report template - Text field 

Program window: Database ▶ Report template

Text fields are used for showing any texts in the report.

Insert

In order to insert a text field into a report template the corresponding symbol
must be selected on the Module bar and placed on the report template by
creating a field with the left-hand mouse key.

Properties

X pos.

x-position within the permitted section.
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Range 0.0000 ... (max. page width) mm

Y pos.

y-position within the permitted section.

Range 0.0000 ... (max. page height) mm

Width

Width of image field.

Range 0.0000 ... (max. page width) mm

Height

Height of image field.

Range 0.0000 ... (max. page height) mm

Selection of the available Windows fonts.

Font size in pt.

Color selection.

Bold.

Italic.

Underlined.

Left-justified.

Centered.

Right-justified.

Switches line break on/off for multi-line text fields.
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Fills the field with dots.

Text

Entry of text for the text field.

4.4.1.4.3.2 Report template - Data field 

Program window: Database ▶ Report template

Data fields are used for showing determination data in a report.

Insert

In order to insert a data field into a report template the corresponding sym-
bol must be selected on the Module bar and placed on the report template
by creating a field with the left-hand mouse key.

Properties

X pos.

x-position within the permitted section.

Range 0.0000 ... (max. page width) mm

Y pos.

y-position within the permitted section.

Range 0.0000 ... (max. page height) mm

Width

Width of data field.

Range 0.0000 ... (max. page width) mm

Height

Height of data field.

Range 0.0000 ... (max. page height) mm

Selection of the available Windows fonts.

Font size in pt.
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Color selection.

Bold.

Italic.

Underlined.

Left-justified.

Centered.

Right-justified.

Switches line break on/off for multi-line data fields.

Fills the field with dots.

Prefix

Text placed in front of the data field contents.

Input 50 characters

Data field

Shows path and name of selected data field (the field cannot be edited

directly). With  a window opens for selecting the data field in which all
the available fields for the determination overview are shown in a tree struc-
ture. With a double-click on the required field the path and name of the data
field are entered.

Suffix

Text placed after the data field contents.

Input 50 characters
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Preview

Shows a formatted example of text.

4.4.1.4.3.3 Report template - Date field 

Program window: Database ▶ Report template

Date fields are used for showing the current date in a report.

Insert

In order to insert a date field into a report template the corresponding sym-
bol must be selected on the Module bar and placed on the report template
by creating a field with the left-hand mouse key.

Properties

X pos.

x-position within the permitted section.

Range 0.0000 ... (max. page width) mm

Y pos.

y-position within the permitted section.

Range 0.0000 ... (max. page height) mm

Width

Width of date field.

Range 0.0000 ... (max. page width) mm

Height

Height of date field.

Range 0.0000 ... (max. page height) mm

Selection of the available Windows fonts.

Font size in pt.

Color selection.
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Bold.

Italic.

Underlined.

Left-justified.

Centered.

Right-justified.

Fills the field with dots.

Prefix

Text placed in front of the date field contents.

Input 50 characters

Suffix

Text placed after the date field contents.

Input 50 characters

Sample

Shows the formatted date.

4.4.1.4.3.4 Report template - Time field 

Program window: Database ▶ Report template

Time fields are used for showing the actual time in the report.

Insert

In order to insert a time field in a report template the corresponding symbol
must be selected on the Module bar and then placed on the report template
by creating a field with the left-hand mouse key.
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Properties

X pos.

x-position within the permitted section.

Range 0.0000 ... (max. page width) mm

Y pos.

y-position within the permitted section.

Range 0.0000 ... (max. page height) mm

Width

Width of time field.

Range 0.0000 ... (max. page width) mm

Height

Height of time field.

Range 0.0000 ... (max. page height) mm

Selection of the available Windows fonts.

Font size in pt.

Color selection.

Bold.

Italic.

Underlined.

Left-justified.

Centered.
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Right-justified.

Fills the field with dots.

Prefix

Text placed in front of the contents of the time field.

Input 50 characters

Suffix

Text to be placed after the contents of the time field.

Input 50 characters

Preview

Shows the formatted time.

4.4.1.4.3.5 Report template - Page number 

Program window: Database ▶ Report template

The actual page number in the report is produced in a page number field.

Insert

In order to insert page number field into a report template the corresponding
symbol must be selected on the Module bar and then placed in the header
or footer of the report template by creating a field with the left-hand mouse
key.

Properties

X pos.

x-position within the permitted section.

Range 0.0000 ... (max. page width) mm

Y pos.

y-position within the permitted section.

Range 0.0000 ... (max. page height) mm

Width

Width of the page number field.

Range 0.0000 ... (max. page width) mm
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Height

Height of the page number field.

Range 0.0000 ... (max. page height) mm

Selection of the available Windows fonts.

Font size in pt.

Color selection.

Bold.

Italic.

Underlined.

Left-justified.

Centered.

Right-justified.

Fills the field with dots.

Prefix

Text placed in front of the page number field.

Input 50 characters

Suffix

Text placed after the page number field.

Input 50 characters
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Preview

Shows the formatted page number.

4.4.1.4.3.6 Report template - Number of pages 

Program window: Database ▶ Report template

This field shows the total number of pages in the report.

Insert

In order to insert a number of pages field into a report template, the corre-
sponding symbol must be selected on the Module bar and then placed in
the header or footer of the report template by creating a field with the left-
hand mouse key.

Properties

X pos.

x-position within the permitted section.

Range 0.0000 ... (max. page width) mm

Y pos.

y-position within the permitted section.

Range 0.0000 ... (max. page height) mm

Width

Width of the field.

Range 0.0000 ... (max. page width) mm

Height

Height of the field.

Range 0.0000 ... (max. page height) mm

Selection of the available Windows fonts.

Font size in pt.

Color selection.
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Bold.

Italic.

Underlined.

Left-justified.

Centered.

Right-justified.

Fills the field with dots.

Prefix

Text placed in front of the field contents.

Input 50 characters

Suffix

Text placed after the field contents.

Input 50 characters

Preview

Shows the formatted number of pages.

4.4.1.4.3.7 Report template - Fixed report  

Program window: Database ▶ Report template

Fixed reports are used for producing predefined part-reports of the deter-
mination in the report.

Insert

In order to insert a fixed report in a report template the corresponding sym-
bol must be selected on the Module bar and then placed on the report
template by creating a field with the left mouse button.
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Properties

X pos.

Shows the predefined x-position for the fixed report.

Y pos.

Y position within the permitted section.

Range 0.0000 ... (max. page height) mm

Width

Shows the predefined width of the fixed report.

Height

Height of fixed report.

Range 0.0000 ... (max. page height) mm

Fixed report

Selection of a predefined fixed report.

Selection Calculations | Calibration data | Curves | Mes-
sages | List of meas. points | Result list | Raw
data (endpoints) | Standard addition | Statistics
data (brief) | Statistics data (full) | Signature list
Determination | Signature list Method | Varia-
bles | Devices used | Common variables used |
Solutions used | Sensors used

Default value Calculations

Command name

Name of the command for which a curve, a calibration curve or a measuring
point list is to be produced. With not defined, the lists for all curves present
in the determination will be produced as default.

This parameter appears only as editable field when Fixed report = Curve,
Calibration curve or Measuring point list.

Input 50 characters
Selection not defined
Default value not defined
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4.4.1.4.3.8 Report template - Group field

Program window: Database ▶ Report template

A group field is for the purpose of grouping together a variety of fields in
the report template. All of the fields gathered together in a group field can
be moved together as a group. The group field prevents a page break inside
the group field.

The group field always extends across the entire width of a page; only the
upper edge (Y value) and the height of the field can be configured.

Note

The following fields, which do not permit page break controls, cannot be
inserted into a group field.

￭ Fixed report
￭ Curve
￭ Calibration curve

Insert

In order to insert group field into a report template the corresponding sym-
bol must be selected on the Module bar and placed on the report template
by creating a field with the left-hand mouse key.

Properties

X pos.

Shows the predefined x-position for the field.

Y pos.

y-position within the permitted section.

Range 0.0000 ... (max. page height) mm

Width

Shows the predefined width of the fixed report.

Height

Height of the field

Range 0.0000 ... (max. page height) mm
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4.4.1.4.3.9 Report template - Image 

Program window: Database ▶ Report template

An image field is used for including any external graphics on the report tem-
plate. The file formats *.jpg and *.gif are supported.

Insert

In order to insert an image into a report template the corresponding symbol
must be selected on the Module bar and placed on the report template by
creating a field with the left-hand mouse key.

Properties

X pos.

x-position within the permitted section.

Range 0.0000 ... (max. page width) mm

Y pos.

y-position within the permitted section.

Range 0.0000 ... (max. page height) mm

Width

Width of image field.

Range 0.0000 ... (max. page width) mm

Height

Height of image field.

Range 0.0000 ... (max. page height) mm

Graphics file

Shows path and name of the selected graphics file (the field cannot be edited

directly). With  a window opens for selecting the graphics file. The path
and name of the graphics file are then entered.

Size

Entry how the image is to be displayed.

Selection original | proportional | non-proportional
Default value original

original
Original size.
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proportional
Proportional enlargement or diminishment.

non-proportional
Non-proportional enlargement or diminishment.

4.4.1.4.3.10 Report template - Line 

Program window: Database ▶ Report template

Any line can be inserted in the report template.

Insert

In order to insert a line in a report template the corresponding symbol must
be selected on the Module bar and then placed on the report template by
creating a field with the left-hand mouse key.

Properties

X pos.

x-position within the permitted section.

Range 0.0000 ... (max. page width) mm

Y pos.

y-position within the permitted section.

Range 0.0000 ... (max. page height) mm

Length

Length of the line.

Range 0.0 ... (max. page width) mm

Angle

Angle of the line.

Range 0 ... 360.000 °

Thickness

Thickness of the line.

Range 0.1 ... 10.0 mm
Default value 0.5 mm

Selection of the line color.
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Selection of the type of line.

4.4.1.4.3.11 Report template - Rectangle 

Program window: Database ▶ Report template

Any rectangle can be inserted in the report template.

Insert

In order to insert a rectangle into a report template the corresponding sym-
bol must be selected on the Module bar and placed on the report template
by creating a field with the left-hand mouse key.

Properties

X pos.

x-position within the permitted section.

Range 0.0000 ... (max. page width) mm

Y pos.

y-position within the permitted section.

Range 0.0000 ... (max. page height) mm

Width

Width of the rectangle.

Range 0.0000 ... (max. page width) mm

Height

Height of the rectangle.

Range 0.0000 ... (max. page height) mm

Thickness

Thickness of the line for the rectangle.

Range 0.1 ... 10.0 mm
Default value 0.5 mm

Selection of the line color.

Selection of the type of line for the rectangle.
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Switches the fill color on and off.

Selection of the fill color.

4.4.1.4.3.12 Report template - Curve field 

Program window: Database ▶ Report template

Curve fields are used for showing determination curves in the report.

Insert

In order to insert a curve in a report template the corresponding symbol must
be selected on the Module bar and then placed on the report template by
creating a field with the left mouse button.

Properties

Note

The properties are saved individually for each curve field. This means that
it is possible, e.g., to show several different curves for the same measuring
command beside one another in several curve fields.

X pos.

x-position within the permitted section.

Range 0.0000 ... (max. page width) mm

Y pos.

y-position within the permitted section.

Range 0.0000 ... (max. page height) mm

Width

Width of curve field.

Range 0.0000 ... (max. page width) mm

Height

Height of curve field.

Range 0.0000 ... (max. page height) mm
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Command type

Shows the command type for which a curve is to be produced.

Selection DET | MET | SET | MEAS | KFT | KFC | BRC |
STAT | DOS

Default value DET

Command name

Name of the command for which the curve is to be produced. With not
defined all curves present in the determination with the selected Com-
mand type will be produced as default.

Note

In the command name, the index in the format .# must be specified addi-
tionally (e.g. Chloride.1).

Selection not defined | 50 characters
Default value not defined

Autoscaling

on | off (Default value: on)

If this check box is activated, all axes in the curve window are scaled auto-
matically. In this case the fields Start value and End value cannot be
edited.

Tabs

Additional properties for the curve field can be set on the following 4 tabs:

￭ x axis
Parameters for the graphical display of the curve on the x axis.

￭ y1 axis
Parameters for the graphical display of the curve on the y1 axis (left-hand
y axis).

￭ y2 axis
Parameters for the graphical display of the curve on the y2 axis (right-
hand y axis).

￭ Options
Options for graphical display of curves.
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4.4.1.4.3.13 Report template - Calibration curve field

Program window: Database ▶ Report template

Calibration curve fields are used for showing calibration or standard addition
curves in the report.

Insert

In order to insert calibration curve field into a report template the corre-
sponding symbol must be selected on the Module bar and placed on the
report template by creating a field with the left-hand mouse key.

Properties

X pos.

x-position within the permitted section.

Range 0.0000 ... (max. page width) mm

Y pos.

y-position within the permitted section.

Range 0.0000 ... (max. page height) mm

Width

Width of calibration curve field.

Range 0.0000 ... (max. page width) mm

Height

Height of calibration curve field.

Range 0.0000 ... (max. page height) mm

Command name

Entry of the name of the command for which the calibration curve is to be
produced. With not defined the first calibration curve present in the deter-
mination with the selected Command type will be produced as default.

Selection not defined | 50 characters
Default value not defined
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4.4.2 Curve overlay templates

4.4.2.1 Manage curve overlay templates

Menu item: Database ▶ Tools ▶ Templates ▶ Curve overlay templates

With the menu item Tools, Templates, Curve overlay templates the
dialog window Curve overlay templates opens in which the globally
available templates for curve overlay can be managed.

Template table

The table with the defined templates cannot be edited, although it can be
sorted according to the selected column in increasing or decreasing
sequence by clicking on the column title

Template name

Shows the name of the template.

Command type

Shows the command type for which the template can be used.

Comment

Shows the comments about the template.

Functions

[New]

Generates a new template. The dialog window Properties - Overlay
curves opens in which the properties for the new template can be defined.

[Properties]

Open the dialog window Properties - Overlay curves in which the prop-
erties of the template selected in the table can be edited.

[Delete]

Delete the template selected in the table.

[Copy]

Copy the template selected in the table and save it under the name Copy
of....
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4.4.2.2 Edit curve overlay templates

4.4.2.2.1 Curve overlay - Properties

Dialog window: Database ▶ Tools ▶ Templates ▶ Curve overlay templates... ▶ Curve

overlay templates ▶ [Properties] ▶ Properties - Overlay curves - 'Name'

Template name

Name for the curve overlay template which is saved in the configuration
database per client.

Input 50 characters

Command type

Selection of the command type from which curves are to be overlaid.

Selection DET pH | DET U | DET Ipol | DET Upol | MET pH
| MET U | MET Ipol | MET Upol | SET pH | SET U
| SET Ipol | SET Upol | STAT pH | STAT U | DOS
pH | DOS U | KFT Ipol | KFT Upol | KFC | BRC |
MEAS pH | MEAS U | MEAS Ipol | MEAS Upol |
MEAS T | MEAS Conc | MEAS Cond | CAL MEAS
pH | CAL MEAS Conc | CAL Cond

Default value DET pH

Autoscaling

on | off (Default value: on)

If this check box is activated, then the. In this case the fields Start value
and End value cannot be edited.

Tabs

Further properties of a template for the overlaying of curves can be set on
the following 4 tabs:

￭ x axis
Parameters for the graphical display of the overlaid curves on the x axis.

￭ y axis
Parameters for the graphical display of the overlaid curves on the y axis.

￭ Options
Options for the graphical display of the overlaid curves.

￭ Comment
Enter comment on the template.
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4.4.2.2.2 Curve overlay - x axis

Dialog window: Database ▶ Tools ▶ Templates ▶ Curve overlay templates... ▶ Curve

overlay templates ▶ [Properties] ▶ Properties - Overlay curves - 'Name'

Parameters for the graphical display of the overlaid curves on the x axis.

x axis

Size

Selection of the quantity to be shown on the x axis.

Selection Command-dependent selection

Label

Freely definable axis label for the x axis. With auto the designation from the
field Size will be used.

Input 25 characters
Default value auto

Scaling

Start value

Initial value for scaling the x axis.

Range -1.0 E12 ... 1.0 E12 
Default value 0.0 

End value

End value for scaling the x axis.

Range -1.0 E12 ... 1.0 E12 
Default value 1000.0 

4.4.2.2.3 Curve overlay - y axis

Dialog window: Database ▶ Tools ▶ Templates ▶ Curve overlay templates... ▶ Curve

overlay templates ▶ [Properties] ▶ Properties - Overlay curves - 'Name'

Parameters for the graphical display of the overlaid curves on the y axis.

y axis

Size

Selection of the quantiy to be shown on the y axis.

Selection Command-dependent selection

Label

Freely definable axis label for the y axis. With auto the designation from the
field Size will be used.
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Input 25 characters
Default value auto

Display measuring points

on | off (Default value: on)

If this check box is activated then the individual measuring points will be
shown on the curve.

Note

With curves, for which the distance between to measuring points is
smaller than 5 pixels, the separate measuring points are not displayed
anymore, even if a symbol has been selected. In this case, the graphics
window can eventually be enlarged in order to display the symbols again.

Scaling

Start value

Initial value for scaling the y-axis.

Range -1.0 E12 ... 1.0 E12 
Default value 0.0 

End value

End value for scaling the y-axis.

Range -1.0 E12 ... 1.0 E12 
Default value 1000.0 

4.4.2.2.4 Curve overlay - Options

Dialog window: Database ▶ Tools ▶ Templates ▶ Curve overlay templates... ▶ Curve

overlay templates ▶ [Properties] ▶ Properties - Overlay curves - 'Name'

Options for the graphical display of the overlaid curves.

Display grid

on | off (Default value: off)

If this check box is actjvated then a grid will be shown against the back-
ground.

Grid type

Selection of the type of grid line.

Selection Select line type
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Grid color

Selection of the grid line color.

Selection Color selection | gray
Default value gray

Show endpoints

on | off (Default value: off)

If this check box is activated then the endpoints found will be indicated on
the curve by the symbol ♦ and labeled with EP# (potentiometric endpoints),
BP# (break point) or FP# (fixed endpoint).

Automatic EPs

Selection of the color for automatically set endpoints.

Selection Color selection | black
Default value black

Manual EPs

Selects the color for manually set endpoints.

Selection Color selection | pink
Default value pink

Background

Background color

Selection of the color for the curve background.

Selection Color selection | white
Default value white

Legend

Display of the data field, which is shown in the legend to identify the curves.

Open the dialog window Legend - Field selection for selecting the data
field.

Multiple curves of the same command

Setting, which curves are displayed when the command has been run several
times, e.g. because of a LOOP command or a multiple call of a Track.

Selection Show only last curve | Show all curves
Default value Show only last curve
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Show only last curve
Only the curve generated during the last run of the command is displayed.

Show all curves
The curves of all runs of the command are displayed.

4.4.2.2.5 Curve overlay - Comment

Dialog window: Database ▶ Tools ▶ Templates ▶ Curve overlay templates... ▶ Curve

overlay templates ▶ [Properties] ▶ Properties - Overlay curves - 'Name'

Entry of comment on the curve overlay template.

Comment

Comment on control chart.

Input 1000 characters

4.4.3 Templates for control chart

4.4.3.1 Managing control chart templates

Menu item: Database ▶ Tools ▶ Templates ▶ Control chart templates... ▶ Control
chart templates

With the menu item Tools ▶ Templates ▶ Control chart templates...,
the dialog window Control chart templates opens in which the globally
available templates for control charts can be managed.

Template table

The table with the defined templates cannot be edited, although it can be
sorted according to the selected column in increasing or decreasing
sequence by clicking on the column title

Template name

Shows the name of the template.

Comment

Shows the comments about the template.

Functions

[New]

Create new template. The dialog window Properties - Control chart
template opens in which the properties for the new template can be
defined.

[Properties]

The dialog window Properties - Control chart template opens, in which
the properties of the template selected in the table can be edited.
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[Delete]

Delete template.

[Copy]

Copies the template and saves it under the name Copy of....

4.4.3.2 Editing control chart templates

4.4.3.2.1 Control chart template - Properties

Dialog window: Database ▶ Tools ▶ Templates ▶ Control chart templates... ▶ Control

chart templates ▶ [Properties] ▶ Properties - Control chart - 'Name'

Template name

Name for the control chart template which is saved in the configuration
database per client.

Input 50 characters

Tabs

The properties of a control chart template can be set on the following 4
tabs:

￭ Graphical parameters
Parameters for the graphical display of the control chart.

￭ Limits
Definition of warning and intervention limits for the control chart.

￭ Statistics
Display of statistics data on the control chart.

￭ Comment
Enter comment on the template.

4.4.3.2.2 Control chart template - Graphical parameters

Dialog window: Database ▶ Tools ▶ Templates ▶ Control chart templates... ▶ Control

chart templates ▶ [Properties] ▶ Properties - Control chart - 'Name'

Parameters for the graphical display of the control chart.

y axis

Result

Selection of the result column whose value is to be shown on the y axis.

Selection RS01 | RS02 | RS03 | RS04 | RS05 | RS06 | RS07 |
RS08 | RS09 | RS10 | RS11 | RS12 | RS13 | RS14 |
RS15 | RS16 | RS17 | RS18 | RS19 | RS20 | RS21 |
RS22 | RS23 | RS24 | RS25

Default value RS01
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Label

Freely definable axis label for the y axis.

Input 25 characters
Default value Result

Background

Background color

Selection of the background color for the control chart.

Selection Color selection | white
Default value white

Measured values

Shape

Selection of the symbol for the display of the measured values.

Selection Symbol selection | •
Default value •

Color

Selection of the color for the measuring point symbol.

Selection Color selection | blue
Default value blue

Link measured values

on | off (Default value: off)

If this check box is activated, then the measured value points will be joined
by a line.

4.4.3.2.3 Control chart template - Limit values

Dialog window: Database ▶ Tools ▶ Templates ▶ Control chart templates... ▶ Control

chart templates ▶ [Properties] ▶ Properties - Control chart - 'Name'

Definition of warning and intervention limits to be shown on the control
chart.

Warning limits

Warning limits are always in orange on the control chart.

Lower limit

Lower warning limit.

Input 10 digits
Range -1.0E8 ... 1.0E8 (max. 10 digits) 
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Upper limit

Upper warning limit.

Input 10 digits
Range -1.0E8 ... 1.0E8 (max. 10 digits) 

Intervention limits

Intervention limits are displayed in red on the control chart.

Lower limit

Lower intervention limit.

Input 10 digits
Range -1.0E8 ... 1.0E8 (max. 10 digits) 

Upper limit

Upper intervention limit.

Input 10 digits
Range -1.0E8 ... 1.0E8 (max. 10 digits) 

4.4.3.2.4 Control chart template - Statistics

Dialog window: Database ▶ Tools ▶ Templates ▶ Control chart templates... ▶ Control

chart templates ▶ [Properties] ▶ Properties - Control chart - 'Name'

Definition of the display of statistics data on the control chart.

Show the statistics data

on | off (Default value: on)

If this check box is activated, then below the graph the statistics data for
Mean value, Standard deviation, Number of measuring points and
Minimum and maximum values will be shown.

Draw in mean value

on | off (Default value: on)

If this check box activated, then the Mean value will be shown on the
control chart as a continuous line in the color of the measured value.

Draw in standard deviation

on | off (Default value: on)

If this check box is activated, then the two values Mean value + Absolute
standard deviation and Mean value - Absolute standard deviation
will be shown on the control chart as dotted lines in the color of the meas-
ured value.
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4.4.3.2.5 Control chart template - Comment

Dialog window: Database ▶ Tools ▶ Templates ▶ Control chart templates... ▶ Control

chart templates ▶ [Properties] ▶ Properties - Control chart - 'Name'

Entry of comment on the control chart template.

Comment

Comment on control chart.

Input 1000 characters

4.4.4 Export templates

4.4.4.1 Export templates manager

Dialog window: Database ▶ Tools ▶ Templates ▶ Export templates... ▶ Export tem-
plates

With the menu item Tools ▶ Templates ▶ Export templates, the dialog
window Export templates opens in which the globally available templates
for manual or automatic export of determination data can be managed.

Template table

The table with the defined templates cannot be edited, although it can be
sorted according to the selected column in increasing or decreasing
sequence by clicking on the column title

Name

Shows the name of the export template.

File type

Shows the file format of the export template for data export.

Comment

Shows the comment on the export template.

Functions

[New]

Creates a new export template. The dialog window Export template opens
in which the properties for the new template can be defined.

[Properties]

The dialog window Export template opens, in which the properties of the
template selected in the table can be edited.

[Delete]

Delete the selected export template.
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[Copy]

Copies the selected export template and saves under the name Copy
of….

4.4.4.2 Edit export templates

4.4.4.2.1 Export template - Properties

Dialog window: Database ▶ Tools ▶ Templates ▶ Export templates... ▶ Export tem-

plates ▶ [Properties] ▶ Export template 'Name'

[Properties] is used to open the dialog window Export template
'Name' in which the properties of the selected export template can be edi-
ted.

Name

Name of export template.

Input 50 characters

Comment

Freely definable comment on the export template.

Input 250 characters

Target directory

Entry or selection (with ) of the path for the folder in which the export
file is to be saved.

Input 1000 characters

File type

Selection of the file format for data export:

Selection *.tdet (tiBase format) | *.csv (comma-separa-
ted) | *.slk (SLK format) | *.xml (XML format) |
*.csv (measuring point list)

Default value *.tdet (tiBase format)

*.tdet (tiBase format)
Program-specific data exchange format that can only be imported into
other tiBase 1.0  databases.

*.csv (comma-separated)
Data exchange format with unformatted text that can be imported into
other PC programs (e.g. Excel, Access).

*.slk (SLK format)
Data exchange format with formatted text that can be imported into
other PC programs (e.g. Excel).
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*.xml (XML format)
Data exchange format with XML code that can be imported into corre-
sponding PC programs.

*.csv (measuring point list)
Data exchange format for the measuring point list with unformatted text,
which can be imported into corresponding PC programs. The text file
contains a document header with date/time of the determination and
the determination ID, then the measuring point lists of the separate
commands are listed one after the other. The command name is listed
first for each measuring point list, followed by a header with the desig-
nations and the units of the measured values of the command. This is
followed by the list of the measuring points, each measuring point is listed
in a separate line and consists of a time indication and all measured values
generated by the command.

[Select fields]

Opens the dialog window Select fields in which the required fields for
export can be selected, arranged in the required sequence and renamed.

Note

Field selection is only possible for the file types *.csv and *.slk. With
*.tdet and *.xml all fields will always be exported.

[Options]

Opens the dialog window Options, in which the separators can be defined.

Note

The options can only be set for the data types *.csv (comma separa-
ted) and *.csv (measuring point list).

File name

One of the following options can be selected for the definition of the name
of the export file:

Selection Determination ID | Sample identification |
Request on each export | Fixed file name
(append data)

Default value Determination ID

Determination ID
If this option is selected then the name of the export file will be formed
from the unambiguous Determination ID, the Computer name, the
date stamp -YYYYMMDD-HHMMSS and the suffix for the format.
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Sample identification
If this option is selected then the name of the export file will be formed
from the selected sample identification ID1 or ID2, the Computer
name, the date stamp -YYYYMMDD-HHMMSS and the suffix for the
format. If the generated name already exists in the folder then a version
number will additionally be appended to the date.

Request on each export
If this option is selected then the name of the export file will be requested
at each export. In addition to the entered name the Computer name
and the date stamp -YYYYMMDD-HHMMSS will be added automati-
cally.

Fixed file name (append data)
If this option is selected then the name of the export file will be formed
from the name entered here and the suffix for the format. If the file is
already present in the folder then the data will be appended to this file.

Note

The option Fixed file name can only be selected for the file type *.csv
(comma separated) or *.slk (SLK format).

4.4.4.2.2 Export template - Select fields

Dialog window: Database ▶ Tools ▶ Templates ▶ Export templates... ▶ Export tem-

plates ▶ [Properties] ▶ Export templates ▶ [Select fields] ▶ Select fields

With [Select fields] in the Properties window for export templates the dia-
log window Select fields opens in which the fields for data export for the
file types *.csv and *.slk can be selected.

Available fields

Shows all the fields that can be exported.

Selected fields

Shows all the fields that will be exported.

Default name

Non-editable name of the field to be exported.

Displayed name

Field name that can be edited by the user for the exported field. The Default
name is entered as default. If the field name is deleted then the Default
name appears again.

Add selected field.
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Remove selected field.

Modifies the sequence of the exported fields by moving the selected field
up.

Modifies the sequence of the exported fields by moving the selected field
down.

4.4.4.2.3 Export template - Options for CSV format

Dialog window: Database ▶ Tools ▶ Templates ▶ Export templates... ▶ Export tem-

plates ▶ [Properties] ▶ Export template ▶ [Options] ▶ Options for CSV format

With [Options] in the Properties window for export templates the dialog
window Options for CSV format opens in which the separators can be
defined.

Field separator

Selection of the field separator.

Selection ; | , | Tab
Default value ;

Record separator

Selection of the data set separator (CR = Carriage return, LF = Line feed).

Selection CR/LF | CR | LF
Default value CR/LF

Header

on | off (Default value: on)

If this check box is activated, the column headers are exported at the begin-
ning of the export file.

4.4.4.2.4 Export template - Options for measurement point list

Dialog window: Database ▶ Tools ▶ Templates ▶ Export templates... ▶ Export tem-

plates ▶ [Properties] ▶ Export template ▶ [Options] ▶ Options for measuring point
list

With [Options] in the Properties window for export templates the dialog
window Options for measurement point list opens in which the sepa-
rators can be defined.
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Field separator

Selection of the field separator.

Selection ; | , | Tab
Default value ;

4.4.4.2.5 Export template - Request at file export

Dialog window: Database ▶ Tools ▶ Templates ▶ Export templates... ▶ Export tem-

plates ▶ [Properties] ▶ Export template

If in the properties of the export template under File name the option
Request on each export has been selected (see Chapter 4.4.4.2.1, page
174), then before the export of a determination the dialog File export is
displayed.

Target directory

Shows the target directory for the export file, which has been defined in the
properties of the export templates (see Chapter 4.4.4.2.1, page 174) used.

File name

Name under which the export file is to be saved în the Target directory.
During creating the file the user name as well as the current time stamp are
automatically attached to the name entered.

[OK]

The export of the corresponding determination is carried out to the indicated
file.

[Cancel]

The export of the corresponding determination is canceled. If several deter-
minations have been selected to be exported, then the dialog File export
will be displayed for the next determination.

[Cancel all]

The export of all selected determinations is canceled.

4.4.4.3 XML export
XML export

General

An XML export file with all determination data can be created when an XML
report template is used at the export of the determinations.

Structure

An XML export file is constructed as follows:

<?xml version="1.0" encod-
ing="ISO-8859-1" ?>
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–<DeterminationReport> Determination report

<xmlCreator val=""/> Program name

<xmlCreatorVersion val=""/> Program version

<xmlCreatorBuildNo val=""/> Build number

<subtype val=""/>  

+ <Determination> Determination data

+ <Method> Method data

+ <Sample> Sample data

+ <Results dynamic=""> Results overview

+ <ResultaSingle=""> Single results

+ <Command Data dynamic=""> Command variables

+ <Comvars dynamic=""> Common variables

+ <usedDevices dynamic=""> Device data

+ <usedSensors dynamic=""> Sensor data

+ <Statistics> Statistical data

–<System> System data

<userName val="" /> User name (abbreviation)

<userNameFull val="" /> User name (full name)

<clientName val="" /> Client name

<progVersion val="" /> Program version - Build number

<licenseRoot val="" /> License code

</Sytem>  

</DeterminationReport>  

Note

dynamic= means that the following nodes can appear more than once.

The actual data is situated between " ".
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4.4.4.3.1 XML export - Determination data
XML export

– <Determination> Determination data

– <Identification> Information about the identification of the determination.

<statisticLinkID val=""/> Statistics ID:

Unambiguous and unmistakable identification for the stat-
istically linked determinations.

<determinationID val=""/> Determination ID:

Unambiguous and unmistakable identification for the
determination.

<serverName val=""/> Name of the server to which the client was connected
when the determination was recorded.

<clientName val=""/> Name of the client with which the determination was
recorded.

<detCounter val=""/> Sample number which was entered in the run window.

<startCounter val=""/> Start counter

</Identification>

– <Acquisition> Information about recording the determination.

<determinationStart val=""/> Date and time at start of determination.

<determinationDuration val=""/> Duration of the determination from its start to its end or
termination in s.

<determinationEndState val=""/> Determination run (way in which the determination was
ended):

regular without errors

The determination was finished automatically after the
method was processed normally and without any errors.

manual stop

The determination has been ended with the [Stop] fixed
key.

error

The determination has been ended because an error
occured.

<userName val=""/> Short name of user logged in at start of determination.

<userNameFull val=""/> Full name of user logged in at start of determination.

<determinationNote val=""/> Remark on determination
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<progVersion val=""/> Program version and build number of the program at
recording the determination.

<licenseRoot val=""/> License start number of the program at recording the
determination.

</Acquisition>  

– <Version> Information about the determination version.

<signOffState val=""/> Signature status

no

Determination not signed.

Level 1

Determination signed on level 1.

Level 2

Determination signed on level 2.

<version val=""/> Version of the determination.

<status val="original"/> Determination status:

original

Determination data unaltered.

modified

Determination data modified.

<recalcDate val=""/> Date and time when the reprocessed determination ver-
sion was saved.

<recalcedBy val=""/> Short name of user logged in when determination was
reprocessed.

<recalcedByuserFull val=""/> Full name of user logged in when determination was
reprocessed.

<recalcReason val=""/> Reason for the determination modification.

<changeComment val=""/> User comment on the determination modification.

</Version>  

– <Miscellaneous> Different determination data.

<deterComment val=""/> Comment, which has been entered on the determination.

– <runMessages dynamic=""> Messages

– <data> Message

<subtype val=""/>  
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<msgSource val=""/> Message source:

Shows from where the message comes:

Program

Message that cannot be assigned to a particular command.

Track 'Track name' - Command 'Command name'

Message produced by a command during the run.

<msgText val=""/> Message text.

<msgTime val=""/> Time at which the message was created in the run (date,
time, UTC in the format JJJJ-MM-TT hh:mm:ss UTC....

<msgTitle val=""/> Message title and number.

</data>  

</runMessages>  

– <DetermVars dynamic=""> Determination variables

– <data> Determination variable

<vt val=""/> Variable type:

TX = Text

NR = Number

DT = Date/Time

NA = Unknown

<vn val=""/> Variable identification

<vr val=""/> Variable value.

</data>  

</DetermVars>  

– <SystemVars dynamic=""> System variables

– <data> System variable

<vt val=""/> Variable type:

TX = Text

NR = Number

DT = Date/Time

NA = Unknown

<vn val=""/> Variable identification

<vr val=""/> Variable value.
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</data>  

</SystemVars>  

</Miscellaneous>  

– <signOff dynamic=""> Signatures

– <data> Signature

<subtype val=""/>  

– <signature>  

<vr val=""/> Shows at which level the determination has been signed
(Level 1 or Level 2).

</signature>  

– <signDate>...</signDate> Date and time at which the determination was signed.

– <userName>...</userName> Short name of the user who signed the determination.

– <userNameFull>...</userName-
Full>

Full name of the user who signed the determination.

– <reason>...</reason> Reason for signature.

– <comment>...</comment> Comment on the signature.

</data>  

</signOff>  

</Determination>  

4.4.4.3.2 XML export - Method data
XML export

– <Method> Method data

– <Identification> Information about the identification of the method.

<methodName val=""/> Name of the method.

<methodID val=""/>> Method ID:

Unambiguous and unmistakable identification for the
method.

<methodComment val=""/> Method comment (Command comment on START
command).
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</Identification>

– <Version> Information about method version.

<signOffState val=""/> Signature status

no

Method not signed.

Level 1

Method signed at level 1.

Level 2

Method signed at level 2.

<version val=""/> Version of the method.

<status val="original"/> Method status:

new

The method has been newly created and not yet saved.

modified

The method has been reprocessed but not saved.

saved

The method has been saved.

reviewed

The method has been signed at stage 1.

released

The method has been signed at stage 2.

<savingTime val=""/> Date and time when the modified method version was
saved.

<savingUser val=""/> Short name of user logged in when modified method was
saved.

<savingUserFull val=""/> Full name of user logged in when modified method was
saved.

<changeReason val=""/> Reason for the method modification.

<changeComment val=""/> User comment on the method modification.

</Version>  

– <signOff dynamic=""> Signatures

– <data> Signature

<subtype val=""/>  
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– <signature>  

<vr val=""/> Shows at which level the method has been signed (Level
1 or Level 2).

<</signature>>  

– <signDate>...</signDate> Date and time at which the method was signed.

– <userName>...</userName> Short name of the user who signed the method.

– <userNameFull>...</userName-
Full>

Full name of the user who signed the method.

– <reason>...</reason> Reason for signature.

– <comment>...</comment> Comment on the signature.

</data>  

</signOff>  

</Method>  

4.4.4.3.3 XML export - Sample data
XML export

– <Sample> Sample data

– <Smpl.Data> Sample data

– <SmplSize> Sample size.

– <data>...</data> see above

</SmplSize>  

– <SmplUnit> Sample size unit.

– <data>...</data> see above

</SmplUnit>  

</SmplData>  

– <Identification> Sample identifications.

– <ID__01> Sample identification ID1.

– <data>...</data> see above

</ID__01>  

– <ID__02> see above

</Identification>  

</Sample>  
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4.4.4.3.4 XML export - Results overview
XML export

– <Results dynamic=""> Results overview

– <data>  

<subtype val="" />  

<vr val="" /> Result value with the number of decimal places defined in
the CALC command.

<vf val="" /> Result value with full precision.

<vs val=""/> Result status:

OK = The value is ok and has not been monitored.

OKL = The value is ok and has been monitored.

LE = The value exceeded the limit and has not been moni-
tored.

LEL = The value exceeded the limit and has been moni-
tored..

NV = The value is invalid and has not been monitored.

NVL = The value is invalid and has been monitored.

<vt val=""/> Result type:

TX = Text

NR = Number

DT = Date/Time

NA = Unknown

<vn val=""/> Result name.

 Name of the CALC command the result has been gener-
ated with.

<un val=""/> Unit of the result.

<fo val=""/> Formula used for the calculation of the result.

– <fv dynamic=""> Variables used for the calculation of the result.

– <data>  

<vr val="" /> Variable value.

<vs val=""/> Variable status (see above).

<vt val=""/> Variable type (see above).

<vn val=""/> Variable name.
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</data>  

</fv>  

– <sme> Mean value of the result.

– <data>  

<vr val="" /> Mean value with the number of decimal places defined in
the CALC command.

<vf val="" /> Mean value with full precision.

<vs val=""/> Variable status (see above).

</data>  

<sme>  

– <abs> Absolute standard deviation of the result.

– <data>  

<vr val="" /> Absolute standard deviation with the number of decimal
places defined in the CALC command.

<vf val="" /> Absolute standard deviation with full precision.

<vs val=""/> Variable status (see above).

</data>  

<abs>  

– <rel> Relative standard deviation of the result.

– <data>  

<vr val="" /> Absolute standard deviation with the number of decimal
places defined in the CALC command.

<vf val="" /> Relative standard deviation with full precision.

<vs val=""/> Variable status (see above).

</data>  
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<rel>  

-<max>  

– <data>  

<vr val="" />  

<vf val="" />  

<vs val=""/>  

</data>  

</max>  

-<min>  

– <data>  

<vr val="" />  

<vf val="" />  

<vs val=""/>  

</data>  

</min>  

<n val="" /> Number of the result among the statistically evaluated
results.

<nmax val="" /> Maximum number of statistically evaluated results.

</data>  

</Results>  

4.4.4.3.5 XML export - Single results
XML export

– <ResultsSingle> Single results

– <RS01> 1. single result

– <data>  

<vr val="" /> Result value with the number of decimal places defined in
the CALC command.

<vf val="" /> Result value with full precision.
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<vs val=""/> Result status:

OK = The value is ok and has not been monitored.

OKL = The value is ok and has been monitored.

LE = The value exceeded the limit and has not been moni-
tored.

LEL = The value exceeded the limit and has been moni-
tored..

NV = The value is invalid and has not been monitored.

NVL = The value is invalid and has been monitored.

<vt val=""/> Result type:

TX = Text

NR = Number

DT = Date/Time

NA = Unknown

<vn val=""/> Result name.

<un val=""/> Unit of the result.

<fo val=""/> Formula used for the calculation of the result.

– <fv dynamic=""> Variables used for the calculation of the result.

– <data>  

<vr val="" />  

<vs val="" />  

<vt val=""/>  

<vn val=""/>  

</data>  

– <sme> Mean value of the result.

– <data>  

<vr val="" /> Mean value with the number of decimal places defined in
the CALC command.

<vf val="" /> Mean value with full precision.

<vs val=""/> Variable status (see above).

</data>  
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<sme>  

– <abs> Absolute standard deviation of the result.

– <data>  

<vr val="" /> Absolute standard deviation with the number of decimal
places defined in the CALC command.

<vf val="" /> Absolute standard deviation with full precision.

<vs val=""/> Variable status (see above).

</data>  

<abs>  

– <rel> Relative standard deviation of the result.

– <data>  

<vr val="" /> Absolute standard deviation with the number of decimal
places defined in the CALC command.

<vf val="" /> Relative standard deviation with full precision.

<vs val=""/> Variable status (see above).

</data>  

<rel>  

– <max>  

– <data>  

<vr val="" />  

<vf val="" />  

<vs val=""/>  

</data>  

</max>  

– <min>  

– <data>  

<vr val="" />  

<vf val="" />  

</data>  

</min>  

<n val="" /> Number of the result among the statistically evaluated
results.

<nmax val="" /> Maximum number of statistically evaluated results.
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</data>  

<RS01>  

<RS02> … <RS25> Further single results (see above)

</ResultsSingle>  

4.4.4.3.6 XML export - Command data
XML export

– <CommandData dynamic=""> Command data

– <Command> Data on command

<subtype val="" />  

<data val="" /> Command name.Index

<commandType val="" /> Command type.

– <CommandVars dynamic=""> Command variables

– <data>  

<vt val="" /> Variable type:

TX = Text

NR = Number

DT = Date/Time

NA = Unknown

<vn val="" /> Variable identification

<vr val="" /> Variable value.

</data>  

</CommandVars>  

– <Sensor> Data on sensor.

<subtype val="" /> Type of sensor:

XML_SENSOR_OTHER = Other sensor

XML_SENSOR_PH = pH sensor

XML_SENSOR_ION = ISE sensor

XML_SENSOR_METAL = Metal sensor

XML_SENSOR_TEMP = Temperature sensor

XML_SENSOR_COND = Conductivity sensor

– <sensorData> Data on sensor.

<sensorName val="" /> Sensor name.



4.4 Templates ￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭

192 ￭￭￭￭￭￭￭￭ tiBase 1.0

<sensorType val="" /> Sensor type.

<sensorOrderNo val="" /> Order number of sensor.

<sensorSerialNo val="" /> Serial number of sensor.

<sensorInitDate val="" /> Date on which the sensor was used for the first time.

<sensorCellConst val="" /> Cell constant of the conductivity sensor.

<sensorSlope val="" /> Slope of the sensor.

<sensorPh0 val="" /> Electrode zero point of the pH sensor.

<sensorIonVa val="" /> Ion (valency) of the ISE sensor.

<sensorE0 val="" /> Electrode zero point of the sensor.

<sensorC val="" /> Blank value of the ISE sensor.

<sensorCalTemp val="" /> Calibration temperature.

<sensorCalDate val="" /> Calibration date.

<sensorCalMethod val="" /> Calibration method.

</sensorData>  

</Sensor>  

</Device>  

– <CalibData> Calibration data

<sensorName val="" /> Sensor name.

<sensorType val="" /> Sensor type.

<sensorSlope val="" /> Slope of the sensor.

<sensorPh0 val="" /> Electrode zero point of the pH sensor.

<sensorIonVa val="" /> Ion (valency) of the ISE sensor.

<sensorE0 val="" /> Electrode zero point of the sensor.

<sensorC val="" /> Blank value of the ISE sensor.

<resultUnit val="" /> Concentration unit of calibration.

<variance val="" /> Variance of calibration.

<sensorCalTemp val="" /> Calibration temperature.

<sensorCalTempType val="" /> Calibration mode.

<sensorCalDate val="" /> Calibration date.

<sensorCalMethod val="" /> Calibration method.

– <CalibrationTable> Calibration solutions.

– <header> Column headers.
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<<RowDesc val="" /> Column header for buffers/standards.

<NominalVal val="" /> Column header for nominal value.

<MeasVal val="" /> Column header for measured value.

<CalTemp val="" /> Column header for calibration temperature.

<CalDur val="" /> Column header for duration of measurement.

<header>  

– <body dynamic="">  

– <data>  

<RowDesc> ... </RowDesc> Buffer/Standard.

<NominalVal> ... </NominalVal> Nominal value.

<MeasVal> ... </MeasVal> Measured value.

<CalTemp> ... </CalTemp> Calibration temperature.

<CalDur> ... </CalDur> Duration of measurement in s.

</data>  

</body>  

</CalibrationTable>  

</CalibData>  

– <StdAddData> Standard addition data

<slope val="" /> Calculated slope of the standard addition curve.

<e0 val="" /> Calculated axis intercept of the standard addition curve.

<ion val="" /> Ion (Valency).

<conc val="" /> Calculated valency.

<concUnit val="" /> Concentration unit.

<variance val="" /> Variance.

– <StdAddTable> Standard addition solutions.

– <header> Column headers.

<RowDesc val="" /> Column header for measuring solution.

<dV val="" /> Column header for addition volume.

<MeasVal val="" /> Column header for measured value.

<dU val="" /> Column header for measured value differential.

<Dur val="" /> Column header for duration of measurement.

</header>  
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– <body dynamic="">  

– <data>  

<RowDesc> ... </RowDesc> Measuring solution.

<dV> ... </dV> Addition volume in mL.

<MeasVal> ... </MeasVal> Measured value in mV.

<dU> ... </dU> Measured value differential in mV.

<Dur> ... </Dur> Duration of measurement in s.

</data>  

</body>  

</StdAddTable>  

</StdAddData>  

– <MeasPoints content-
Type="table">

Measuring points

– <tableHeader> Column headers.

– <th>  

<vr val="" /> Column header.

</th>  

</tableHeader>  

– <tableBody> Measuring points.

– <td>  

<vr val="" />  

<vf val="" />  

</td>  

</tableBody>  

</MeasPoints>  

– <EndPoints dynamic=""> Endpoints

– <data>  

<ept val="" /> Designation of the endpoint.

<epvx val="12.1835" /> X value of the endpoint.

<epux val="mL" /> Unit of the x value of the endpoint.

<epvy val="518.5" /> Y value of the endpoint.

<epuy val="mV" /> Unit of the y value of the endpoint.
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</data>  

</EndPoints>  

</Command>  

</CommandData>  

4.4.4.3.7 XML export - Common Variables
XML export

– <Comvars dynamic> Common variables

– <data>  

<subtype val="" />  

<vr val="" /> Variable value.

<vs val="" /> Variable status:

OK = The value is ok and has not been monitored.

OKL = The value is ok and has been monitored.

LE = The value exceeded the limit and has not been moni-
tored.

LEL = The value exceeded the limit and has been moni-
tored..

NV = The value is invalid and has not been monitored.

NVL = The value is invalid and has been monitored.

<vt val="" /> Variable type:

TX = Text

NR = Number

DT = Date/Time

NA = Unknown

<vn val="" /> Variable name.

<un val="" /> Unit of the variable.

<am val="" /> Assignment method.

<at val="" /> Assignment date.

</data>  

</Comvars dynamic>  
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4.4.4.3.8 XML export - Device data
XML export

– <usedDevices dynamic=""> Device data

– <Device> Data on device.

<subtype val="" />  

– <deviceType> Device type.

<vn val="" /> Parameter name.

<vr val="" /> Parameter value.

</deviceType>  

– <deviceName> ... </device-
Name>

Device name.

– <instrNo> ... </instrNo> Device serial number.

– <deviceProgNo> ... </device-
ProgNo>

Device program number.

– <rackName> ... </rackName> Rack name.

– <rackCode> ... </rackCode> Rack code.

– <towerNoOne> ... </tower-
NoOne>

Tower number.

– <swingHeadOneType> ... </
swingHeadOneType>

Type of Swing Head on tower 1.

– <swingHeadOneSerial> ... </
swingHeadOneSerial>

Serial number of the Swing Head on tower 1.

– <towerNoTwo> ... </tower-
NoTwo>

Tower number.

– <swingHeadTwoType> ... </
swingHeadTwoType>

Type of Swing Head on tower 2.

– <swingHeadTwoSerial> ... </
swingHeadTwoSerial>

Serial number of the Swing Head on tower 2.

– <devicePorts dynamic=""> Data on the peripheral devices connected.

– <Port>  

<subtype val="" /> Type of the device connected to the port:

XML_PORT_DEVICE_DOS = Dosing/Exchange unit

XML_PORT_DEVICE_REMOTE  = Remote Box

XML_PORT_DEVICE_STIR  = Stirrer
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– <dosPortName> ... </dosPort-
Name>

Number of the MSB connector the dosing device was con-
nected to.

– <dosType> ... </dosType> Dosing device type.

– <dosSerial> ... </dosSerial> Dosing device serial number.

– <exchDosUnit> Data on exchange/dosing unit.

– <exdosTitle> ... </exdosTitle> Designation of the exchange/dosing unit.

– <exdosName> ... </exdos-
Name>

Name of the exchange/dosing unit.

– <exdosType> ... </exdosType> Type of exchange/dosing unit.

– <exdosOrder> ... </exdosOr-
der>

Order number of exchange/dosing unit.

– <exdosSerial> ... </exdosSerial> Serial number of exchange/dosing unit.

– <cylVol> ... </cylVol> Cylinder volume of exchange/dosing unit.

– <cylSerial> ... </cylSerial> Cylinder serial number of exchange/dosing unit.

– <Solution> Data on solution.

– <solTitle> ... </solTitle> Solution title.

– <solutionName> ... </solution-
Name>

Solution name.

– <conc> ... </conc> Concentration.

– <concUnit> ... </concUnit> Concentration unit.

– <solCreationTime> ... </solCrea-
tionTime>

Production date.

– <titer> ... </titer> Titer value.

– <titerUnit> ... </titerUnit> Titer unit.

– <titerCreationTime> ... </titer-
CreationTime>

Date and time of the last titer determination.

– <titerMethod> ... </titerMe-
thod>

Name of the method with which the last titer determina-
tion was carried out.

</Solution>  

</exchDosUnit>  

– <stirrerPortName> ... </stirrer-
PortName>

Number of the MSB connector the stirrer was connected
to.

– <stirrerType> ... </stirrerType> Type of stirrer.

– <serialStirrer> ... </serialStir-
rer>

Serial number.
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– <remotePortName> ... </remo-
tePortName>

Number of the MSB connector the Remote Box was con-
nected to.

– <remoteType> ... </remote-
Type>

Type of Remote Box.

</Port>  

</devicePorts>  

</Device>  

</usedDevices>  

4.4.4.3.9 XML export - Sensor data
XML export

– <usedSensors dynamic=""> Sensor data

– <Sensor> Data on sensor.

<subtype val="" /> Type of sensor:

XML_SENSOR_OTHER = Other sensor

XML_SENSOR_PH = pH sensor

XML_SENSOR_ION = ISE sensor

XML_SENSOR_METAL = Metal sensor

XML_SENSOR_TEMP = Temperature sensor

XML_SENSOR_COND = Conductivity sensor

– <sensorData> Data on sensor.

<sensorName val="" /> Sensor name.

<sensorType val="" /> Sensor type.

<sensorOrderNo val="" /> Order number of sensor.

<sensorSerialNo val="" /> Serial number of sensor.

<sensorInitDate val="" /> Date on which the sensor was used for the first time.

<sensorSlope val="" /> Slope of the sensor.

<sensorPh0 val="" /> Electrode zero point of the pH sensor.

<sensorIonVa val="" /> Ion (valency) of the ISE sensor.

<sensorE0 val="" /> Electrode zero point of the sensor.

<sensorC val="" /> Blank value of the ISE sensor.

<sensorCalTemp val="" /> Calibration temperature.

<sensorCalDate val="" /> Calibration date.
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<sensorCalMethod val="" /> Calibration method.

<sensorCalUser val="" /> User

<sensorCalMeasInput val="" /> Measuring input at calibration.

</sensorData>  

</Sensor>  

</usedSensors>  

4.4.4.3.10 XML export - Statistical data
XML export

– <Statistics> Statistical data

<subtype val="" />  

<nMax val="" /> Maximum number of statistically evaluated results.

– <StatisticsShort dynamic=""> Statistical data on the separate results.

– <data>  

<subtype val="" />  

– <resName>  

<vr val="" /> Result name.

<vf val="" />  

</resName>  

– <n> ... </n> Number of the result among the statistically evaluated
results.

– <sme> ... </sme> Mean value of the result.

– <un> ... </un> Result unit.

– <abs> ... </abs> Absolute standard deviation of the result.

– <rel> ... </rel> ... Relative standard deviation of the result.

– <min> ... </min> ... Minimum value of the result.

– <max> ... </max> ... Maximum value of the result.

</data>  

</StatisticsShort>  

– <StatisticsOverview content-
Type="table">

Statistical data overview

<subtype val="" />  

– <tableHeader> Column headers (dynamic).
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– <th>  

<vr val="" /> Column header.

</th>  

</tableHeader>  

– <tableBody> Table content (dynamic).

– <td>  

<vr val="" /> Field content.

</td>  

</tableBody>  

</StatisticsOverview>  

</Statistics>  

4.5 Determination overview

4.5.1 Determination overview - General

4.5.1.1 Determination overview - Overview

Subwindow: Database ▶ Determination overview

General

The subwindow Determination overview shows selected data for the
determinations contained in the open database in tabular form. It is always
shown in the program part Database, i.e. it cannot be removed from the
Database view. The subwindow can be enlarged and reduced as required;
it can also be maximized.

Elements

The subwindow Determination overview includes the following tools:

￭ Determination table
￭ Filter selection
￭ Navigation bar

4.5.1.2 Determination overview - Table  

Subwindow: Database ▶ Determination overview

Data display

In the determination table the information about the determinations defined
under Column display is shown. If the contents of a field is larger than the
column width then the whole contents will be shown as a tooltip if the
mouse cursor is kept on the field.



￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭ 4 Database

tiBase 1.0 ￭￭￭￭￭￭￭￭ 201

If the value of a result is monitored and lies within the limits defined, then
it will be shown in green. If it is outside these limits then the value will be
shown in red.

Note

Lines that contain red entries will also show the line number with a red
background.

Updating

As long as the program part Database remains open modifications in the
determination table, caused by running determinations or by other users
(addition, editing or deletion of data sets), will not be shown automatically.
The table must either be updated with View ▶ Update or newly sorted or
filtered. Each switch from a different program part to the program part
Database automatically updates the determination table. 

Table view

With a click on the column title the table can be sorted according to the
selected column in either increasing or decreasing sequence. The table view
can be adapted with the left-hand mouse button as follows:

￭ Drag the border between column titles:
Sets the column width.

￭ Double-click on the border between column titles
Sets the optimal column width.

￭ Drag the column title
Moves the column to the required location.

Data record selection and table navigation

The determinations selected in the table are shown in turquoise, the
focused determination whose data is shown in the other Subwindows is
indicated by an arrow in front of the line number. There are various oppor-
tunities for data set selection in the table.

In the determination table it is not possible to show more than 200 deter-
minations at once. If more than 200 data sets are present in the database
then the Navigation bar must be used to switch to further sets of determi-
nations.

4.5.1.3 Determination overview - Column display 

Dialog window: Database ▶ View ▶ Properties ▶ Column display… ▶ Column display

View ▶ Properties ▶ Column display… opens the dialog window Col-
umn display. Here you can define the columns that are to be shown in the
determination table.
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Available columns

Shows all the fields that can be shown as columns in the determination table.

Displayed columns

Shows all the fields that will be shown as columns in the determination table.

Default name

Non-editable name of the field that is displayed as column.

Displayed name

Editable name (by double click) of the column displayed in the determination
overview.

Adds the selected column to the table.

Removes the selected column from the table.

Move selected column upwards.

Move selected column downwards.

4.5.1.4 Determination overview - Filter selection 

Subwindow: Database ▶ Determination overview

Filter

Selection of the filter according to which the Determination table is to be
filtered:

Selection All determinations | All statistics records | Quick
filter | Temporary filter | Filter name

Default value All determinations

All determinations
The table is shown unfiltered.

All statistics records
The table is filtered so that all determinations are shown that are linked
statistically with the selected determination.

Quick filter
The table is filtered according to the last defined Quick filter
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Temporary filter
The table is filtered according to the last defined, not saved Special fil-
ter.

Filter name
The table is filtered according to the selected and saved Special filter.

Statistics

With the statistics filter selected here the determinations shown in the
Determination table can be additionally filtered according to the statistical
data generated by the method independently of any other filters that may
have been used.

Selection All | Last

All
All determinations are shown for all statistics series.

Last
Only the last determination is shown for all statistics series.

4.5.1.5 Determination overview - Navigation bar

Subwindow: Database ▶ Determination overview

The navigation bar shown below the determination table is used for navi-
gation in extensive tables in which all the determinations cannot be shown
at once. It contains the following tools:

Jump to the first set of determinations in the table.

Jump back to the previous set of determinations in the table.

Display the selected set #### - #### of determinations in the table. If the
table has not been filtered then the total number of all determinations will
be shown. If the table has been filtered the total number of filtered deter-
minations is shown with (filtered).

Jump further to the next set of determination in the table.

Jump to the last set of determinations in the table.
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4.5.1.6 Determination overview - Table navigation 

Subwindow: Database ▶ Determination overview

In the determination table navigation can be carried out with the mouse and
the vertical and horizontal scroll bars. The following possibilities are also
provided by the keyboard:

[ ↑ ]
Moves the line cursor up by one field.

[ ↓ ]
Moves the line cursor down by one field.

[Ctrl] [End]

Jumps to the last determination in the current set.

[Ctrl] [Home]

Jumps to the first determination in the current set.

[Page Up]

Pages backward within the current set.

[Page Down]

Pages forward within the current set.

[Alt] [End]

Jumps to last determination (of all).

[Alt] [Home]

Jumps to first determination (of all).

[Alt] [ ↑ ]
Jumps to first data set of previous set.

[Alt] [ ↓ ]
Jumps to first data set of next set.

In the determination table it is not possible to show more than 200 deter-
minations at once. If more than 200 determinations are present in the
database then the Navigation bar must be used to switch to further sets of
determinations.
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4.5.1.7 Determination overview - Data record selection 

Subwindow: Database ▶ Determination overview

The determinations selected in the table are shown in turquoise, the
focused determination whose data is shown in the other Subwindows is
indicated by an arrow in front of the line number. When a database is
opened the first determination is always selected and focused.

The following possibilities are available for the selection of determinations
in the determination table:

￭ Single determinations
Single determinations are selected by clicking on them with the mouse
within the line (including line number). This determination, whose data
is shown in the other opened subwindows, is now focused and receives
an arrow in front of the line number.

￭ Several determinations in sequence
In order to select several determinations in sequence the required range
can be selected with the left mouse button pressed down. It is also pos-
sible to select a range with a click on the first determination and [Shift]
& click on the last determination. The last determination to be selected
receives the focus.

￭ Several determinations not in sequence
In order to select several determinations not in sequence the individual
determinations must be selected with the Ctrl key and the left mouse
button. The last determination to be selected receives the focus.

￭ All determinations
With [Ctrl] [A] or by clicking on the uppermost left-hand table field all
the filtered determinations within the current set of determinations are
selected. The focus is retained.

4.5.1.8 Determination overview - Functions

Subwindow: Database ▶ Determination overview

With the determinations selected in the Determination table the following
functions can be carried out:

Editing determinations

￭ Update determination overview
￭ Enter determination comment
￭ Sign determinations
￭ Export determinations
￭ Import determinations
￭ Send determinations to
￭ Reprocess determinations
￭ Delete determinations
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Search and filter determinations

￭ Search determinations
￭ Filter determinations

Other functions

￭ Determination overview - Print
￭ Print report
￭ Determinations - Display history
￭ Determinations - Control chart
￭ Determinations - Overlay curves
￭ Print overlaid curves
￭ Print control chart

4.5.2 Determination overview - Functions

4.5.2.1 Update determination overview

Menu item: Database ▶ View ▶ Update

The menu item View ▶ Update or the symbol    is used to update the
determination table.

Note

The determination table is updated automatically when the database is
opened and when a change is made from another program part to the
program part Database, but afterwards only when the table is newly
sorted or filtered.

4.5.2.2 Determination comment

Dialog window: Database ▶ Determinations ▶ Comment… ▶ Determination com-
ment

With the menu item Determinations ▶ Comment… or the symbol  the
dialog window Determination comment opens in which new comments
on the selected determination can be entered an existing comment can be
edited.

Comments entered this way appear automatically as a Tooltip text when the
cursor line is kept on the number field of a line in the determination table
for more than 1 second. In addition, it is also displayed in the subwindow
Information.
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4.5.2.3 Searching for determinations

Dialog window: Database ▶ Determinations ▶ Search... ▶ Search - Database

With the menu item Determinations ▶ Search... or the symbol     the
dialog window Search - Database for searching for determinations is
opened.

Search in

Selection of the data field to be searched in.

Selection All fields | 'Field name'

All fields
It is being searched in all fields of the database.

'Field name'
It is being searched in the selected field only. Available are always the 10
most recently selected fields.

[More...]

Open the dialog window Search – Field selection. All fields are listed in
tree-form. A field can be included in the search by marking it and then closing
the dialog with [OK].

Details

Depending on the data field, under Details further selection fields are
dynamically created in order to be able to select the required property.

Search options

Type

Selection of the format type for the fields for which several types are possible.
With fields with a fixed type only this one will be displayed.

Selection Text | Date | Number
Default value Text

Operator

Selection of the relational operator for the search condition.

for fields of the type = Text
Selection = | <> | empty | not empty
Default value =

for fields of the type = Date
Selection = | <> | < | <= | > | >= | empty | not empty | inva-

lid | outside limits | Today
Default value =
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invalid
It is being searched for values with the entry invalid .

outside limits
It is being searched for values which exceed the limit values defined for
the selected fields (values presented in red).

Today
It is being searched for the current date. In addition, a range of days can
also be defined in the field Search word in which, starting from the
current date, the search is to be carried out.

for fields of the type = Number
Selection = | <> | < | <= | > | >= | empty | not empty | inva-

lid | outside limits
Default value =

invalid
It is being searched for values with the entry invalid .

outside limits
It is being searched for values which exceed the limit values defined for
the selected fields (values presented in red).

Search word

Enter a search word for searching the selected data field. For fields of the
Type = Date the date can be selected by pressing on [...] in the dialog
window Select date.

for fields of the type = Text
Input 256 characters

Definition of a text expression as search word. The
last 10 search words are saved and can be selected.
The following wildcards can be used in the search
word:

Selection ^? | ^# | ^$ | ^*

^?
Wildcard for any character.

^#
Wildcard for any number.

^$
Wildcard for any letter.

^*
Wildcard for any character string.
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for fields of the type = Date
Input all possible date values

Definition of a date as search word. The last 10 search
words are saved and can be selected.

for fields of the type = Date and Operator = Today
Range -9999 ... 9999 
Default value 0 

Definition of a numerical value as range of days in
which, starting from the current date, the search is to
be carried out. The last 10 search words are saved and
can be selected.

for fields of the type = Number
Input all possible numerical values

Definition of a numerical value as search word. The
last 10 search words are saved and can be selected.

Search direction

Selection of the search direction.

Selection Total | Downward | Upward
Default value Total

Total
It is being searched down to the end of the database and then again
from above down to the selected data record.

Downward
It is being searched to the end of the databse.

Upward
It is being searched to the beginning of the databse.

Match case

on | off (Default value: off)

If this option is enabled, then differentiation will be made between upper
and lower case letters during searches in Text-type fields.

Search for whole word only

on | off (Default value: off)

If this option is enabled, then the field contents must be identical with the
search word during searches in Text-type fields (no part-search).

[Search next]

Search next occurrence of the search word.
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4.5.2.4 Filter determinations

4.5.2.4.1 Filter determinations - Overview 

Subwindow: Database ▶ Determination overview

The following possibilities exist for filtering determinations in the Determi-
nation table:

￭ Search filter selection in the filter list
￭ Quick filter
￭ Special filter
￭ Last filter
￭ Remove filter

4.5.2.4.2 Determinations - Last filter 

Menu item: Database ▶ Determinations ▶ Filter ▶ Last filter

With the menu item Determinations ▶ Filter ▶ Last filter or the symbol

 the most recently used filter will be activated.

4.5.2.4.3 Determinations - Quick filter 

Menu item: Database ▶ Determinations ▶ Filter ▶ Quick filter

With the menu item Determinations ▶ Filter ▶ Quick filter or the symbol

 a quick filtering for the content of the selected tabular field can be carried
out. After this function has been selected the field in the determination table
in which the cursor is located will be shown with a colored background
during navigation. At the same time the following special filter symbol
appears:

By double-clicking with the left mouse button set the content of the selected
field as filter criterion and apply directly on the table.

Note

The quick filter can be used again within the filtered table, so that the
number of entries can be limited step by step.

4.5.2.4.4 Determinations - Special filter 

Dialog window: Database ▶ Determinations ▶ Filter ▶ Special filter… ▶ Special filter
- Database "Database name"

With the menu item Determinations ▶ Filter ▶ Special filter... or the

symbol  the dialog window Special filter - Database opens for defining
user-specific filters.
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Filter

Selects the filter to be loaded for processing.

Selection 'Filter name' | New filter
Default value New filter

'Filter name'
The saved filter is loaded.

New filter
An empty table with the name New filter is loaded.

[Save filter]

Opens the dialog window Save filter in which the filter criteria entered in
the table can be saved as a special filter under the required name.

[Delete filter]

Deletes the special filter that is currently loaded.

Table view

The overview table shows all the defined filter criteria and cannot be directly
edited. The filter conditions will be numbered automatically in sequence.
The table view can be adapted with the left-hand mouse button as follows:

￭ Drag the border between column titles:
Sets the column width

￭ Double-click on the border between column titles
Sets the optimal column width

If the contents of a field is larger than the column width then the whole
contents will be shown as a tooltip if the mouse cursor is kept on the field.

For the meaning of the columns, see Edit filter criterion.

Functions

The menu [Edit] beneath the filter table contains the following menu items:

Edit line Open the dialog window Edit filter criterion in which the filter criterion of the
line selected in the table can be edited.

Insert new line Inserts a new empty line above the line selected in the table. The dialog window
Edit filter criterion opens automatically.

Cut lines Transfer selected lines to clipboard.

Copy lines Copies selected lines to the clipboard.

Paste lines Insert lines from the clipboard above the selected line.

Delete lines Deletes the selected lines.



4.5 Determination overview ￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭

212 ￭￭￭￭￭￭￭￭ tiBase 1.0

[Apply filter]

Applies filter criteria to Determination table.

4.5.2.4.5 Determinations - All statistics data sets

Menu item: Database ▶ Determination ▶ Filter ▶ All statistics sets

With the menu item Determinations ▶ Filter ▶ All statistics data sets

or the symbol  all determinations statistically linked with the selected
determination are displayed.

4.5.2.4.6 Determinations - Delete filter

Menu item: Database ▶ Determinations ▶ Filter ▶ Remove filter

With the menu item Determinations ▶ Filter ▶ Delete filter or the symbol

 the most recently used filter will be deleted and all determinations will
be displayed.

4.5.2.4.7 Determinations - Save filter

Dialog window: Database ▶ Determinations ▶ Filter ▶ Special filter... ▶ Special filter

- Database "Database name" ▶ [Save filter] ▶ Save filter

With the button [Save filter] in the dialog window Special filter - Data-
base "Database name" the dialog window Save filter opens for saving
a special filter.

All the saved special filters are shown in the upper field.

Filter name

Name under which the special filter is to be saved.

Input 50 characters

[Save]

Saves filter under given name.

Note

The filters are saved globally in the configuration database and are there-
fore available for all clients.

4.5.2.4.8 Determinations - Edit filter condition

Dialog window: Database ▶ Determinations ▶ Filter ▶ Special filter ▶ Special filter -

Database "Database name" ▶ [Edit] ▶ Edit line ▶ Edit filter criterion 'Filter name'

With the command Edit ▶ Edit line in the dialog window Special filter -
Database "Database name" the dialog window Edit filter criterion #
opens, in which the filter criterion selected in the filter table can be edited.
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Link

Selection of the logic operator with the previous filter criterion.

Selection AND | OR
Default value AND

AND
Logical "AND" link

OR
Logical "OR" link

Field

Selection of a data field for which a condition is to be formulated.

Selection 'Field name'
Filtering is carried out only for the selected field. The
10 most recently selected fields are always available
for selection.

[Other...]

Open the dialog window Filter - Field selection. Herein all fields that can
be used for filtering are listed in tree-form. A field can be adopted by marking
it and then closing the dialog with [OK].

Details

Depending on the data field, further selection fields are created under Details
in order to be able to select the desired property.

Condition

Type

Selection of the type of format for fields in which several types are possible.
For fields with a fixed type only this type will be shown.

Selection Text | Number | Date
Default value Text

Operator

Selection of the comparison operator for the filter criterion.

Only for fields of the type = text
Selection = | <>
Default value =

Only for fields of the type = date
Selection = | <> | < | <= | > | >= | Today
Default value =
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Today
A search is made for the current date. In addition, a range of days can
also be defined the field Comparison value in which, starting from the
current date, the filtering is to be carried out.

For fields of the type = number
Selection = | <> | < | <= | > | >= | empty | not empty | inva-

lid | out of limits
Default value =

invalid
Filtering is carried out for values with the entry invalid.

out of limits
Values that are out of the defined limits for the selected fields will be
filtered for (values shown in red).

Comparative value

Selection or entry of the comparative value for the filter criterion. For fields
where Type = Date, the date can be selected by pressing [...] in the dialog
window Select date.

Only for fields of the type = text
Input 256 characters

Definition of a text expression as comparison value.
* can be used as a wildcard for any sequence of char-
acters if the option Use asterisk (*) as wildcard is
enabled.

Only for fields of the type = date
Input all possible date values

Definition of a date as comparison value.

For fields of the type = date and operator = today.
Range -9999 ... 9999 
Default value 0 

Definition of a numerical value as a range in days in
which, starting from the current date, the filtering is
to be carried out.

For fields of the type = number
Input all possible numerical values

Definition of a numerical value as comparison value.
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Match case

on | off (Default value: off)

If this check box is activated then upper/lower case will be differentiated
when filtering Text-type fields.

Use asterisk (*) as wildcard

on | off (Default value: off)

If this check box is activated then when filtering Text-type fields the asterisk
* can be used as a wildcard for any character strings.

4.5.2.5 Sign determinations

4.5.2.5.1 Rules for electronic signatures
Program part: Database

In tiBase  determinations can be electronically signed at two levels. The
following rules apply for this:

￭ Signature levels
Signature levels for determinations can be signed at two levels (Signature
Level 1 and Signature Level 2) by entering the user name and password.

￭ Multiple signing
Determinations can be signed several times at each level.

￭ Sign at Level 1
If Level 2 has been signed then no more signatures are possible at Level
1.

￭ Sign at Level 2
Level 2 can only be signed if signatures already exist at Level 1.

￭ Different users
The same user may only sign on either Level 1 or Level 2.

￭ Reason and comment
Each signature must be accompanied by a reason selected from prede-
fined default reasons. A further comment can also be entered.

￭ Saved data
The signature date, user name, full name, reason and comments are
saved for each signature.

￭ Deleting signatures 1
Signatures at Level 1 are automatically deleted again when compiling a
new version.

￭ Deleting signatures 2
Signatures at Level 2 can only be deleted by users who have the appro-
priate rights.

￭ Signature options
The options for electronic signatures are set in the Signatures tab in the
Security settings dialog window.
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4.5.2.5.2 Signature Level 1

Dialog window:Database ▶ Determinations ▶ Sign ▶ Signature
1... ▶ Signature Level 1

Determinations can be signed at Level 1 in the Signature Level 1 window.

Note

Determinations which have been signed at Level 1 can be changed and
deleted. If the altered method or determination is saved as a new version
then all existing signatures will be deleted automatically, i.e. the method
or determination must be signed again.

Info

Information display for signing and deleting signatures. The following mes-
sages are possible:

Selection Signature possible | Signature 1 not possible
(signature 2 exists) | Signature not possible
(accessed by other client) | Signature not pos-
sible for multiple determinations

Signature possible
The selected determination can be signed.

Signature 1 not possible (signature 2 exists)
The selected determination can no longer be signed at Level 1 as it has
already been signed at Level 2.

Signature not possible (accessed by other client)
The selected determination cannot be signed as it is already marked to
be signed on a different client.

Signature not possible for multiple determinations
Several determinations have been selected, they may however only be
signed individually.

User

Entry of the user name (short name).

Input 24 characters

Password

Password entry.

Input 24 characters
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Reason

Selection from the Default reasons defined in the Security Settings dia-
log window for the category Signature level 1.

Selection Selection from the Default reasons

Comment

Entry of comment on the signature.

Input 1000 characters

[Sign]

Sign determination. The window remains open.

Note

Determinations can only be signed at level 1 if the user belongs to a user
group with the corresponding authorization .

4.5.2.5.3 Signature Level 2

Dialog window:Database ▶ Determinations ▶ Sign ▶ Signature
2... ▶ Signature Level 2

Determinations can be signed at Level 2 in the Signature Level 2 window.

Note

Determinations that can be signed at level 2 are blocked, i.e. they can
neither be modified nor deleted. In order to be able to edit such deter-
minations again the signatures at level 2 must first be deleted .

Info

Information for signing and deleting signatures is displayed in this box. The
following messages are possible:

Selection Signature possible | Signature 2 not possible
(signature 1 missing) | Signature not possible
(accessed by other client)

Signature possible
The selected determination can be signed.

Signature 2 not possible (signature 1 missing)
The selected determination cannot be signed at Level 2 as it has not yet
been signed at Level 1.
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Signature not possible (accessed by other client)
The selected determination cannot be signed as it is already marked to
be signed on a different client.

User

Entry of the user name (short name).

Input 24 characters

Password

Password entry.

Input 24 characters

Reason

Selection from the Default reasons defined in the Security Settings dia-
log window for the category Signature level 2.

Selection Selection from the Default reasons

Comment

Entry of comment on the signature.

Input 1000 characters

[Sign]

Sign determination. The window remains open.

Note

Determinations can only be signed at level 2 if the user belongs to a user
group with the corresponding authorization .

4.5.2.5.4 Display determination signatures 

Dialog window: Database ▶ Determinations ▶ Sign ▶ Display signatures… ▶ Signa-
tures - Determination 'Determination ID'

With the menu item Determinations ▶ Sign ▶ Show signatures... the
window Signatures - Determination 'Determination ID' opens with a
table in which information about all the signatures for the selected deter-
mination is shown.

Signature

Shows at which level the determination has been signed (Level 1 or Level
2).

Signature date

Date and time at which the determination was signed.
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User

Short name of the user who signed the determination.

Full name

Full name of the user who signed the determination.

Reason

Reason for signature.

Signature comment

Comment on the signature.

4.5.2.5.5 Delete Signature Level 2

Dialog window:Database ▶ Determinations ▶ Sign ▶ Delete signa-
tures 2... ▶ Delete Signatures Level 2

The Delete Level 2 signatures window allows you to delete all signatures
on Level 2 for the selected methods or determination.

User

Entry of the user name (short name).

Input 24 characters

Password

Password entry.

Input 24 characters

Reason

Selection from the Default reasons defined in the Security Settings dia-
log window for the category Signature level 2.

Selection Selection from the Default reasons

Comment

Entry of comment on the signature.

Input 1000 characters

[Delete]

Delete Signatures 2.
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Note

Signatures 2 can only be deleted if the user belongs to a user group with
the corresponding authorization.

4.5.2.6 Determinations - Reprocessing

4.5.2.6.1 Reprocessing - General
Dialog window: Reprocess

Reprocessing determinations

The determinations saved in the database can be reprocessed at any time.
The variables, methods, statistics and curve evaluation can be modified and
the results recalculated. The reprocessed determination can then be saved
in the database as a new version.

Note

Determinations that have a signature at level 2 cannot be reprocessed.

Opening the reprocessing window

The reprocessing of determinations that have been selected in the sub-
window Determination overview takes place in the independent dialog
window Reprocessing which is opened with Determinations ▶ Reproc-

ess... or the symbol . When the window is opened the first of the selected
determinations is always shown as standard.

Closing the reprocessing window

The dialog window Reprocessing is closed with [OK], [Cancel] or with
the Windows button for closing.

Note

The reprocessing window cannot be closed while recalculations are still
running.

4.5.2.6.2 Reprocessing - Window
Dialog window: Reprocess

Subwindow

The dialog window Reprocessing contains the following two subwindows
that can be enlarged and reduced by dragging the separating bar between
them:
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￭ Modifications
Modification of variables, method, statistics, curve evaluation

￭ Result view
Shows current results

Functions

If determinations have been edited in the subwindow Modifications then
the following functions can be triggered:

[Recalc]

Recalculate selected determination(s) with the modifications on variables,
method, statistics or curve evaluation made in the subwindow Modifica-
tions.

A progress bar appears during the recalculating, the recalculating can be

canceled with  next to the bar. The results of this recalculation are entered
automatically in the subwindow Result view.

This button is inactive until modifications have actually been made. After the
recalculation further data can be modified and then recalculation triggered
again.

[Reset]

Reset all modifications made and unsaved during reprocessing to the original
data and results.

This button is inactive for as long as no modifications have been made or
when the recalculation has not yet been triggered.

[OK]

Close the dialog window Reprocessing. Each determination that has been
modified by reprocessing will be saved as a new version with a version num-
ber increased by +1.

This button is inactive when the recalculation has not yet been triggered and
if not all the selected determinations could have been recalculated.

[Cancel] or 

Close the dialog window Reprocessing. The result of the reprocessing
made since the last saving will not be saved.

Note

If the option Comment on modification of determinations is ena-
bled under Configuration ▶ Tools ▶ Security settings ▶ Audit Trail/
Modifications, the dialog window Modification comment determi-
nation is displayed before saving.



4.5 Determination overview ￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭

222 ￭￭￭￭￭￭￭￭ tiBase 1.0

4.5.2.6.3 Reprocessing rules
Dialog window: Reprocess

The following rule applies for recalculating the selected and modified deter-
minations:

With measuring commands (DET, MET, SET, KFT, BRC, MEAS, CAL MEAS)
only the evaluations with existing data will be recalculated. All other param-
eters will be ignored.

4.5.2.6.4 Modifications

4.5.2.6.4.1 Modifications - Overview

Subwindow: Database ▶ Determination overview ▶ Determinations ▶ Reproc-

ess... ▶ Reprocessing ▶ Modifications

In the subwindow Modifications of the dialog window Reprocessing
modifications can be made on the following 4 tabs:

￭ Variables
Modification of the variables used in the selected determination.

￭ Calculations
Selected determinations will be recalculated.

￭ Statistics
Modification of statistics data.
The tab Statistics will only be shown when the last determination (and
only this one) is selected from a set of determinations which, because of
the statistics defined in the method, belong together.

￭ Curve evaluation
Manual modification of the curve evaluation.
The tab Curve evaluation is only shown when a single determination
is selected that contains curves that can be evaluated.

4.5.2.6.4.2 Modifications - Variables

Tab: Database ▶ Determination overview ▶ Determinations ▶ Reproc-

ess... ▶ Reprocessing ▶ Modifications ▶ Variables

On the tab Variables the variables used in the determination can be modi-
fied.

Variable table

The variable table shows those variables used that are present in all the
selected determinations and cannot be edited directly. With a click on the
column title (columns Variable, Value) the table can be sorted according
to the selected column in increasing or decreasing order.

Variable

Shows the name of the variable. Only the those variables are displayed which
are available in all the selected determinations and can be edited. These
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include: the method variables FCT (factor) and DIV (divisor), the sample data
variables C00 (sample size), ID1 and ID2 (sample identification, the com-
mon variables CV01 to CV25 as well as the following command variables:

￭ 1M.TITER
Titer value of the solution used in the command.

￭ 1M.CONC
Concentration of the solution used in the command.

Value

Display of the variable value. If a fixed value is defined for a variable, the
value will be presented in italics.

[Modify]

Open the dialog window Modify variable to modify the value of an existing
variable.

Note

If a variable is modified, then with [Recalculate] all the selected deter-
minations will be recalculated with the new value. If one variable is not
modified then when several determinations are recalculated the original
value of the variable will be used (i.e. variables with the same name but
different values will not be overwritten until they are deliberately modi-
fied).

4.5.2.6.4.3 Modifications - Calculations

Tab: Database ▶ Determinations ▶ Reprocess... ▶ Reprocessing ▶ Modifica-

tions ▶ Calculations

Table with calculations

The table contains details on the calculations.

Result variable

Variable, which is automically generated by the program during the evalu-
ation or by the results defined by the user.

Result name

Name of the result. This name will be shown in the result view as well as in
the report. The result name can be used in further calculations as variable
RS.Result name.VAL.

Formula

Calculation formula which can be generated after pressing  in the for-
mula editor.
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Formula lines can be deleted according to normal rules ([Delete]), copied
([Ctrl+C]), cut ([Ctrl+x]) and be pasted ([Ctrl+v])

Input 1000 characters
Default value empty

Unit

Unit of the result for the output (text only). The unit can be used in further
calculations as variable 'RS.Result name.UNI'.

Input 16 characters
Default value empty

Decimal places

Number of decimal places for the output of the calculated result. This para-
meter is ignored for results of the type text or date/time.

Range 0 ... 5 
Default value 2 

Assignment

Assign a result to a defined result column RS01 … RS25. This order specifies
in which of the 25 available result columns in the determination overview
the result is being added to. Per calculation the result columns RS01 ...
RS25 are available. Only the columns still free are made available. With
none the result will not be assigned to any column.

Range RS01 ... RS25 
Default value none 

Statistics

on | off (Default value: on)

If this check box is activated, the mean value and the absolute and relative
standard deviation are calculated for the result. This field is only active when
the statistics is enabled in the method of the imported determination (i.e.
the statistics can only then be disabled and enabled again, if it has already
been enabled in the method).

Description

Freely selectable description of the result.

Input 1000 characters
Default value empty
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Functions

[New]

Opens the dialog window Result 'Resultname' - RS# (see Chapter
4.5.2.6.4.7, page 238). A maximum of 81 result calculations can be gen-
erated. Afterwards, the button [New] will be disabled.

[Delete]

Deletes the selected calculations from the table.

[Properties]

Opens the dialog window Result 'Result name' - RS# in order to edit
calculations selected in the table (see Chapter 4.5.2.6.4.7, page 238).

4.5.2.6.4.4 Modifications - Statistics

Tab: Database ▶ Determination overview ▶ Determinations ▶ Reproc-

ess... ▶ Reprocessing ▶ Modifications ▶ Statistics

On the tab Statistics the single results for the statistics calculation can sub-
sequently be switched on and off.

Results with statistics

Result name

Selection of the statistically evaluated result by using the result name for
which the single results of all determinations are shown.

Selection Result name

Table of single results

For the result selected above the following data for the individual determi-
nations is shown:

Determination start

Shows the date and time at which the determination was started.

Version

Shows the version number of the determination.

Sample size

Shows the sample size.

Result value

Shows the result value. The statistics data (mean value, standard deviations,
etc.) for the selected determination are listed in the subwindow Result
view (see Chapter 4.5.2.6.5, page 240).
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[Determination on/off]

All single results of the selected determination for statistical calculations can
be switched off or on. If the determination is switched off then an asterisk
(*) appears behind all result values in the table and the line is shown as
inactive (gray); if it is switched on again then the asterisks will disappear.
However, updating the statistics data always only takes place with [Recal-
culate].

[Result on/off]

Switch the selected single result for the statistical calculations off or on. If
the result is switched off, an asterisk (*) appears behind the result value, is
it switched on again, the asterisk disappears. However, updating the statis-
tics data always only takes place with [Recalculate].

Note

If the results of a determination are switched off, the statistics for these
results will be switched off when this determination is recalculated, i.e.
no data for the mean value and standard deviations will be shown. How-
ever, the determinations remain statistically linked to each other so that
the results can also be switched on again.

4.5.2.6.4.5 Modify variable

Dialog window: Reprocessing ▶ Modifications ▶ Variables ▶ [Modify] ▶ Modifiy var-
iable

In the dialog window Modify variable the value of the selected variable is
modified.

Variable

Shows the name of the variable.

Value

Value of the variables. With variables of the type Date the date must be
entered in the dialog window (see Chapter 2.5.1, page 67).

Range -1.0 E+99 ... 1.0 E+99 
(for Type = Number)

Input 100 characters
(for Type = Text)

Selection 'Date'
(for Type = Date/Time)
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4.5.2.6.4.6 Curve evaluation

4.5.2.6.4.6.1 Modifications - Curve evaluation

Tab: Database ▶ Determinations ▶ Reprocess... ▶ Reprocessing ▶ Modifica-

tions ▶ Curve evaluation

On the tab Curve evaluation the curves that can be manually evaluated
are displayed.

Command name

Selection of the measuring command (command name.index - com-
mand type) for which the curve is to be shown for reprocessing.

Selection Command name

[Edit]

The dialog window Curve evaluation opens for manually reprocessing the
curve evaluation.

4.5.2.6.4.6.2 Edit curve evaluation

Dialog window: Database ▶ Determinations ▶ Reprocess... ▶ Reprocessing ▶ Mod-

ifications ▶ Curve evaluation ▶ [Edit] ▶ Curve evaluation

In the dialog window Curve evaluation the evaluation of the selected curve
can be reprocessed manually.

In the curve those EP's are indicated, which have values for the dimensions
of the x and y axis, i.e. manually set EP's are possibly not indicated.

Command name

Selection Command name

Command name
Selection of the measuring command for which the curve is to be shown
for reprocessing.

Toolbar

The toolbar above the curve contains symbols for the following functions
for re-evaluation of the curve:

Set EP manually

By moving the mouse a point on the curve is selected. The current
X and Y values are shown graphically with a blue cross hair and
numerically above the curve in the fields X and Y. A new endpoint
can be set by clicking with the left mouse button. This function is
activated as standard when the window Curve evaluation is
opened.
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Set EP with intersection lines

By moving the mouse a point on the curve is selected to which the
tangent is automatically applied. The first tangent is set by clicking
the left mouse button. The mouse is then used to select a second
point to which the second tangent is to be applied. The second
tangent is set with clicking the left mouse button and at the same
time a new endpoint is set at the point where both tangents inter-
sect.

Set EP with parallel tangents

By moving the mouse a point on the curve is selected to which the
tangent is automatically applied. At the same time a tangent parallel
to it is applied to the other leg of the curve. The two tangents are
set with a click of the left mouse button and at the same time a new
endpoint is set at the intersection of the middle line of the two tan-
gents with the curve.

Note

If new endpoints are set manually or by intersection or tangent evaluation
or if existing endpoints are deleted then the endpoints will always be
renumbered from left to right. During recalculation the automatic evalu-
ations will generally no longer be used for curves, i.e. the endpoints
defined in the curve evaluation are retained.

Set horizontal auxiliary lines

By moving the mouse a horizontal auxiliary line is drawn in the
graph; this can be set by clicking the left mouse button. This function
is only active when under Curve evaluation ▶ Proper-
ties ▶ Properties - Curves 1 ▶ Options the option Show
evaluation lines is enabled.

Set vertical auxiliary lines

By moving the mouse a vertical auxiliary line is drawn in the graph;
this can be set by clicking the left mouse button. This function is
only active when under Curve evaluation ▶ Properties ▶ Prop-
erties - Curves 1 ▶ Options the option Show evaluation
lines is enabled.

Delete endpoints and auxiliary lines

With the context-sensitive menu item Delete EP# the selected
endpoint can be deleted, with Delete ###.### the selected aux-
iliary line can be deleted.
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Zooming

By drawing out a rectangle with the left mouse button the selected
area can be zoomed.

Reset zoom

The graph will be reset to zoom level 100%.

Copy to clipboard

The content of the curve window is copied to the clipboard.

Define properties for the graph display

The dialog window Properties - Curves # is opened for graph
display. The curve properties defined for each command type are
saved for the reprocessing window per client.

Show EP list

The dialog window Endpoints is opened in which all endpoints of
the selected curve are displayed in a table. If an endpoint is added
to or deleted from the curve then the table will be updated auto-
matically.

Show coordinates

The current coordinates of the cursor are shown in the coordinate display:

X:

X-coordinate.

Y:

Y-coordinate.

4.5.2.6.4.6.3 Curve evaluation - Endpoint list

Dialog window: Database ▶ Determinations ▶ Reprocess... ▶ Reprocessing ▶ Mod-

ifications ▶ Curve evaluation ▶ [Edit] ▶ Curve evaluation ▶ Show EP list ▶ Endpoints

The dialog window Endpoints opened with the icon  shows all auto-
matically found and manually set endpoints of the selected curve in tabular
form. The endpoints are sorted according to ascending volume, if an end-
point is deleted from or added to the curve then the table will be updated
automatically.

Endpoint

Designation of the endpoint with number. The following names are possible:

Selection EP#
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EP#
Endpoint that has been determined automatically by potentiometric eval-
uation or set manually by using the intersection or tangent method.

Selection BP#

BP#
Endpoint that has been determined by automatic break point evaluation.

Selection FP#

FP#
Endpoint that has been determined by automatic fixed point evaluation.

Volume

Volume value in mL for endpoint.

Measured value

Measured value (pH) for endpoint.

ERC

ERC value for the endpoint.

Time

Time for the endpoint.

Temperature

Temperature for the endpoint.

Note

Manually set endpoints only have two measured quantities, for the other
measured quantities invalid is entered.

[Delete]

Delete selected endpoint.

[Exit]

Close dialog window.
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4.5.2.6.4.6.4 Curve evaluation - Properties

4.5.2.6.4.6.4.1 Properties curve evaluation - Overview

Dialog window: Database ▶ Determinations ▶ Reprocess... ▶ Reprocessing ▶ Curve

evaluation ▶ [Edit] ▶ Curve evaluation ▶ Icon 'Properties and Graphical dis-

play' ▶ Properties - 'Curve #'

The properties of the curve display in the dialog window Properties -
'Curve #' can be set on the following 4 tabs:

￭ x axis
Parameters for the graphical display of the curves on the x axis.

￭ y axis
Parameters for the graphical display of the curves on the left y axis.

￭ y2 axis
Parameters for the graphical display of the curves on the right y axis.

￭ Options
Options for graphical display of curves.

4.5.2.6.4.6.4.2 Properties curve evaluation - x axis

Tab: Database ▶ Determinations ▶ Reprocess... ▶ Reprocessing ▶ Curve evalua-

tion ▶ [Edit] ▶ Curve evaluation ▶ Properties ▶ x axis

On the tab x axis the parameters for the graphical display of the curves on
the x axis can be set.

Command type

Shows the type of command for which the curve properties can be defined.
The curve properties defined for each command type for the reprocessing
window are saved per client.

Autoscaling

on | off (Default value: on)

If this option is switched on then all axes in the curve window will be scaled
automatically. In this case the fields Start value and End value cannot be
edited.

Size

Selection Command-dependent selection

Command-dependent selection
Selection of the quantity to be shown on the x axis.

Label

Freely definable axis label for the x axis.

Selection 50 characters | auto
Default value auto
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auto
The designation from the field Size will be used.

Scaling

Fixed scaling of the x axis between the start value and the end value.

Start value

Initial value for scaling the x axis.

Only editable when the option Autoscaling is disabled.
Range -1.0E12 ... 1.0E12 
Default value 0 

End value

End value for scaling the x axis.

Only editable when the option Autoscaling is disabled.
Range -1.0E12 ... 1.0E12 
Default value 1000 

4.5.2.6.4.6.4.3 Properties curve evaluation - y axis

Tab: Database ▶ Determinations ▶ Reprocess... ▶ Reprocessing ▶ Curve evalua-

tion ▶ [Edit] ▶ Curve evaluation ▶ Properties ▶ y axis

On the tab y axis the parameters for the graphical display of the curves on
the y axis (left y axis) can be set.

Command type

Shows the type of command for which the curve properties can be defined.
The curve properties defined for each command type for the reprocessing
window are saved per client.

Autoscaling

on | off (Default value: on)

If this option is switched on then all axes in the curve window will be scaled
automatically. In this case the fields Start value and End value cannot be
edited.

Size

Selection Command-dependent selection

Command-dependent selection
Selection of the quantiy to be shown on the y axis.

Label

Freely definable axis label for the y axis.
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Selection 50 characters | auto
Default value auto

auto
The designation from the field Size will be used.

Scaling

Fixed scaling of the y axis between the start value and the end value.

Start value

Initial value for scaling the y-axis.

Only editable when the option Autoscaling is disabled.
Range -1.0E12 ... 1.0E12 
Default value 0 

End value

End value for scaling the y-axis.

Only editable when the option Autoscaling is disabled.
Range -1.0E12 ... 1.0E12 
Default value 1000 

Curve

Curve color

Selection of the color for the curve line.

Selection 13 colors | blue
Default value blue

Symbol

Selection of the symbol for the display of the individual measuring points.

Selection 5 symbols | No symbol
Default value No symbol

No symbol
Measuring points are not shown.

Note

With curves, for which the distance between to measuring points is
smaller than 5 pixels, the separate measuring points are not displayed
anymore, even if a symbol has been selected. In this case, the graphics
window can eventually be enlarged in order to display the symbols again.
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Symbol color

Selection of the color for the measuring point symbol.

Selection 13 colors | blue
Default value blue

Smoothing

Smoothing

on | off (Default value: on)

Switches smoothing on/off for the curve.

Smoothing factor x axis

Factor for smoothing on the x axis.

Range 0.01 ... 1000 
Default value 0.01 

Smoothing factor y-axis

Factor for smoothing on the y axis.

Range 0.01 ... 1000 
Default value 0.01 

Show with original curve

on | off (Default value: off)

If this check box is activated, then the original curve (solid line, same color)
will be shown in addition to the smoothed curve (dotted line).

4.5.2.6.4.6.4.4 Properties curve evaluation - y2 axis

Tab: Database ▶ Determinations ▶ Reprocess... ▶ Reprocessing ▶ Curve evalua-

tion ▶ [Edit] ▶ Curve evaluation ▶ Properties ▶ y2 axis

On the tab y2 axis the parameters for the graphical display of the curves
on the y2 axis (right y axis) can be set.

Command type

Shows the type of command for which the curve properties can be defined.
The curve properties defined for each command type for the reprocessing
window are saved per client.

Autoscaling

on | off (Default value: on)

If this option is switched on then all axes in the curve window will be scaled
automatically. In this case the fields Start value and End value cannot be
edited.
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Size

Selection Command-dependent selection | off
Default value off

Command-dependent selection
Selection of the quantity to be shown on the y2 axis.

Label

Freely definable axis label for the y2 axis.

Selection 50 characters | auto
Default value auto

auto
The designation from the field Size will be used.

Curve

Curve color

Selection of the color for the curve line.

Selection 13 colors | red
Default value red

Symbol

Selection of the symbol for the display of the individual measuring points.

Selection 5 symbols | No symbol
Default value No symbol

No symbol
Measuring points are not shown.

Note

With curves, for which the distance between to measuring points is
smaller than 5 pixels, the separate measuring points are not displayed
anymore, even if a symbol has been selected. In this case, the graphics
window can eventually be enlarged in order to display the symbols again.

Symbol color

Selection of the color for the measuring point symbol.

Selection 13 colors | red
Default value red
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Smoothing

Smoothing

on | off (Default value: on)

Switches smoothing on/off for the curve.

Smoothing factor x axis

Factor for smoothing on the x axis.

Range 0.01 ... 1000 
Default value 0.01 

Smoothing factor y-axis

Factor for smoothing on the y axis.

Range 0.01 ... 1000 
Default value 0.01 

4.5.2.6.4.6.4.5 Properties curve evaluation - Options

Tab: Database ▶ Determinations ▶ Reprocess... ▶ Reprocessing ▶ Curve evalua-

tion ▶ [Edit] ▶ Curve evaluation ▶ Properties ▶ Options

On the tab Options the parameters for the graphical display of the curves
can be set.

Command type

Shows the type of command for which the curve properties can be defined.
The curve properties defined for each command type for the reprocessing
window are saved per client.

Autoscaling

on | off (Default value: on)

If this option is switched on then all axes in the curve window will be scaled
automatically. In this case the fields Start value and End value cannot be
edited.

Display grid

Display grid

on | off (Default value: off)

If this check box is actjvated then a grid will be shown against the back-
ground.

Grid type

Selection of the type of grid line.
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Selection 5 line types

Grid color

Selection of the grid line color.

Selection 13 colors | gray
Default value gray

Background

Background color

Selection of the color for the curve background.

Selection 13 colors | white
Default value white

Show endpoints

Show endpoints

on | off (Default value: on)

If this check box is activated then the endpoints found will be shown on the
curve by the symbol ♦ and labeled with EP# (potentiometric endpoint),
BP# (break point), FP# (fixed endpoint), HP (HNP), MI (minimum value) or
MA (maximum value).

Automatic EPs

Selection of the color for automatically set endpoints.

Selection 13 colors | black
Default value black

Manual EPs

Selects the color for manually set endpoints.

Selection 13 colors | pink
Default value pink

Show evaluation lines

Show evaluation lines

on | off (Default value: off)

If this check box is activated the evaluation lines (tangents, auxiliary lines)
will be shown.

Tangents

Selection of the color for the tangents and auxiliary lines.
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Selection 13 colors | light green
Default value light green

Auxiliary lines

Selection of the color for the auxiliary lines.

Selection 13 colors | blue
Default value blue

4.5.2.6.4.7 Result Result name

Dialog window: Database ▶ Determination ▶ Reprocessing ▶ Modifications ▶ Cal-

culations ▶ [New]/[Properties] ▶ Result 'Result name' - RS##

In the dialog window Result Result name - RS## results and their prop-
erties can be edited.

The dialog window consists of the following two tabs:

4.5.2.6.4.7.1 Definition

Tab: Database ▶ Determinations ▶ Reprocessing ▶ Modifications ▶ Calcula-

tions ▶ [New]/[Properties] ▶ Result 'Result name' - RS## ▶ Definition

Result variable

Variable, which is automically generated by the program during the evalu-
ation or by the results defined by the user.

Result name

Name of the result. This name will be shown in the result view as well as in
the report. The result name can be used in further calculations as variable
RS.Result name.VAL.

Input 50 characters
Default value empty

Formula

Calculation formula which can be generated after pressing  in the for-
mula editor.

Formula lines can be deleted according to normal rules ([Delete]), copied
([Ctrl+C]), cut ([Ctrl+x]) and be pasted ([Ctrl+v])

Input 1000 characters
Default value empty

Unit

Unit of the result for the output (text only). The unit can be used in further
calculations as variable 'RS.Result name.UNI'.
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Input 16 characters
Default value empty

Decimal places

Number of decimal places for the output of the calculated result. This para-
meter is ignored for results of the type text or date/time.

Range 0 ... 5 
Default value 2 

Assignment

Assign a result to a defined result column RS01 … RS25. This order specifies
in which of the 25 available result columns in the determination overview
the result is being added to. Per calculation the result columns RS01 ...
RS25 are available. Only the columns still free are made available. With
none the result will not be assigned to any column.

Range RS01 ... RS25 
Default value none 

Statistics

on | off (Default value: on)

If this check box is activated, the mean value and the absolute and relative
standard deviation are calculated for the result. This field is only active when
the statistics is enabled in the method of the imported determination (i.e.
the statistics can only then be disabled and enabled again, if it has already
been enabled in the method).

Description

Freely selectable description of the result.

Input 1000 characters
Default value empty

4.5.2.6.4.7.2 Monitoring

Tab: Database ▶ Determinations ▶ Reprocessing ▶ Modifications ▶ Calcula-

tions ▶ [New]/[Properties] ▶ Result 'Result name' - RS## ▶ Monitoring

Result monitoring

If this check box is activated, then the limit values for the result of the cal-
culation formula are being monitored.

Lower limit

Lower limit for the result. This parameter is only editable when the result
monitoring is enabled.
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Input 10 digits
Default value 0

Upper limit

Upper limit for the result. This parameter is only editable when the result
monitoring is enabled.

Input 10 digits
Default value 99999.99999

Message

Only editable when the check box Monitoring result is activated.

Selection Display message | Record message

Display message
If this option is selected, the message "The limit value for the result 'result
name' has been exceeded." appears. At the same time the message is
documented, i.e. it is saved in the determination.

Record message
If this option is selected, the message "The limit value for the result 'result
name' has been exceeded." is saved in the determination.

4.5.2.6.5 Result view

Subwindow: Database ▶ Determinations ▶ Reprocess... ▶ Reprocessing ▶ Result
view

In the subwindow Result view of the dialog window Reprocessing results
and raw data are displayed on the following two tabs:

4.5.2.6.5.1 Result view - Results overview

Tab: Database ▶ Determinations ▶ Reprocess... ▶ Reprocessing ▶ Result dis-

play ▶ Result overview

On the tab Result view of the subwindow Result display the results cal-
culated during the calculating commands and the variables used for are
displayed and updated with each recalculation.

The following elements are displayed:

Title

Name of the calculation command (1C...9C).

Result

Result name, result value with defined number of decimal places, units.

Statistical evaluations

Results of the statistical evaluation (mean value, absolute and relative stand-
ard deviations, number of measured values used for the statistics).
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Navigation

If several determinations are selected for reprocessing then the navigation
buttons can be used to switch between showing the results of the individual
determinations:

Jump to first determination.

Jump to previous determination.

Jump to next determination.

Jump to last determination.

4.5.2.6.5.2 Result view - Raw data

Tab: Database ▶ Determinations ▶ Reprocess... ▶ Reprocessing ▶ Result dis-

play ▶ Raw data

On the tab Raw data of the subwindow Result view the raw data gen-
erated in commands with evaluations will be shown and updated at each
recalculation.

If several determinations are selected for reprocessing then the navigation
buttons can be used to switch between showing the results of the individual
determinations:

Jump to first determination.

Jump to previous determination.

Jump to next determination.

Jump to last determination.

4.5.2.6.6 Modification comment for determinations

Dialog window: Database ▶ Determinations ▶ Delete/Reprocess...

If the option Comment on modification of determinations is switched on
in the security settings then before the modified sample data is accepted the
window Modification comment determination first appears in which a
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Reason must be selected and a Comment on the modification must be
entered.

Reason

Selection from the default reasons defined for the category Modifications
of determinations in the Security settings dialog window.

Selection Selection from default reasons

Comment

Entry of a comment on the modification of the determinations.

Input 1000 characters

4.5.2.7 Sending determinations to

Dialog window: Database ▶ Determinations ▶ Send to...

The menu item Determinations ▶ Send to...  opens the dialog window
Send determinations per E-mail.

Selection Determination ID | Sample identification | File
name

Default value Determination ID

Determination ID
With this option, the name of the export file is formed out of an unam-
biguous determination ID, the computer name, the date stamp -
YYYYMMDD-HHMMSS and the suffix for the format.

Sample identification
With this option the sample identification is selected. The name of the
export file is formed out of this ID, the computer name, the date stamp
YYYYMMDD-HHMMSS and the suffix for the format. If the created
name exists already in the directory, a version number will be appended
additionally to the date.

File name
With this option the name under which the export file of a determination
is saved as an attachment to the E-mail message is entered. If more than
one determination is selected, then a sequential number will be added
to this name for each determination.

After each confirmation of the file name with [OK] every determination is
exported to a separate *.tdet file. The standard Windows E-mail Client will
open with an empty message and the export files will automatically be added
as an attachment.
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4.5.2.8 Exporting determinations

Dialog window: Database ▶ Determinations ▶ Export... ▶ Export determinations

Click on menu itemDeterminations ▶ Export... to open the dialog win-
dow Export determinations for exporting the selected determinations.

Selection

Selection of determinations for export.

Selection All selected data records | All filtered data
records

Default value All selected data records

All selected data records
All those determinations are exported that have been selected (marked)
in the determination table.

All filtered data records
All those determinations from the whole determination table are expor-
ted that correspond to the set filter.

Export template

Selection of the Export template for data export.

Selection 'Export template'

4.5.2.9 Importing determinations

Dialog window: Database ▶ Determinations ▶ Import... ▶ Import determinations

With the menu item Determinations ▶ Import... the dialog window
Import determination opens, in which the determinations to be imported
must be selected. These determinations are then imported into the open
Database.

Note

Exported determinations can be imported in the file format *.txt (PC
LIMS report) and *.tdet (tiBase format).

4.5.2.10 Deleting determinations

Menu item: Database ▶ Determinations ▶ Delete

With the symbol  or the menu item Determinations ▶ Delete, the selec-
ted determinations are deleted after the confirmation request.



4.5 Determination overview ￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭

244 ￭￭￭￭￭￭￭￭ tiBase 1.0

Note

If a database is opened simultaneously on several clients and if determi-
nations are deleted on a client then these will still be shown in the
determination table of the other clients until the table is updated. All the
fields of these determinations will then have the entry deleted.

Note

If the check box Comment on modification of determinations in the
Security settings is activated, then the window Modification com-
ment determination will appear before the modification is saved.

4.5.2.11 Determination overview - Print

Dialog window: Database ▶ File ▶ Print ▶ Determination overview… ▶ Print deter-
mination overview (PDF)

The Menu item File ▶ Print ▶ Determination overview... opens the dia-
log window Print determination overview (PDF).

Selection

Selection Selected determinations | All filtered determi-
nations

Default value Selected determinations

Selected determinations
If this option is selected, then a list with all determinations that are selec-
ted (marked) in the determination table will be produced.

All filtered determinations
If this option is selected, then a list with all the determinations in the
determination table that meet the filter criterion will be produced.

Orientation

Selection Portrait | Landscape
Default value Portrait

Portrait
If this option is selected then the determination table will be produced
in portrait format.

Landscape
If this option is selected then the determination table will be produced
in landscape format.
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[OK]

The determination table is produced in the required format as a PDF file and
opened directly with Acrobat Reader; it can then be printed out and/or
saved.

4.5.2.12 Determinations - Print report

Dialog window: Database ▶ File ▶ Print ▶ Report... ▶ Report output

The menu item File ▶ Print ▶ Report... opens the dialog window Report
output.

Selection

Selection Selected determinations | All filtered determi-
nations

Default value Selected determinations

Selected determinations
If this option is selected, then the reports will be produced for all deter-
minations that are selected (marked) in the determination table.

All filtered determinations
If this option is selected, then the reports will be produced for all the
determinations in the determination table that meet the filter criterion.

Report type

Selection Original report(s) | Report template
Default value Original report(s)

Original report(s)
If this option is selected then the reports produced during the determi-
nation will appear at the Output target defined below.

Report template
If this option is selected then reports according to the selected Report
template will be produced at the Output target defined below.

Note

Original report is used to refer to a report, which has been automatically
generated at the creation of the determination version. If a determi-
nation is being reprocessed, a new determination version and therefore
also a new original report is created.

In order to print the report of the non-reprocessed determination the
determination 1 must be selected.
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Output target

Printer

on | off (Default value: on)

If this check box is activated, the reports are printed on the selected printer.

PDF file

on | off (Default value: off)

If this check box is activated the reports are put out as PDF files under the
entered file name.

Note

If several reports are produced simultaneously as a PDF file then an index
will be automatically appended to the file name.

4.5.2.13 Determinations - Displaying history

Menu item: Database ▶ Determinations ▶ Show history

Switch history view on/off

With the menu item Determinations ▶ Display history... or the symbol

 only the currently focused determination in the Determination table as
well as all the previous versions of this determination will be shown.

If the History view with the menu item Determinations ▶ Display his-

tory... or the symbol  is disabled again, then the original selection of
determinations in the Determination table will appear again.

4.5.2.14 Determinations - Make current

Menu item: Database ▶ Determinations ▶ Make current

Make old version current

With the menu item Determinations ▶ Make current... or the symbol

 the determination version selected in the determination table will again
be made the current determination version. This creates a new determina-
tion whose version number is increased by +1 compared with the last version
to have been saved.
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4.5.2.15 Determinations - Show calibration curve

Dialog window: Database ▶ Determinations ▶ Show calibration curve... ▶ Calibration
curve

With the menu item Determinations, Show calibration curve... or the

symbol  the calibration or standard addition curve is shown for the cali-
bration selected in the dialog window Calibration curve.

Calibration curve for CAL LOOP pH

In the dialog window Calibration curve a tab marked with the command
name showing the calibration curve and calibration data will be displayed
for each CAL LOOP pH command . The command type is shown above the
calibration curve. The curve display shows the measured values and the curve
calculated from these measured values. Listed below are the individual
measured values and the results for Slope, E(0) and Variance.

Calibration curve for CAL LOOP Conc

In the dialog window Calibration curve a tab marked with the command
name showing the calibration curve and calibration data will be displayed
for each CAL LOOP Conc command . The command type is shown above
the calibration curve. The curve display shows the measured values and the
curve calculated from these measured values. Listed below are the individual
measured values and the results for Slope, E(0), c(blank) and Variance.
Calibration curve for CAL LOOP Conc

Standard addition curve for STDADD

In the dialog window Calibration curve a tab marked with the command
name showing the standard addition curve and evaluation data will be dis-
played for each STDADD command . The command type is shown above
the calibration curve. The curve display shows the measured values and the
curve calculated from these measured values. Listed below are the individual
measured values and the results for Determination, Show calibration
curve..., E(0), Determination, Show calibration curve... and Var-
iance.

Note

Calibration curves cannot be printed out directly from the dialog window
Calibration curve. Instead you should use a report with a report tem-
plate which contains the fixed report .
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4.5.2.16 Determinations - Control chart

Dialog window: Database ▶ Determinations ▶ Control chart… ▶ Control chart

With the menu item Determinations, Control chart... or the symbol 
the dialog window Control chart - 'Template name' opens in which a
control chart is shown for the selected determinations containing statistical
evaluation (mean value, number of determinations, absolute and relative
standard deviation) according to the loaded template.

Template

Selection Standard | 'Template name'
Default value Standard

Standard
Selection of the saved templates for control charts (see Chapter
4.4.3.2.1, page 170). When the dialog window is opened, the last tem-
plate to have been loaded will be shown. If a new template is selected
then the display will be updated automatically.

[Templates]

Open the dialog window Templates for control charts.

Graphics presentation

Shows the measured values together with warning and intervantion limits
and statistical values according to the settings on the selected control chart.
If the cursor is moved to a point then the number, date and value appear as
a tooltip. The sorting and the date and time for the first and last point are
shown as the legend.

[Print (PDF)]

Open dialog window Print control chart (PDF)(see Chapter 4.5.2.19,
page 250). The content of the control chart can be shown as a PDF file in
the required format.

4.5.2.17 Determinations - Overlay curves

Menu item: Database ▶ Determinations ▶ Overlay curves… ▶ Overlay curves

With the menu item Determinations, Overlay curves... or the symbol

 the dialog window Overlay curves opens in which overlaid curves of
the selected determinations are shown according to the loaded template.

Template

Selection of a saved template for showing overlaying curves.
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Selection Standard | "Template" | Last saved template
Default value Last saved template

If a new template is selected then the display will be
updated automatically.

Note

In the template the Command type is defined for which the overlaying
of curves is possible. Curves from the selected determinations can only be
overlaid when the determination method contains a command with this
Command type (e.g. DET).

Command name

Selection of the command, whose curves are to be displayed with the selec-
ted template.

Selection "Command"
This selection is only necessary if the method contains
several commands of the same Command type.

[Templates]

Open the dialog window Curve overlay templates.

Graphics presentation

Shows the curves according to the settings of the selected template. The
command type (e.g. DET pH) is shown centrally above the graph. At the
right of the curve the legend is shown with the line number in the determi-
nation table belonging to the determination.

The legend consists of the content of a data field which can be defined in
the options of the template and of a counter, which identifies the curves if
the same command has been executed several times during a determination.

[Print (PDF)]

Open the dialog window Print curves (PDF) (see Chapter 4.5.2.18, page
249). The content of the curve overlay with legend can be shown as a PDF
file in the required format.

4.5.2.18 Print overlaid curves

Dialog window: Database ▶ Determinations ▶ Overlay curves... ▶ Overlay

curves ▶ [Print (PDF)] ▶ Print curves (PDF)

With [Print (PDF)] in the dialog window Overlay curves the dialog win-
dow Print curves (PDF) is openend.
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Orientation

Selection Portrait | Landscape
Default value Landscape

Portrait
Produces control chart in portrait format.

Landscape
Produces control chart in landscape format.

Comment

Possibility of entering comments on the control chart which will be produced
together with the control chart.

Input 1000 characters

[OK]

Close dialog window. The control chart is shown in the required format as
a PDF file and opened directly with the Acrobat Reader; it can then be printed
out and/or saved.

4.5.2.19 Print control chart

In the dialog window Print control chart (PDF) the format for the printout
of the control chart is indicated.

Orientation

Selection Portrait | Landscape
Default value Landscape

Portrait
Produces control chart in portrait format.

Landscape
Produces control chart in landscape format.

Comment

Possibility of entering comments on the control chart which will be produced
together with the control chart.

Input 1000 characters

[OK]

The control chart is shown in the required format as a PDF file and opened
directly with the Acrobat Reader; it can then be printed out and/or saved.
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4.6 Subwindow Information

4.6.1 Information - Overview  
Subwindow: Database ▶ Information

General

In the subwindow Information general information about the focused
determination in the determination table is shown. The subwindow can be
switched on in the program part Database during the definition of the
layout and thus made visible. It can be enlarged and reduced as required; it
can also be maximized.

Tabs

Information about the determination is shown on the following tabs:

￭ Determination
Display of general information about determination.

￭ Method
Shows general information about the method used.

￭ Sample
Shows general information about the sample used.

￭ Configuration
Shows general information about the devices, sensors and common var-
iables used.

￭ Messages
Shows messages about the determination.

￭ Determination comment
Shows the comment on the determination.

4.6.2 Information - Determination    
Tab: Database ▶ Information ▶ Determination

Display of general information about determination.

Identification

Information about the identification of the determination.

Determination ID:

Unambiguous and unmistakable identification for the determination.

Sample number:

Shows the Sample number entered in the run window.

Start counter:

Shows the start counter which is increased by +1 at the start of each deter-
mination. The start counter is saved for each client and cannot be reset.
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Recording

Information about recording the determination.

Determination start:

Date and time at start of determination.

Determination duration:

Duration of the determination from its start to its end or termination in s.

Determination run:

Way in which the determination was ended:

Selection Regular without errors | Manual stop |  error

Regular without errors
The determination was finished automatically after the method was pro-
cessed normally and without any errors.

Manual stop
The determination has been ended with the [Stop] fixed key.

error
The determination has been ended because an error occured.

User (short name):

Short name of the user.

Program version

Display of program version and build number of tiBase  with which the
PC_LIMS report was imported and edited.

Status/Version

Information about the determination version.

Determination status:

Selection original | modified

original
Determination data unaltered.

modified
Determination data modified.

Determination version:

Version of the determination. The unaltered original determination has the
version number 1, reprocessed determinations have a version number >1.

Reprocessing date:

Date and time when the reprocessed determination version was saved.
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Reprocessed by (short name):

Short name of user logged in when determination was reprocessed. If a new
version was generated automatically by reprocessing statistically linked
determinations without modification of determination data, tiBase 1.0  will
be displayed here.

Reprocessed by (full name):

Full name of user logged in when determination was reprocessed. If a new
version was generated automatically by reprocessing statistically linked
determinations without modification of determination data, New gener-
ated version for statistics will be displayed here.

Modification reason determination:

Reason for the determination modification.

Modification comment determination:

User comment on the determination modification.

Signature Level #

Information about the signatures at Level 1 or Level 2 in chronological order.

Signature date:

Date and time at which the determination was signed.

Signed by (short name):

Short name of user who signed the determination.

Signed by (full name):

Full name of user who signed the determination.

Signature reason:

Reason for signature selected by user.

Signature comment:

User comments on signing the determination.

4.6.3 Information - Method    
Tab: Database ▶ Information ▶ Method

Shows general information about the method used.

Identification

Information about the identification of the method.
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Method name:

Name of the method.

Method ID:

Unambiguous identification for the method.

Method comment:

Method comment (Command comment on START command).

Status/Version

Information about method version.

Method status:

Selection new | modified | saved | reviewed | released

new
The method has been newly created and not yet saved.

modified
The method has been reprocessed but not saved.

saved
The method has been saved.

reviewed
The method has been signed at stage 1.

released
The method has been signed at stage 2.

Method version:

Version of the method the determination was created with.

Method saving date:

Date and time when the modified method version was saved.

Method saved by (short name):

Short name of user logged in when modified method was saved.

Modification reason method:

Reason for the method modification.

Modification comment method:

User comment on the method modification.

Signature Level #

Information about the signatures at Level 1 or Level 2 in chronological order.
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Signature date:

Date and time at which the method was signed.

Signed by (short name):

Short name of the user who signed the method.

Signature reason:

Reason for signature selected by user.

Signature comment:

User comments on signing the method.

4.6.4 Information - Sample
Tab: Database ▶ Information ▶ Sample

Shows general information about the sample used.

Sample data

Information about the sample. The only sample data shown is that for which
a value is available.

Sample size:

Value for the sample size.

Sample size unit:

Unit of sample size.

Identification

Information about the sample identifications.

ID1

Shows the sample identification saved under ID1. The identifications will
only be shown when a value is present.

ID2

Shows the sample identification saved under ID2. The identifications will
only be shown when a value is present.

4.6.5 Information - Configuration       
Tab: Database ▶ Information ▶ Configuration

Shows general information about the devices, sensors and common varia-
bles used.



4.6 Subwindow Information ￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭

256 ￭￭￭￭￭￭￭￭ tiBase 1.0

Device 'Software name'

Information about the device used (only the existing device information will
be shown).

Device type:

Name of the software.

Program version:

Version of the software.

Device serial number:

Serial number of the software.

Device 'Device name'

Information about the device used (only the existing device information will
be shown).

Device type:

Type of device.

Program version:

Device program version.

Device serial number:

Serial number of the instrument.

　

Rack name:

Name of the rack on the sample changer.

Rack code:

Rack code of the rack on the sample changer.

　

Tower:

Number of the tower on which a Swing Head is used.

Swing Head type:

Type of Swing Head attached to tower.

Swing Head serial number:

Serial number of Swing Head attached to tower.
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Measuring input:

Number of the measuring input (+ designation iConnect for intelligent sen-
sors).

ADC type:

Type of analog/digital converter.

ADC serial number:

Serial number of measuring input.

Temperature sensor:

Type of connected temperature sensor.

　

Stirrer:

Stirrer connection at device.

Stirrer type:

Type of stirrer.

Stirrer serial number:

Serial number of stirrer.

　

Dosing device:

Dosing connection at device.

Dosing device type:

Dosing device type.

Dosing device serial number:

Serial number of dosing device.

Exchange/Dosing unit:

Type of exchange or dosing unit.

Remote Box:

Connection to device.

Buret serial number

Serial number of the buret.
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Solution 'Solution name'

Solution name:

Name of the solution.

Concentration:

Concentration value and unit of the solution.

Titer:

Titer value and units of the solution.

Date titer det.:

Date of the titer determination.

Titer method:

Method with which the titer was determined.

Sensor 'Sensor name'

Information about the sensor used.

Sensor type:

Type of sensor (+ designation IS for intelligent sensors).

Sensor serial number:

Serial number of sensor.

Order number:

Order number of sensor.

Slope:

Electrode slope of the sensor used (in % for pH sensor or in mV for ISE).

pH (0):

Electrode zero point of the sensor used (dimensionless for pH sensor).

Calibration temperature:

Temperature during the calibration.

Calibration method:

Shows the method with which the calibration was carried out.

User:

Shows the user logged in during the calibration or who entered the calibra-
tion data manually.
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E (0):

Electrode zero point of the sensor used (in mV only for ISE).

c (blank):

Blank value of the ISE sensor used.

Cell constant:

Cell constant of the conductivity sensor used.

Common variable 'Name'

Information about the common variable used.

Value:

Value and unit of the common variables at the start of the determination.

4.6.6 Information - Messages 
Tab: Database ▶ Information ▶ Messages

Shows messages generated during the determination run.

'Time'

Shows the time at which the message was generated in the run (date, time,
UTC in the format YYYY-MM-DD hh:mm:ss UTC.....).

Message title:

Shows the message title and number.

Message source:

Shows from where the message comes:

4.6.7 Information - Determination comment 
Tab: Database ▶ Information ▶ Determination comment

Shows the comment on the determination.

Determination comment:

Shows the comment entered for the determination.
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4.7 Subwindow Results

4.7.1 Results - General
Subwindow: Database ▶ Results

In the subwindow Results in the program part Database the results cal-
culated in the calculation commands and the variables used for are shown.
It shows the results overview, the raw data of the commands with evalua-
tions as well as the results calculated in the calculation commands, statistical
evaluations, formulas and all variables used for for the determination selec-
ted in the determination overview.

When navigating in the determination overview this data will be updated
automatically (with a certain delay).

The subwindow Results can be switched on and made visible in the defi-
nition of the layout in the program part Database. It can be enlarged and
reduced as required; it can also be maximized.

Tabs

The results of the determination are shown on the following tabs:

￭ Results overview
Shows the results overview for all calculation commands.

￭ Raw data
Display of evaluation raw data for commands with evaluations.

￭ "Command name"
Show the results for a single calculation command. A tab with the cor-
responding command name is provided for each calculation command.

4.7.2 Results - Results overview
Tab: Database ▶ Result ▶ Results overview

On the tab Results overview the results for all calculation commands and
(if existent and desired) the corresponding statistical evaluations are dis-
played. The display of the statistical evaluations can be selected in the dialog
window Properties result window

Command "Command name"

For each CALC command a results overview is shown according to the fol-
lowing pattern:

"Command name"

Name of the CALC command.
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Note

Only the last results having been calculated will be shown. For example,
if there are several commands that generate a result with the same name,
then the corresponding result data will be shown only for that command
that was the last to calculate the result. Nothing will be shown for the
other commands.

"Result"

Shows the result name and result value with the defined number of decimal
places and units.

Note

If a result value is monitored and lies within the limit value defined in the
CALC command then the text will be shown in green, if it lies outside the
limits it will be shown in red text color.

Mean value:

Shows the mean value for statistically evaluated results.

s(abs):

Shows the absolute standard deviation for statistically evaluated results.

s(rel):

Shows the relative standard deviation for statistically evaluated results.

Minimum:

Shows the minimum value for statistically evaluated results.

Maximum:

Shows the maximum value for statistically evaluated results.

n:

Shows the number of measurements for statistically evaluated results.
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4.7.3 Results - Raw data
Tab: Database ▶ Results ▶ Results

On the tab Raw data the evaluation results of commands with evaluations
are shown.

"Command name"

For each CALC command the raw data is displayed in six columns:

Column 1

Display of the command type.

Column 2

Shows the variable designation for the raw data.

Columns 3-6

Shows the raw data.

The following tables show the raw data depending on the command type.
For each variable the Variable name, Unit and Number of decimal pla-
ces is indicated.

Table 1 Command DET pH

Column 2: Variable Column 3 Column 4 Column 5 Column 6

EP# EP#.VOL , mL , 4 EP#.MEA , pH , 3 EP#.TIM , s , 1 EP#.TEM , °C , 1

FP# FP#.VOL , mL , 4 FP#.MEA , pH , 3 FP#.TIM , s , 1 FP#.TEM , °C , 1

HP# HP#.VOL , mL , 4 HP#.MEA , pH , 3 HP#.TIM , s , 1 HP#.TEM , °C , 1

MI MI.VOL , mL , 4 MI.MEA , pH , 3 MI.TIM , s , 1 MI.TEM , °C , 1

MA MA.VOL , mL , 4 MA.MEA , pH , 3 MA.TIM, s, 1 MA.TEM , °C , 1

BP# BP#.VOL , mL , 4 BP#.MEA , pH , 3 BP#.TIM , s , 1 BP#.TEM, °C, 1

Table 2 Command DET U

Column 2: Variable Column 3 Column 4 Column 5 Column 6

EP# EP#.VOL , mL , 4 EP#.MEA , mV , 1 EP#.TIM , s , 1 EP#.TEM , °C , 1

FP# FP#.VOL , mL , 4 FP#.MEA , mV , 1 FP#.TIM , s , 1 FP#.TEM , °C , 1

HP# HP#.VOL , mL , 4 HP#.MEA , mV , 1 HP#.TIM , s , 1 HP#.TEM , °C , 1

MI MI.VOL , mL , 4 MI.MEA , mV , 1 MI.TIM , s , 1 MI.TEM , °C , 1

MA MA.VOL , mL , 4 MA.MEA , mV , 1 MA.TIM, s, 1 MA.TEM , °C , 1

BP# BP#.VOL , mL , 4 BP#.MEA , mV , 1 BP#.TIM , s , 1 BP#.TEM, °C, 1
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Table 3 Command DET Ipol

Column 2: Variable Column 3 Column 4 Column 5 Column 6

EP# EP#.VOL , mL , 4 EP#.MEA , mV , 1 EP#.TIM , s , 1 EP#.TEM , °C , 1

FP# FP#.VOL , mL , 4 FP#.MEA , mV , 1 FP#.TIM , s , 1 FP#.TEM , °C , 1

HP# HP#.VOL , mL , 4 HP#.MEA , mV , 1 HP#.TIM , s , 1 HP#.TEM , °C , 1

MI MI.VOL , mL , 4 MI.MEA , mV , 1 MI.TIM , s , 1 MI.TEM , °C , 1

MA MA.VOL , mL , 4 MA.MEA , mV , 1 MA.TIM, s, 1 MA.TEM , °C , 1

BP# BP#.VOL , mL , 4 BP#.MEA , mV , 1 BP#.TIM , s , 1 BP#.TEM, °C, 1

Table 4 Command DET Upol

Column 2: Variable Column 3 Column 4 Column 5 Column 6

EP# EP#.VOL , mL , 4 EP#.MEA , µA , 1 EP#.TIM , s , 1 EP#.TEM , °C , 1

FP# FP#.VOL , mL , 4 FP#.MEA , µA , 1 FP#.TIM , s , 1 FP#.TEM , °C , 1

HP# HP#.VOL , mL , 4 HP#.MEA , µA , 1 HP#.TIM , s , 1 HP#.TEM , °C , 1

MI MI.VOL , mL , 4 MI.MEA , µA , 1 MI.TIM , s , 1 MI.TEM , °C , 1

MA MA.VOL , mL , 4 MA.MEA , µA , 1 MA.TIM, s, 1 MA.TEM , °C , 1

BP# BP#.VOL , mL , 4 BP#.MEA , µA , 1 BP#.TIM , s , 1 BP#.TEM, °C, 1

Table 5 Command MET pH

Column 2: Variable Column 3 Column 4 Column 5 Column 6

EP# EP#.VOL , mL , 4 EP#.MEA , pH , 3 EP#.TIM , s , 1 EP#.TEM , °C , 1

FP# FP#.VOL , mL , 4 FP#.MEA , pH , 3 FP#.TIM , s , 1 FP#.TEM , °C , 1

HP# HP#.VOL , mL , 4 HP#.MEA , pH , 3 HP#.TIM , s , 1 HP#.TEM , °C , 1

MI MI.VOL , mL , 4 MI.MEA , pH , 3 MI.TIM , s , 1 MI.TEM , °C , 1

MA MA.VOL , mL , 4 MA.MEA , pH , 3 MA.TIM, s, 1 MA.TEM , °C , 1

BP# BP#.VOL , mL , 4 BP#.MEA , pH , 3 BP#.TIM , s , 1 BP#.TEM, °C, 1

Table 6 Command MET U

Column 2: Variable Column 3 Column 4 Column 5 Column 6

EP# EP#.VOL , mL , 4 EP#.MEA , mV , 1 EP#.TIM , s , 1 EP#.TEM , °C , 1

FP# FP#.VOL , mL , 4 FP#.MEA , mV , 1 FP#.TIM , s , 1 FP#.TEM , °C , 1

HP# HP#.VOL , mL , 4 HP#.MEA , mV , 1 HP#.TIM , s , 1 HP#.TEM , °C , 1

MI MI.VOL , mL , 4 MI.MEA , mV , 1 MI.TIM , s , 1 MI.TEM , °C , 1

MA MA.VOL , mL , 4 MA.MEA , mV , 1 MA.TIM, s, 1 MA.TEM , °C , 1

BP# BP#.VOL , mL , 4 BP#.MEA , mV , 1 BP#.TIM , s , 1 BP#.TEM, °C, 1
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Table 7 Command MET Ipol

Column 2: Variable Column 3 Column 4 Column 5 Column 6

EP# EP#.VOL , mL , 4 EP#.MEA , mV , 1 EP#.TIM , s , 1 EP#.TEM , °C , 1

FP# FP#.VOL , mL , 4 FP#.MEA , mV , 1 FP#.TIM , s , 1 FP#.TEM , °C , 1

HP# HP#.VOL , mL , 4 HP#.MEA , mV , 1 HP#.TIM , s , 1 HP#.TEM , °C , 1

MI MI.VOL , mL , 4 MI.MEA , mV , 1 MI.TIM , s , 1 MI.TEM , °C , 1

MA MA.VOL , mL , 4 MA.MEA , mV , 1 MA.TIM, s, 1 MA.TEM , °C , 1

BP# BP#.VOL , mL , 4 BP#.MEA , mV , 1 BP#.TIM , s , 1 BP#.TEM, °C, 1

Table 8 Command MET Upol

Column 2: Variable Column 3 Column 4 Column 5 Column 6

EP# EP#.VOL , mL , 4 EP#.MEA , µA , 1 EP#.TIM , s , 1 EP#.TEM , °C , 1

FP# FP#.VOL , mL , 4 FP#.MEA , µA , 1 FP#.TIM , s , 1 FP#.TEM , °C , 1

HP# HP#.VOL , mL , 4 HP#.MEA , µA , 1 HP#.TIM , s , 1 HP#.TEM , °C , 1

MI MI.VOL , mL , 4 MI.MEA , µA , 1 MI.TIM , s , 1 MI.TEM , °C , 1

MA MA.VOL , mL , 4 MA.MEA , µA , 1 MA.TIM, s, 1 MA.TEM , °C , 1

BP# BP#.VOL , mL , 4 BP#.MEA , µA , 1 BP#.TIM , s , 1 BP#.TEM, °C, 1

Table 9 Command SET pH

Column 2: Variable Column 3 Column 4 Column 5 Column 6

EP# EP#.VOL , mL , 4 EP#.MEA , pH , 3 EP#.TIM , s , 1 EP#.TEM , °C , 1

DRI DRI , µL/min , 1    

DTI DTI , s , 1    

FP# FP#.VOL , mL , 4 FP#.MEA , pH , 3 FP#.TIM , s , 1 FP#.TEM , °C , 1

MI MI.VOL , mL , 4 MI.MEA , pH , 3 MI.TIM , s , 1 MI.TEM , °C , 1

MA MA.VOL , mL , 4 MA.MEA , pH , 3 MA.TIM, s, 1 MA.TEM , °C , 1

Table 10 Command SET U

Column 2: Variable Column 3 Column 4 Column 5 Column 6

EP# EP#.VOL , mL , 4 EP#.MEA , mV , 1 EP#.TIM , s , 1 EP#.TEM , °C , 1

DRI DRI , µL/min , 1    

DTI DTI , s , 1    

FP# FP#.VOL , mL , 4 FP#.MEA , mV , 1 FP#.TIM , s , 1 FP#.TEM , °C , 1

MI MI.VOL , mL , 4 MI.MEA , mV , 1 MI.TIM , s , 1 MI.TEM , °C , 1

MA MA.VOL , mL , 4 MA.MEA , mV , 1 MA.TIM, s, 1 MA.TEM , °C , 1
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Table 11 Command SET Ipol

Column 2: Variable Column 3 Column 4 Column 5 Column 6

EP# EP#.VOL , mL , 4 EP#.MEA , mV , 1 EP#.TIM , s , 1 EP#.TEM , °C , 1

DRI DRI , µL/min , 1    

DTI DTI , s , 1    

FP# FP#.VOL , mL , 4 FP#.MEA , mV , 1 FP#.TIM , s , 1 FP#.TEM , °C , 1

MI MI.VOL , mL , 4 MI.MEA , mV , 1 MI.TIM , s , 1 MI.TEM , °C , 1

MA MA.VOL , mL , 4 MA.MEA , mV , 1 MA.TIM, s, 1 MA.TEM , °C , 1

Table 12 Command SET Upol

Column 2: Variable Column 3 Column 4 Column 5 Column 6

EP# EP#.VOL , mL , 4 EP#.MEA , µA , 1 EP#.TIM , s , 1 EP#.TEM , °C , 1

DRI DRI , µL/min , 1    

DTI DTI , s , 1    

FP# FP#.VOL , mL , 4 FP#.MEA , µA , 1 FP#.TIM , s , 1 FP#.TEM , °C , 1

MI MI.VOL , mL , 4 MI.MEA , µA , 1 MI.TIM , s , 1 MI.TEM , °C , 1

MA MA.VOL , mL , 4 MA.MEA , µA , 1 MA.TIM, s, 1 MA.TEM , °C , 1

Table 13 Command KFT Ipol

Column 2: Variable Column 3 Column 4 Column 5 Column 6

EP EP.VOL , mL , 4 EP.MEA , mV , 1 EP.TIM , s , 1 EP.TEM , °C , 1

DRI DRI , µL/min , 1    

DTI DTI , s , 1    

FP# FP#.VOL , mL , 4 FP#.MEA , mV , 1 FP#.TIM , s , 1 FP#.TEM , °C , 1

MI MI.VOL , mL , 4 MI.MEA , mV , 1 MI.TIM , s , 1 MI.TEM , °C , 1

MA MA.VOL , mL , 4 MA.MEA , mV , 1 MA.TIM, s, 1 MA.TEM , °C , 1

Table 14 Command KFT Upol

Column 2: Variable Column 3 Column 4 Column 5 Column 6

EP EP.VOL , mL , 4 EP.MEA , µA , 1 EP.TIM , s , 1 EP.TEM , °C , 1

DRI DRI , µL/min , 1    

DTI DTI , s , 1    

FP# FP#.VOL , mL , 4 FP#.MEA , µA , 1 FP#.TIM , s , 1 FP#.TEM , °C , 1

MI MI.VOL , mL , 4 MI.MEA , µA , 1 MI.TIM , s , 1 MI.TEM , °C , 1

MA MA.VOL , mL , 4 MA.MEA , µA , 1 MA.TIM, s, 1 MA.TEM , °C , 1
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Table 15 Command KFC

Column 2: Variable Column 3 Column 4 Column 5 Column 6

EP EP.MEA , mV , 1 EP.QTY , µg , 1 EP.TIM , s , 1 EP.TEM , °C , 1

DRI DRI , µg/min , 1    

DTI DTI , s , 1    

FP# FP#.MEA , mV , 1 FP#.QTY , µg , 1 FP#.TIM , s , 1 FP#.TEM , °C , 1

Table 16 Command BRC

Column 2: Variable Column 3 Column 4 Column 5 Column 6

EP EP.MEA , mV , 1 EP.QTY , µg , 1 EP.TIM , s , 1 EP.TEM , °C , 1

DRI DRI , µg/min , 1    

DTI DTI , s , 1    

FP# FP#.MEA , mV , 1 FP#.QTY , µg , 1 FP#.TIM , s , 1 FP#.TEM , °C , 1

Table 17 Command STAT pH

Column 2: Variable Column 3 Column 4 Column 5 Column 6

MR MR.MRT , mL/min ,
4

MR.MRS , mL/min ,
4

MR.MRC , "leer" , 3  

RE# RE#.DRT , mL/min ,
4

RE#.DRS , mL/min ,
4

RE#.DRC ,
"empty" , 3

 

FP# FP#.VOL , mL , 4 FP#.MEA , pH , 3 FP#.TIM , s , 1 FP#.TEM , °C , 1

MI MI.VOL , mL , 4 MI.MEA , pH , 3 MI.TIM , s , 1 MI.TEM , °C , 1

MA MA.VOL , mL , 4 MA.MEA , pH , 3 MA.TIM, s, 1 MA.TEM , °C , 1

Table 18 Command STAT U

Column 2: Variable Column 3 Column 4 Column 5 Column 6

MR MR.MRT , mL/min ,
4

MR.MRS , mL/min ,
4

MR.MRC , "leer" , 3  

RE# RE#.DRT , mL/min ,
4

RE#.DRS , mL/min ,
4

RE#.DRC ,
"empty" , 3

 

FP# FP#.VOL , mL , 4 FP#.MEA , mV , 3 FP#.TIM , s , 1 FP#.TEM , °C , 1

MI MI.VOL , mL , 4 MI.MEA , mV , 3 MI.TIM , s , 1 MI.TEM , °C , 1

MA MA.VOL , mL , 4 MA.MEA , mV , 3 MA.TIM, s, 1 MA.TEM , °C , 1

Table 19 Command MEAS pH

Column 2: Variable Column 3 Column 4 Column 5 Column 6

EME EME , pH , 3    

ETE ETE , °C , 1    
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Column 2: Variable Column 3 Column 4 Column 5 Column 6

FP# FP#.MEA , pH , 3 FP#.TIM , s , 1 FP#.TEM , °C , 1  

MI MI.MEA , pH , 3 MI.TIM , s , 1 MI.TEM , °C , 1  

MA MA.MEA , pH , 3 MA.TIM, s, 1 MA.TEM , °C , 1  

BP# BP#.MEA , pH , 3 BP#.TIM , s , 1 BP#.TEM , °C , 1  

Table 20 Command MEAS U

Column 2: Variable Column 3 Column 4 Column 5 Column 6

EME EME , mV , 1    

ETE ETE , °C , 1    

FP# FP#.MEA , mV , 1 FP#.TIM , s , 1 FP#.TEM , °C , 1  

MI MI.MEA , mV , 1 MI.TIM , s , 1 MI.TEM , °C , 1  

MA MA.MEA , mV , 1 MA.TIM, s, 1 MA.TEM , °C , 1  

BP# BP#.MEA , mV , 1 BP#.TIM , s , 1 BP#.TEM , °C , 1  

Table 21 Command MEAS Ipol

Column 2: Variable Column 3 Column 4 Column 5 Column 6

EME EME , mV , 1    

ETE ETE , °C , 1    

FP# FP#.MEA , mV , 1 FP#.TIM , s , 1 FP#.TEM , °C , 1  

MI MI.MEA , mV , 1 MI.TIM , s , 1 MI.TEM , °C , 1  

MA MA.MEA , mV , 1 MA.TIM, s, 1 MA.TEM , °C , 1  

BP# BP#.MEA , mV , 1 BP#.TIM , s , 1 BP#.TEM , °C , 1  

Table 22 Command MEAS Upol

Column 2: Variable Column 3 Column 4 Column 5 Column 6

EME EME , µA , 1    

ETE ETE , °C , 1    

FP# FP#.MEA , µA , 1 FP#.TIM , s , 1 FP#.TEM , °C , 1  

MI MI.MEA , µA , 1 MI.TIM , s , 1 MI.TEM , °C , 1  

MA MA.MEA , µA , 1 MA.TIM, s, 1 MA.TEM , °C , 1  

BP# BP#.MEA , µA , 1 BP#.TIM , s , 1 BP#.TEM , °C , 1  

Table 23 Command MEAS T

Column 2: Variable Column 3 Column 4 Column 5 Column 6

EME EME , °C , 1    
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Column 2: Variable Column 3 Column 4 Column 5 Column 6

FP# FP#.MEA , °C , 3 FP#.TIM , s , 1   

MI MI.MEA , °C , 1 MI.TIM , s , 1   

MA MA.MEA , °C , 1 MA.TIM, s, 1   

BP# BP#.MEA , °C , 1 BP#.TIM , s , 1   

Table 24 Command MEAS T/Flow

Column 2: Variable Column 3 Column 4 Column 5 Column 6

EME EME , °C , 1    

MI MI.MEA , °C , 1 MI.GFL , mL/min ,
1

MI.TIM , s , 1  

MA MA.MEA , °C , 3 MA.GFL , mL/min ,
1

MA.TIM, s, 1  

Table 25 Command MEAS Conc

Column 2: Variable Column 3 Column 4 Column 5 Column 6

EME EME , "selected
unit" , 3

   

ETE ETE , °C , 1    

Table 26 Command MEAS Cond

Column 2: Variable Column 3 Column 4 Column 5 Column 6

EME EME , mS/cm , 2 RTE , °C , 1   

ETE ETE , °C , 1    

FP# FP#.MEA , mS/cm ,
2

FP#.TIM , s , 1 FP#.TEM , °C , 1  

MI MI.MEA , mS/cm ,
2

MI.TIM , s , 1 MI.TEM , °C , 1  

MA MA.MEA , mS/cm ,
2

MA.TIM, s, 1 MA.TEM , °C , 1  

BP# BP#.MEA , mS/cm ,
2

BP#.TIM , s , 1 BP#.TEM , °C , 1  

Table 27 Command CAL LOOP pH

Column 2: Variable Column 3 Column 4 Column 5 Column 6

SLO SLO , % , 1    

ENP ENP , – , 3    
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Table 28 Command CAL LOOP Conc

Column 2: Variable Column 3 Column 4 Column 5 Column 6

SLO SLO , mV , 1    

ENP ENP , – , 3    

BLV BLV , "unit from
configuration" , 2

   

Table 29 Befehl CAL Cond

Column 2: Variable Column 3 Column 4 Column 5 Column 6

CLC CLC , /cm , 3    

RTE RTE , °C , 1    

Table 30 Command STDADD

Column 2: Variable Column 3 Column 4 Column 5 Column 6

SLO SLO , mV , 1    

ENP ENP , mV , 1    

RES RES , "selected
unit" , 1

   

VAR VAR , "leer" , 3    

Table 31 Command DOS pH

Column 2: Variable Column 3 Column 4 Column 5 Column 6

MR MR.MRT , mL/min ,
4

MR.MRS , mL/min ,
4

MR.MRC , "leer" , 3  

Table 32 Command DOS U

Column 2: Variable Column 3 Column 4 Column 5 Column 6

MR MR.MRT , mL/min ,
4

MR.MRS , mL/min ,
4

MR.MRC , "leer" , 3  

4.7.4 Results - Calculation #
Tab: Database ▶ Results ▶ Command name

For each calculation command the results and (if existent and desired) the
corresponding statistical evaluations are displayed on a separate tab Cal-
culation_#. The sequence of the shown results corresponds to that defined
in the calculation command. The display of the statistical evaluations can be
selected in the dialog window Properties result window

For every single result a maximum of the following information is displayed:
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Result "Result name"

Result "Result name"

Display of the result with variable name.

Note

Only the last results having been calculated will be shown. For example,
if there are several commands that generate a result with the same name,
then the corresponding result data will be shown only for that command
that was the last to calculate the result. Nothing will be shown for the
other commands.

"Result"

Shows the result name and result value with the defined number of decimal
places and units.

Note

If a result value is monitored and lies within the limit value defined in the
CALC command then the text will be shown in green, if it lies outside the
limits it will be shown in red text color.

Mean value:

Shows the mean value for statistically evaluated results.

s(abs):

Shows the absolute standard deviation for statistically evaluated results.

s(rel):

Shows the relative standard deviation for statistically evaluated results.

Minimum:

Shows the minimum value for statistically evaluated results.

Maximum:

Shows the maximum value for statistically evaluated results.

n:

Shows the number of measurements for statistically evaluated results.
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Assignment:

Assigns the result to one of the result columns RS01...RS25 in the Deter-
mination overview.

Formula:

Shows the formula used for calculating the result.

'Variable name':

'Displays the variables used in the formula.

Note

Variables that have not been created during the determination are not
displayed and lead to invalid results.

4.7.5 Results - Properties
Dialog window Database ▶ View ▶ Properties ▶ Properties ▶ Properties result win-
dow

In the dialog window Properties result window the information to be
displayed in the result window can be selected.

Display for results overview

Selection of the information to be displayed on the tab Results over-
view.

Results

on | off (Default value: on)

Shows all results.

Statistics

on | off (Default value: off)

Shows the statistics results.

Display for calculation commands

Selection of the information to be displayed on the tabs Calculation_#.

Results

on | off (Default value: on)

Shows the results defined in the calculation command.
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Statistics

on | off (Default value: off)

Shows the statistics results.

Assignment

on | off (Default value: on)

Shows the assignment.

Formula

on | off (Default value: on)

Shows the calculation formula.

Variables

on | off (Default value: off)

Displays the variables used in the formula.

4.8 Subwindow curves

4.8.1 Curves - General
Dialog window: Database ▶ Curves

Subwindow curves

The subwindows Curves 1...5 are subwindows in the program part Data-
base, in which the measuring points generated by the measuring com-
mands for the focused determination in the Determination table are
shown as a graph. When navigating in the determination overview this data
will be updated automatically (with a certain delay).

The subwindows Curves 1...5 can be switched on in the program part
Database during the definition of the layout and thus made visible. They
can be enlarged and reduced as required; they can also be maximized.

Tabs

In the curve window a tab with the corresponding command name and the
run index (e.g. Chloride.1) is provided for each execution of a measuring
command; their sequence is determined by the method.

Show curves

The curves of the selected determination are shown on the tabs with the
properties defined per window and per command type. The command type
(e.g. DET pH) is shown above the left-hand y axis.

Curves can be zoomed as often as required by spanning a section of the
curve display with the left mouse button pressed down. Zooming can be
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undone with a double-click on the section of the graph or with the context-
sensitive menu command Show All.

Note

When a new determination is selected the complete curve is always
shown, i.e. the zoom range is not retained when the determination is
changed.

Curves can be copied into the clipboard with the context-sensitive menu
command Copy graphics.

4.8.2 Curves - Measuring point list
Dialog window: Database ▶ Curves

With the context-sensitive menu item Measuring point list... in the curve
window the dialog window Measuring point list - 'Command
name.#' opens for showing the measuring point list for the selected curve.

The display of the measuring points in the table can be defined per window
and per command type in the Properties - Curve #

4.8.3 Properties

4.8.3.1 Curve properties - Overview

Dialog window: Database ▶ Curves ▶ Properties curves #

The properties for the display of curves can be set on the following 5 tabs:

￭ x axis
Parameters for the graphical display of the curves on the x axis.

￭ y1 axis
Parameters for the graphical display of the curves on the y1 axis (left-
hand y axis).

￭ y2 axis
Parameters for the graphical display of the curves on the y2 axis (right-
hand y axis).

￭ Options
Options for graphical display of curves.

￭ Measuring point list
Parameters for showing the measuring point list.

4.8.3.2 Curve properties - x axis

Dialog window: Database ▶ Curves ▶ Properties curves # ▶ x axis

Parameters for the graphical display of the curves on the x axis.
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Command type

Selection of the command type for which the curve properties are to be
defined. The curve properties defined for each command type are saved per
curve window and per client.

Selection DET | MET | SET | KFT | KFC | BRC | STAT |
MEAS | DOS

Default value DET

Note

When the dialog window is opened, those Command type will be selec-
ted as standard which applies for the curve shown in the curve window.

Autoscaling

on | off (Default value: on)

If this option is switched on then all axes in the curve window will be scaled
automatically. In this case the fields Start value and End value cannot be
edited.

Size

Selection of the quantity to be shown on the x axis.

For DET commands
Selection Volume [mL] | Measured value | ERC | Time [s] |

Temperature [°C] | Calculated 1...3 | External
1...3

Default value Volume [mL]

For MET commands
Selection Volume [mL] | Measured value | dMW | Time

[s] | Temperature [°C] | Calculated 1...3 | Exter-
nal 1...3

Default value Volume [mL]

For SET, STAT, DOS and KFT commands
Selection Time [s] | Measured value | Volume [mL] | dV/dt

[µL/min] | Temperature [°C] | Calculated 1...3 |
External 1...3

Default value Time [s]
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For KFC commands
Selection Time [s] | Measured value | Amount [µg] |

Charge [mAs] | Drift [µg/min] | dV/dt [µ/min] |
Ugen | Igen [mA] | Calculated 1...3 | External
1...3

Default value Time [s]

For BRC commands
Selection Time [s] | Measured value | Amount [µg] |

Charge [mAs] | Drift [µg/min] | dV/dt [µ/min] |
Ugen | Igen [mA] | Calculated 1...3 | External
1...3

Default value Time [s]

For MEAS commands
Selection Time [s] | Measured value | dMW/dt | Tempera-

ture [°C] | Calculated 1...3 | External 1...3
Default value Time [s]

Label

Freely definable axis label for the x axis. With auto the designation from the
field Size will be used.

Selection 50 characters | auto
Default value auto

Scaling

Start value

Initial value for scaling the x axis.

Only editable when autoscaling is disabled.
Range -1.00E+12 ... +1.00E+12 
Default value 0 

End value

End value for scaling the x axis.

Only editable when autoscaling is disabled.
Range -1.00E+12 ... +1.00E+12 
Default value 1000 



4.8  Subwindow curves ￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭

276 ￭￭￭￭￭￭￭￭ tiBase 1.0

4.8.3.3 Curve properties - y1 axis

Dialog window: Database ▶ Curves ▶ Properties curves # ▶ y1 axis

Parameters for the graphical display of the curves on the y1 axis (left-hand
y axis).

Command type

Selection of the command type for which the curve properties are to be
defined. The curve properties defined for each command type are saved per
curve window and per client.

Selection DET | MET | SET | KFT | KFC | BRC | STAT |
MEAS | DOS

Default value DET

Note

When the dialog window is opened, those Command type will be selec-
ted as standard which applies for the curve shown in the curve window.

Autoscaling

on | off (Default value: on)

If this option is switched on then all axes in the curve window will be scaled
automatically. In this case the fields Start value and End value cannot be
edited.

Size

Selection of the quantity to be shown on the y1 axis.

For DET commands
Selection Volume [mL] | Measured value | ERC | Time [s] |

Temperature [°C] | Calculated 1...3 | External
1...3

Default value Measured value

For MET commands
Selection Volume [mL] | Measured value | dMW | Time

[s] | Temperature [°C] | Calculated 1...3 | Exter-
nal 1...3

Default value Measured value



￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭ 4 Database

tiBase 1.0 ￭￭￭￭￭￭￭￭ 277

For SET, STAT, DOS and KFT commands
Selection Time [s] | Measured value | Volume [mL] | dV/dt

[µL/min] | Temperature [°C] | Calculated 1...3 |
External 1...3

Default value Volume [mL]

For KFC commands
Selection Time [s] | Measured value | Amount [µg] |

Charge [mAs] | Drift [µg/min] | dV/dt [µ/min] |
Ugen | Igen [mA] | Calculated 1...3 | External
1...3

Default value Amount [µg]

For BRC commands
Selection Time [s] | Measured value | Amount [µg] |

Charge [mAs] | Drift [µg/min] | dV/dt [µ/min] |
Ugen | Igen [mA] | Calculated 1...3 | External
1...3

Default value Amount [µg]

For MEAS commands
Selection Time [s] | Measured value | dMW/dt | Tempera-

ture [°C] | Calculated 1...3 | External 1...3
Default value Measured value

Label

Freely definable axis label for the y1 axis. With auto the designation from
the field Size will be used.

Selection 50 characters | auto
Default value auto

Scaling

Start value

Initial value for scaling the y1 axis.

Only editable when autoscaling is disabled.
Range -1.00E+12 ... +1.00E+12 
Default value 0 

End value

End value for scaling the y1 axis.
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Only editable when autoscaling is disabled.
Range -1.00E+12 ... +1.00E+12 
Default value 1000 

Curve

Curve color

Selection of the color for the curve line.

Selection 13 colors | blue
Default value blue

Symbol

Selection of the symbol for the display of the individual measuring points.

Selection ●   |  ╳   |  ✸   |  ￭   |  ▲   | No symbol
Default value No symbol

No symbol
Measuring points are not shown.

Note

With curves, for which the distance between to measuring points is
smaller than 5 pixels, the separate measuring points are not displayed
anymore, even if a symbol has been selected. In this case, the graphics
window can eventually be enlarged in order to display the symbols again.

Symbol color

Selection of the color for the measuring point symbol.

Selection 13 colors | blue
Default value blue

Smoothing

Smoothing

on | off (Default value: on)

Switches smoothing on/off for the curve.

Smoothing factor x axis

Factor for smoothing on the x axis.

Range 0.01 ... 1000 
Default value 0.01 
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Smoothing factor y-axis

Factor for smoothing on the y axis.

Range 0.01 ... 1000 
Default value 0.01 

Show with original curve

on | off (Default value: off)

If this check box is activated, then the original curve (solid line, same color)
will be shown in addition to the smoothed curve (dotted line).

4.8.3.4 Curve properties - y2 axis

Dialog window: Database ▶ Curves ▶ Properties curves # ▶ y2 axis

Parameters for the graphical display of the curves on the y2 axis (right-hand
y axis).

Command type

Selection of the command type for which the curve properties are to be
defined. The curve properties defined for each command type are saved per
curve window and per client.

Selection DET | MET | SET | KFT | KFC | BRC | STAT |
MEAS | DOS

Default value DET

Note

When the dialog window is opened, those Command type will be selec-
ted as standard which applies for the curve shown in the curve window.

Autoscaling

on | off (Default value: on)

If this option is switched on then all axes in the curve window will be scaled
automatically. In this case the fields Start value and End value cannot be
edited.

Size

Selection of the quantity to be shown on the y2 axis.
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For DET commands
Selection Volume [mL] | Measured value | ERC | Time [s] |

Temperature [°C] | Calculated 1...3 | External
1...3 | off

Default value off

For MET commands
Selection Volume [mL] | Measured value | dMW | Time

[s] | Temperature [°C] | Calculated 1...3 | Exter-
nal 1...3 | off

Default value off

For SET, STAT, DOS and KFT commands
Selection Time [s] | Measured value | Volume [mL] | dV/dt

[µL/min] | Temperature [°C] | Calculated 1...3 |
External 1...3 | off

Default value off

For KFC commands
Selection Time [s] | Measured value | Charge [mAs] |

Amount [µg] | Drift [µg/min] | Ugen | Igen [mA]
| Calculated 1...3 | External 1...3 | off

Default value off

For BRC commands
Selection Time [s] | Measured value | Amount [mAs] |

Water [µg] | Drift [µg/min] | Ugen | Igen [mA] |
Calculated 1...3 | External 1...3 | off

Default value off

Label

Freely definable axis label for the y1 axis. With auto the designation from
the field Size will be used.

Selection 50 characters | auto
Default value auto

Curve

Curve color

Selection of the color for the curve line.

Selection 13 colors | pink
Default value pink
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Symbol

Selection of the symbol for the display of the individual measuring points.

Selection 5 symbols | No symbol
Default value No symbol

No symbol
Measuring points are not shown.

Note

With curves, for which the distance between to measuring points is
smaller than 5 pixels, the separate measuring points are not displayed
anymore, even if a symbol has been selected. In this case, the graphics
window can eventually be enlarged in order to display the symbols again.

Symbol color

Selection of the color for the measuring point symbol.

Selection 13 colors | pink
Default value pink

Smoothing

Smoothing

on | off (Default value: on)

Enables/disables the smoothing for curves.

Smoothing factor x axis

Factor for smoothing on the x axis.

Range 0.01 ... 1000 
Default value 0.01 

Smoothing factor y-axis

Factor for smoothing on the y axis.

Range 0.01 ... 1000 
Default value 0.01 
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4.8.3.5 Curve properties - Options

Dialog window: Database ▶ Curves ▶ Properties curves # ▶ Options

Options for graphical display of curves.

Command type

Selection of the command type for which the curve properties are to be
defined. The curve properties defined for each command type are saved per
curve window and per client.

Selection DET | MET | SET | KFT | KFC | BRC | STAT |
MEAS | DOS

Default value DET

Note

When the dialog window is opened, those Command type will be selec-
ted as standard which applies for the curve shown in the curve window.

Autoscaling

on | off (Default value: on)

If this option is switched on then all axes in the curve window will be scaled
automatically. In this case the fields Start value and End value cannot be
edited.

Display grid

Display grid

on | off (Default value: off)

If this check box is actjvated then a grid will be shown against the back-
ground.

Grid type

Selection of the type of grid line.

Selection Line types | dotted
Default value dotted

Grid color

Selection of the grid line color.

Selection 13 colors | gray
Default value gray
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Background

Background color

Selection of the color for the curve background.

Selection 13 colors | white
Default value white

Show endpoints

Show endpoints

on | off (Default value: on)

If this check box is activated then the endpoints found will be shown on the
curve by the symbol ♦ and labeled with EP# (potentiometric endpoint),
BP# (break point), FP# (fixed endpoint), HP (HNP), MI (minimum value) or
MA (maximum value).

Automatic EPs

Selection of the color for automatically set endpoints.

Selection 13 colors | black
Default value black

Manual EPs

Selects the color for manually set endpoints.

Selection 13 colors | pink
Default value pink

Show evaluation lines

Show evaluation lines

on | off (Default value: off)

If this check box is activated the evaluation lines (tangents, auxiliary lines)
will be shown.

Tangents

Selection of the color for the tangents and auxiliary lines.

Selection 13 colors | light green
Default value light green

Auxiliary lines

Selection of the color for the auxiliary lines.

Selection 13 colors | blue
Default value blue
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4.8.3.6 Curve properties - Measuring point list

Dialog window: Database ▶ Curves ▶ Properties curves # ▶ Options

Parameters for showing the measuring point list.

Command type

Selection of the command type for which the curve properties are to be
defined. The curve properties defined for each command type are saved per
curve window and per client.

Selection DET | MET | SET | KFT | KFC | BRC | STAT |
MEAS | DOS

Default value DET

Note

When the dialog window is opened, those Command type will be selec-
ted as standard which applies for the curve shown in the curve window.

Autoscaling

on | off (Default value: on)

If this option is switched on then all axes in the curve window will be scaled
automatically. In this case the fields Start value and End value cannot be
edited.

Available columns

Shows all fields that can be displayed as columns in the measuring point list.

Displayed columns

Shows all fields that will be shown as columns in the measuring point list.

Adds the selected column to the measuring point list.

Removes the selected column from the measuring point list.

 

Modifies the sequence of displayed columns by moving the selected column
up and down.
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5 How to proceed?

5.1 Backup

5.1.1 Backing up database
How to proceed?

General

In tiBase , determination databases that in contrast to the configura-
tion database can be generated by the user and contain the determination
data are referred to as databases. Included among such determination data
is the method data used for the determination, the measuring data gener-
ated during the determination and the results calculated from it.

In local server systems (tiBase  full) the databases are stored on the drives
administered by the computer and are only available to those users regis-
tered on that computer who have the appropriate access rights. In client/
server systems (tiBase  multi) the databases are stored on drives adminis-
tered centrally by the server and are available globally throughout the entire
Client/Server system, i.e. all users with the appropriate access rights can use
these databases.

Note

Each determination database has to be backed up separately. Afterwards,
it is recommended that all backed-up files be copied to an external direc-
tory or to a CD/DVD.

Backing up database manually

 

1 Select program part Database.

 

2 Click on the symbol  or menu item File ▶ Database manager….

The dialog window Database manager opens.

 

3 Select database.

 

4 Click on [Backup] in the dialog window Database manager.

The dialog window Backup database 'Database name' is opened.
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5 Select the directory for the backup in the field Backup directory.

 

6 Select or enter the name for the Backup file. If an existing backup file
is selected it will be overwritten.

Note

If the backup directory is on a network drive, the backup date should
be added manually to the Backup name field because the backup
date information is not available when restoring.

 

7 Click on [Start].

The manual backup of the database is started and the database is
backed up to the selected directory.

Backing up database automatically

 

1 Select program part Database.

 

2 Click on the symbol  or menu item File ▶ Database manager….

The dialog window Database manager opens.

 

3 Select desired database and click on [Properties].

The dialog window Properties - Database - 'Database name'
opens for editing the database properties.

 

4 On the tab General enter a comment on the database in the field
Comment.

 

5 On the tab Backup enable the check box Backup monitoring.

 

6 Enter Interval for backup monitoring or date for the next backup in
the field Next backup.

 

7 Activate the Start backup automatically check box.

 

8 Select the directory for the backup in the field Backup directory.
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9 Click on [OK].

The dialog window Properties - Database is closed and the database
will be backed up to the selected directory at the desired time.

5.1.2 Restoring database
How to proceed?

1 Select program part Database.

 

2 Click on the symbol  or menu item File ▶ Database manager….

The Database manager window opens.

 

3 Click on [Restore] in the Database manager dialog window.

The Restore databases dialog window opens.

 

4 Select the directory in the Backup directory in which the desired
database was backed up.

 

5 Select or enter the name for the desired backup file in the Backup
name list box.

 

6 Enter the name under Save as under which the database is to be
restored.

 

7 Click on [Start].

The database restoring is started.

Note

Existing databases cannot be overwritten, i.e. they must first be
deleted so that the database can be recovered under its old name.

5.1.3 Backing up configuration data
How to proceed?

General

The configuration data in tiBase  is saved in the Configuration data-
base. Included among the configuration data are settings for the data
import Security settings (see Chapter 3.2.2.1, page 82), User adminis-
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tration (see Chapter 3.2.1.1, page 74), Program administration(see
Chapter 3.2.3.1, page 91) and templates.

For local server systems (tiBase  full) the configuration database is located
in the program folder of the computer on which the program has been
installed. In Client/Server systems (tiBase  multi) the configuration database
is stored centrally on the server and saves and contains all the configuration
data of all computers (clients) that are connected to this server.

Note

It is strongly recommended that the configuration database be backed up
periodically.

Backing up configuration data manually

 

1 Select program part Configuration.

 

2 Click on the menu item File ▶ Backup ▶ Manually.

The dialog window Backup configuration data manually opens.

 

3 Select the directory for the backup in the field Backup directory.

 

4 Select or enter a new name for the backup file in the Backup name
list box. If an existing backup file is selected it will be overwritten.

Note

If the backup directory is on a network drive, the backup date should
be added manually to the Backup name because the backup date
information is not available when the directory is restored.

 

5 Click on [Start].

The manual backup is started and the configuration database is backed
up to the selected directory.

Backing up configuration data automatically

 

1 Select program part Configuration.



￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭ 5 How to proceed?

tiBase 1.0 ￭￭￭￭￭￭￭￭ 289

 

2 Click on menu item File ▶ Backup ▶ Automatically.

The dialog window Backup configuration data automatically
opens.

 

3 Activate the Automatic backup check box.

 

4 Enter Interval for backup monitoring or date for the next backup in
the field Next backup.

 

5 Select the directory for the backup in the field Backup directory.

 

6 Click on [OK].

The dialog window Backup configuration data automatically is
closed and the configuration database will be backed up to the selected
directory at the desired time.

5.1.4 Restoring configuration data
How to proceed?

Exit tiBase full

1 Exit tiBase .

 

2 Start the file ConfigRestore.exe in the program directory …\tiBase
\bin.

The dialog window Restore configuration data opens.

 

3 Select the directory in the Backup directory field in which the desired
database was backed up.

 

4 Select or enter the name for the desired backup file in the Backup
name list box.

 

5 Click on [Start].

The restoring of the configuration database is started.

tiBase  multi

 

1 Make sure that tiBase  is closed on all clients connected to the server
and on the server itself.



5.2 Determinations ￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭

290 ￭￭￭￭￭￭￭￭ tiBase 1.0

 

2 Start the file ConfigRestore.exe in the program directory...\TiBaser
\bin on the server.

The dialog window Restore configuration data opens.

 

3 Select the directory in the Backup directory field in which the con-
figuration database was backed up.

 

4 Select or enter the name for the desired backup file in the Backup
name list box.

 

5 Click on [Start].

The restoring of the configuration database is started.

5.2 Determinations

5.2.1 Search for determinations
How to proceed?

1 Select program part Database.

 

2 Click on the symbol  or the menu item File ▶ Open....

The dialog window Open database opens.

 

3 Select desired database or enter name in the field Database name.

 

4 Click on [Open].

The selected database opens and its data sets are displayed in the
Determination overview.

 

5 Click on the symbol  or the menu item Determination ▶ Find....

The dialog window Search - Database 'Database name' is opened.

 

6 Enter or select desired search terms and search options.

 

7 Click on [Search next].

The next determination containing the search term is marked in the
Determination overview.
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5.2.2 Filter determinations
How to proceed?

Opening the database

 

1 Select program part Database.

 

2 Click on the symbol  or the menu item File ▶ Open....

The dialog window Open database opens.

 

3 Select desired database or enter name in the field Database name.

 

4 Click on [Open].

The selected database opens and its data sets are displayed in the
Determination overview.

Filtering can now be done via quick filter or special filter in the Determi-
nation overview window.

Quick filter

 

1 Click on the symbol  or on Filter ▶ Quick filter in the context menu.

After this function has been selected, the field in which the cursor is
located will have a yellow background when navigating in the deter-
mination table.

 

2 Double click on the desired field with the left-hand mouse key.

The contents of the field selected in the table will be set as a filter
condition and this filter will be applied directly to the table.

Note

The quick filter can be used again within the filtered table, so that
the number of entries can be limited step by step.
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Defining and using special filter

 

1 Click on the symbol  or on Filter ▶ Special filter in the context
menu

The dialog window Special filter opens for defining user-specific fil-
ters.

 

2 Use the Edit ▶ Edit line menu item to open the dialog window Edit
filter criterion New filter.

 

3 Define filter criteria.

 

4 Click on [Save filter].

 

5 Click on [Apply filter].

The table will be filtered.

Using special filter

 

1 In the list box Filter, select the desired special filter.

The table will be filtered.

5.2.3 Sign determination
How to proceed?

Selecting determination

 

1 Select program part Database.

 

2 Click on the symbol  or the menu item File ▶ Open....

The dialog window Open database opens.

 

3 Select desired database or enter name in the field Database name.

 

4 Click on [Open].

The selected database opens and its data sets are displayed in the
Determination overview.
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5 Select desired determination.

Signature 1

Note

Determinations can only be signed at level 1 if the user belongs to a user
group with the corresponding authorization (see Chapter 3.2.1.2.3, page
77).

 

1 Click on the symbol  or menu item Determina-
tions ▶ Sign ▶ Signature 1….

The window Signature Level 1 opens. If the selected determination
can be signed, Signature possible is displayed in the field Info.

 

2 Enter or select User, Password, Reason and Comment.

 

3 Click on [Sign].

The selected determination will be signed on level 1.

Note

Determinations that have been signed at level 1 can be reprocessed
and deleted. If the modified determination is saved as a new deter-
mination version then all existing signatures will be deleted auto-
matically, i.e. the determination must be signed again.

Signature 2

Note

Determinations can only be signed at level 2 if the user belongs to a user
group with the corresponding authorization (see Chapter 3.2.1.2.3, page
77).

 

1 Click on the symbol  or menu item Determina-
tions ▶ Sign ▶ Signature 2….
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The window Signature Level 2 opens. If the selected determination
can be signed, Signature possible is displayed in the field Info.

 

2 Enter or select User, Password, Reason and Comment and click on
[Sign].

The selected determination will be signed on level 2.

Note

Determinations that can be signed at level 2 are blocked, i.e. they
can neither be reprocessed nor deleted. In order to be able to edit
such determinations again the signatures at level 2 must first be
deleted.

5.2.4 Export determinations
How to proceed?

Defining export template

 

1 Select program part Database.

 

2 Click on menu item Tools ▶ Templates ▶ Export templates….

The window Export templates opens.

 

3 Click on [New].

The window Export templates – 'New file' opens.

 

4 Define the properties of the new export template.

 

5 Click on [OK].

The dialog window is closed.

 

6 Click on [Close].

The dialog window Export templates is closed.

Selecting determinations

 

1 Select program part Database.
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2 Click on the symbol  or the menu item File ▶ Open....

The dialog window Open database opens.

 

3 Select desired database or enter name in the field Database name.

 

4 Click on [Open].

The selected database opens and its data sets are displayed in the
Determination overview.

 

5 Select desired determinations.

Export determinations

 

1 Click on the menu item Determinations ▶ Export....

The window Export determinations opens.

 

2 In the field Selection select the desired option (All records or Selec-
ted records).

 

3 In the list box Export template, select an export template.

 

4 Click on [OK].

The selected determinations are exported into the directory defined in
the export template.

5.2.5 Import determinations 
How to proceed?

1 Select program part Database.

 

2 Click on the symbol  or the menu item File ▶ Open....

The dialog window Open database opens.

 

3 Select desired database or enter name in the field Database name.

 

4 Click on [Open].

The selected database opens and its data sets are displayed in the
Determination overview.
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5 Click on the menu item Determinations ▶ Import.... or the symbol

.

The window Import determinations opens.

 

6 Select desired determinations.

 

7 Click on [Open].

The selected determinations are imported into the open database.

Note

Only determinations in the file format *.tdet and *.txt can be
imported.

5.2.6 Deleting determinations
How to proceed?

1 Select program part Database.

 

2 Click on the symbol  or the menu item File ▶ Open....

The dialog window Open database opens.

 

3 Select desired database or enter name in the field Database name.

 

4 Click on [Open].

The selected database opens and its data sets are displayed in the
Determination overview.

 

5 Select desired determinations.

 

6 Click on the symbol  or the menu item Determination ▶ Delete.

 

7 Confirm deleting.

The selected determinations with all Determination versions are
deleted.
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Note

If the option Comment on modification of determinations in
the Security settings is enabled, then the window Modification
comment determination will appear before the modification is
saved.

5.2.7 Make the determination version current
How to proceed?

1 Select program part Database.

 

2 Click on the symbol  or the menu item File ▶ Open....

The dialog window Open database opens.

 

3 Select desired database or enter name in the field Database name.

 

4 Click on [Open].

The selected database opens and its data sets are displayed in the
Determination overview.

 

5 Select desired determination.

 

6 Click on the symbol  or menu item Determinations ▶ Show his-
tory….

Only the currently selected determination in the determination
table as well as all the previous versions of this determination will be
shown.

 

7 Select desired determination that is to be made current.

 

8 Click on the symbol  or the menu item Determination ▶ Make
current.

The determination version selected in the determination table will again
be made the current determination version. This creates a new deter-
mination, the version number of which is increased by +1 compared
with the last version to have been saved.
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5.2.8 Reprocessing determinations
How to proceed?

Note

Determinations that have a signature at level 2 cannot be reprocessed.

 

1 Select program part Database.

 

2 Click on the symbol  or the menu item File ▶ Open....

 

3 Select desired database or enter name in the field Database name.

The selected database opens and its data sets are displayed in the
Determination overview.

 

4 Select desired determinations.

 

5 Click on the symbol  or the menu item Determination ▶ Reproc-
ess....

The dialog window Reprocessing opens. Displayed is the first of the
selected determinations.

Modify variables

 

1 Select the Variables tab.

 

2 Select the desired variable in the table.

 

3 Click on [Modify].

The dialog window Modify variable opens..

 

4 In the field Value, enter a new value for the variable.

 

5 Click on [OK].

 

6 Click on [Recalculate].
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The selected determinations are recalculated. The results of this recal-
culation are entered automatically in the subwindow Result view.

Note

If a variable is modified, then with [Recalculate] all the selected
determinations will be recalculated with the new value. If one vari-
able is not modified then when several determinations are recalcu-
lated the original value of the variable will be used (i.e. variables with
the same name but different values will not be overwritten until they
are deliberately modified).

 

7 In the dialog window Reprocessing click on [OK].

Each determination that has been modified by reprocessing will be
saved as a new version with a version number increased by +1 and the
dialog window Reprocessing will be closed. This button is inactive
when the recalculation has not yet been triggered and if not all the
selected determinations could be reprocessed.

Modify calculation

 

1 Change to the Calculations tab.

 

2 Click on [New].

The dialog window Result New result - RSxx is opened.

 

3 Modify the new calculation as desired.

 

4 Click on [OK].

 

5 Click on [Recalculate].

The selected determinations are recalculated. The results of this recal-
culation are entered automatically in the subwindow Result view.

 

6 If desired, save the modified method with [Save as...] under the same
name or under a new name.

If the modified method is saved under the name of an existing method
then all the earlier method versions will be deleted and a new version
with the number 1 will be generated.
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7 In the dialog window Reprocessing click on [OK].

Each determination that has been modified by reprocessing will be
saved as a new version with a version number increased by +1 and the
dialog window Reprocessing will be closed. This button is inactive
when the recalculation has not yet been triggered and if not all the
selected determinations could be reprocessed.

Modify statistics

Note

The tab Statistics will only be shown when the last determination (and
only this one) is selected from a set of determinations which, because of
the statistics defined in the method, belong together.

 

1 Change to the Statistics tab.

 

2 In the field Result name, select the result whose Result value is to
be displayed.

 

3 Select desired determination whose result value(s) should be switched
on or off for the statistics.

 

4 If only the selected result of the determination has to be switched on
or off for the statistics, click on [Result on/off].

If the result is switched off, an asterisk (*) appears behind the result
value, is it switched on again, the asterisk disappears.

 

5 If all results of the selected determination have to be switched on or
off for the statistics, click on [Determination on/off].

If the determination is switched off then an asterisk (*) appears behind
all result values in the table and the line is shown as inactive (gray); if
it is switched on again then the asterisks will disappear.
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Note

If the results of a determination are switched off, the statistics for
these results will be switched off when this determination is recal-
culated, i.e. no data for the mean value and standard deviations will
be shown. However, the determinations remain statistically linked
to each other so that the results can also be switched on again.

 

6 Click on [Recalculate].

The selected determinations are recalculated. The results of this recal-
culation are entered automatically in the subwindow Result view.

 

7 In the dialog window Reprocessing click on [OK].

Each determination that has been modified by reprocessing will be
saved as a new version with a version number increased by +1 and the
dialog window Reprocessing will be closed. This button is inactive
when the recalculation has not yet been triggered and if not all the
selected determinations could be reprocessed.

Edit curve evaluation

Note

The tab Curve evaluation is only shown when a single determination is
selected that contains curves that can be evaluated.

 

1 Change to the tab Curve evaluation.

 

2 In the field Command name, select the command whose curve is to
be displayed.

 

3 Click on [Edit].

The dialog window Curve evaluation opens for manually reprocess-
ing the curve evaluation.

 

4 Modify curve evaluation manually.

 

5 Then close the window with [OK].
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6 Click on [Recalculate].

The selected determinations are recalculated. The results of this recal-
culation are entered automatically in the subwindow Result view.

 

7 In the dialog window Reprocessing click on [OK].

Each determination that has been modified by reprocessing will be
saved as a new version with a version number increased by +1 and the
subwindow Reprocessing will be closed. This button is inactive when
the recalculation has not yet been triggered and if not all the selected
determinations could have been recalculated.

5.2.9 Printing determination report 
How to proceed?

1 Select program part Database.

 

2 Click on the symbol  or the menu item File ▶ Open....

The dialog window Open database opens.

 

3 Select desired database or enter name in the field Database name.

 

4 Click on [Open].

The selected database opens and its data sets are displayed in the
Determination overview. The database name is displayed in the title
bar of the program, the number of currently opened databases is dis-
played in the left upper corner of the database symbol.

Note

A maximum of 4 databases can be opened, but only 2 can be dis-
played at the same time. Databases that are open at the time the
program is ended will be automatically opened the next time the
program is started.

 

5 Select desired determinations.

 

6 Click on the menu item File ▶ Print ▶ Report....

The dialog window Report output opens.
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7 Under Selection, select desired determinations.

 

8 Under Report type, select the option Original report or Report
template.

 

9 Under Output target, enable the check box Printer and/or select
PDF file.

Note

If several reports are produced simultaneously as a PDF file then an
index will be automatically appended to the file name.

 

10 In the dialog window Report output, click on [OK].

The reports of the selected determination are put out.

5.2.10 Printing determination overview 
How to proceed?

1 Select program part Database.

 

2 Click on the symbol  or the menu item File ▶ Open....

The dialog window Open database opens.

 

3 Select desired database or enter name in the field Database name.

 

4 Click on [Open].

The selected database opens and its data sets are displayed in the
Determination overview. The database name is displayed in the title
bar of the program, the number of currently opened databases is dis-
played in the left upper corner of the database symbol.

Note

A maximum of 4 databases can be opened, but only 2 can be dis-
played at the same time. Databases that are open at the time the
program is ended will be automatically opened the next time the
program is started.
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5 Select desired determinations.

 

6 Click on menu item File ▶ Print ▶ Determination overview….

The dialog window Print determination overview (PDF) opens.

 

7 Under Selection, select desired determinations.

 

8 Under Orientation, select the option Portrait format or Landscape
format.

 

9 Click on [OK].

The determination overview is opened as PDF file.

5.3 Databases

5.3.1 Database in general
In tiBase , determination databases that in contrast to the configura-
tion database can be generated by the user and contain the determination
data are referred to as databases. Included among such determination data
is the method data used for the determination, the measuring data gener-
ated during the determination and the results calculated from it.

In local server systems (tiBase  full) the databases are stored on the drives
administered by the computer and are only available to those users regis-
tered on that computer who have the appropriate access rights. In client/
server systems (tiBase  multi) the databases are stored on drives adminis-
tered centrally by the server and are available globally throughout the entire
Client/Server system, i.e. all users with the appropriate access rights can use
these databases.

Note

Each determination database has to be backed up separately. Afterwards,
it is recommended that all backed-up files be copied to an external direc-
tory or to a CD/DVD.
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5.3.2 Open database
How to proceed?

1 Select program part Database.

 

2 Click on the symbol  or the menu item File ▶ Open....

The dialog window Open database opens.

 

3 Select desired database or enter name in the field Database name.

 

4 Click on [Open].

The selected database opens and its data sets are displayed in the
Determination overview. The database name is displayed in the title
bar of the program, the number of currently opened databases is dis-
played in the left upper corner of the database symbol.

Note

A maximum of 4 databases can be opened, but only 2 can be dis-
played at the same time. Databases that are open at the time the
program is ended will be automatically opened the next time the
program is started.

5.3.3 Close database
How to proceed?

Closing single database

 

1 Select program part Database.

 

2 Click on the symbol  or the menu item File ▶ Close....

The focused database will be closed.

Closing all databases

 

1 Select program part Database.

 

2 Click on menu item File ▶ Close all….
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All opened databases will be closed.

5.3.4 Create database
How to proceed?

1 Select program part Database.

 

2 Click on the symbol  or menu item File ▶ Database manager….

The dialog window Database manager opens.

 

3 Click on the menu item Edit ▶ New....

The dialog window New database opens.

 

4 Enter a name for the new database.

 

5 Click on [OK].

The dialog window Properties - Database - 'Database name'
opens for editing the database properties.

Note

The database name must be unambiguous in the whole Client/Server
system.

 

6 On the tab General enter a comment on the database in the field
Comment.

 

7 On tab Access rights, define access rights for reading and editing the
new database for the different user groups.

 

8 On tab Backup, define backup monitoring and automatic backup for
the new database.

 

9 On tab Monitoring, define monitoring of size and number of data
sets.
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5.3.5 Backing up database
How to proceed?

Backing up database manually

 

1 Select program part Database.

 

2 Click on the symbol  or menu item File ▶ Database manager….

The window Database manager opens.

 

3 Click on [Backup].

The window Backup database opens.

 

4 Select the directory for the backup in the field Backup directory.

 

5 Select or enter the name for the Backup file. If an existing backup file
is selected it will be overwritten.

Note

If the backup directory is on a network drive, the backup date should
be added manually to the Backup name because the backup date
information is not available when the directory is restored.

 

6 Click on [Start].

The manual backup is started and the database is backed up to the
selected directory.

Backing up database automatically

 

1 Select program part Database.

 

2 Click on the symbol  or menu item File ▶ Database manager….

The dialog window Database manager opens.

 

3 Select desired database.

 

4 Click on [Properties].
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The dialog window Properties - Database - 'Database name'
opens for editing the database properties.

 

5 On the tab General enter a comment on the database in the field
Comment.

 

6 On the tab Backup enable the check box Backup monitoring.

 

7 Enter Interval for backup monitoring or date for the Next backup.

 

8 Activate the Start backup automatically check box.

 

9 Select the directory for the backup in the field Backup directory.

 

10 Click on [OK].

 

11 The dialog window Properties - Database is closed.

The database is automatically saved in the selected directory at the
desired time.

5.3.6 Restoring database
How to proceed?

1 Select program part Database.

 

2 Click on the symbol  or menu item File ▶ Database manager….

The dialog window Database manager opens.

 

3 Click on [Restore].

The Restore databases dialog window opens.

 

4 Select the directory in the Backup directory in which the desired
database was backed up.

 

5 Select or enter the name for the desired Backup file.

 

6 Enter the name under Save as under which the database is to be
restored.

 

7 Click on [Start].
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The database restoring is started.

Note

Existing databases cannot be overwritten, i.e. they must first be
deleted so that the database can be recovered under its old name.

5.3.7 Delete database
How to proceed?

1 Select program part Database.

 

2 Click on the symbol  or menu item File ▶ Database manager….

The dialog window Database manager opens.

 

3 Select desired database.

 

4 Click on the menu item Edit ▶ New....

The selected database is deleted.

Note

Databases that are open cannot be deleted.

5.4 Configuration data

5.4.1 Configuration data in general
The configuration data in tiBase  is saved in the Configuration data-
base. Included among the configuration data are settings for the data
import Security settings (see Chapter 3.2.2.1, page 82), User adminis-
tration (see Chapter 3.2.1.1, page 74), Program administration(see
Chapter 3.2.3.1, page 91) and templates.

For local server systems (tiBase  full) the configuration database is located
in the program folder of the computer on which the program has been
installed. In Client/Server systems (tiBase  multi) the configuration database
is stored centrally on the server and saves and contains all the configuration
data of all computers (clients) that are connected to this server.
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5.4.2 Export configuration data
How to proceed?

1 Select program part Configuration.

 

2 Click on the menu item File ▶ Export....

The dialog window Export configuration data opens.

 

3 Select desired configuration data.

 

4 Click on [OK].

The dialog window Export configuration data is closed and the
dialog window Save opened.

 

5 Select or enter name and directory for the export file. If an existing
export file is selected it will be overwritten.

 

6 Click on [Save].

The export of the configuration data is started.

The selected configuration data is then saved in a file with the exten-
sion .mcfg.

5.4.3 Importing configuration data
How to proceed?

1 Select program part Configuration.

 

2 Click on the menu item Determinations ▶ Import....

The dialog window Open opens.

 

3 Select or enter a new name and directory for the import file MCFG.

 

4 Click on [Open].

The dialog window Import configuration data opens.

 

5 Select desired configuration data.
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Note

Data that is not present in the export file cannot be selected.

 

6 Click on [OK].

The import is started and the selected configuration data is imported.

5.4.4 Backing up configuration data
How to proceed?

Note

It is strongly recommended that the configuration database be backed up
periodically.

Backing up configuration data manually

 

1 Select program part Configuration.

 

2 Click on the menu item File ▶ Backup ▶ Manually.

The dialog window Backup configuration data manually opens.

 

3 Select the directory for the backup in the field Backup directory.

 

4 Select or enter the name for the Backup file. If an existing backup file
is selected it will be overwritten.

Note

If the backup directory is on a network drive, the backup date should
be added manually to the Backup name because the backup date
information is not available when the directory is restored.

 

5 Click on [Start].

The manual backup is started and the configuration database is backed
up to the selected directory.
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Backup configuration data automatically

 

1 Select program part Configuration.

 

2 Click on menu item File ▶ Backup ▶ Automatically.

The dialog window Backup configuration data automatically
opens.

 

3 Activate the Automatic backup check box.

 

4 Enter Interval for backup monitoring or date for the Next backup.

 

5 In the field Backup directory select a directory for the backup.

 

6 Click on [OK].

The dialog window Backup configuration data automatically is
closed.

The configuration database is automatically saved in the selected direc-
tory at the desired time.

5.4.5 Restoring configuration data
How to proceed?

tiBase  full

1 Exit tiBase .

 

2 Start the file ConfigRestore.exe in the program directory …\tiBase
\bin.

The dialog window Restore configuration data opens.

 

3 Select the directory in the Backup directory field in which the con-
figuration database was backed up.

 

4 Select or enter the name for the desired Backup file.

 

5 Click on [Start].

The restoring of the configuration database is started.
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tiBase multi

 

1 Make sure that tiBase  is closed on all clients connected to the server
and on the server itself.

 

2 Start the file ConfigRestore.exe in the program directory...\tiBase
\bin on the server.

The dialog window Restore configuration data opens.

 

3 Select the directory in the Backup directory field in which the con-
figuration database was backed up.

 

4 Select or enter the name for the desired Backup file.

 

5 Click on [Start].

The restoring of the configuration database is started.

 

6

5.5 Import of PC/LIMS reports

5.5.1 Import - automatically
How to proceed?

1 Select program part Configuration.

 

2 In the subwindow Import processes, click on the menu item
Edit ▶ New.

The dialog window Properties Import process opens.

 

3 Enter the name of the import process.

 

4 Click on the symbol .

The dialog window Select directory opens.

 

5 Select the source directory with the PC/LIMS reports to be imported to
the database.

 

6 Click on [Select].
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The path is entered in the field Data source.

 

7 Select the database in which the PC/LIMS reports are to be saved.

 

8 Enter a comment (optional).

 

9 If importing the PC/LIMS reports is to run automatically at the start of
tiBase , activate the check box Start automatically.

If the checkbox is deactivated, the PC/LIMS reports have to be imported
manually.

 

10 Activate the option button Delete file if the PC/LIMS reports are to be
deleted in the source directory after the import into the tiBase  data-
base.

 

11 Activate the option button Move file if the PC/LIMS reports are to be
moved from the source directory to another directory after the import
into the tiBase  database.

 

12 Click on the symbol .

The dialog window Select directory opens.

 

13 Select the directory (create new), in which the PC/LIMS reports are to
be moved to.

 

14 Click on [Select].

The path is entered in the field Directory.

5.5.2 Import - manually
How to proceed?

1 Select program part Database.

 

2 Click on the menu item Determinations ▶ Import.... or the symbol

.

The dialog window Import determinations opens.

 

3 Select the PC/LIMS reports.

 

4 Click on [Open].
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5.5.3 Edit import
How to proceed?

1 Select program part Configuration.

 

2 In the subwindow Import processes, click on the menu item
Edit ▶ New.

The dialog window Properties Import process opens.

 

3 Edit the name of the import process.

 

4 Click on the symbol .

The dialog window Select directory opens.

 

5 Select the directory with the PC/LIMS reports to be imported to the
database.

 

6 Click on [Select].

The path is entered in the field Data source.

 

7 Enter a comment (optional).

 

8 If importing the PC/LIMS reports is to run automatically at the start of
tiBase , activate the check box Start automatically.

If the checkbox is deactivated, the PC/LIMS reports have to be imported
manually.

 

9 Activate the option button Delete file if the PC/LIMS reports are to be
deleted in the source directory after the import into the tiBase  data-
base.

 

10 Activate the option button Move file if the PC/LIMS reports are to be
moved from the source directory to another directory after the import
into the tiBase  database.

 

11 Click on the symbol .

The dialog window Select directory opens.

 

12 Select the directory (create new), in which the PC/LIMS reports are to
be moved to.
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13 Click on [Select].

The path is entered in the field Directory.

5.5.4 Import - one USB stick
How to proceed?

Define the properties of the import

 

1 Select program part Configuration.

 

2 In the subwindow Import processes, click on the menu item
Edit ▶ New.

The dialog window Properties Import process opens.

 

3 Enter the name of the import process.

 

4 Click on the symbol .

The dialog window Select directory opens.

 

5 As data source select a path which can access a USB stick

 

6 Click on [Select].

The path is entered in the field Data source.

 

7 Select the database in which the PC/LIMS reports are to be saved.

 

8 Enter a comment (optional).

 

9 If importing the PC/LIMS reports is to run automatically at the start of
tiBase , activate the check box Start automatically.

If the checkbox is deactivated, the PC/LIMS reports have to be imported
manually.

 

10 Activate the option button Delete file if the PC/LIMS reports are to be
deleted in the source directory after the import into the tiBase  data-
base.
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11 Activate the option button Move file if the PC/LIMS reports are to be
moved from the source directory to another directory after the import
into the tiBase  database.

 

12 Click on the symbol .

The dialog window Select directory opens.

 

13 Select the directory (create new), in which the PC/LIMS reports are to
be moved to.

 

14 Click on [Select].

The path is entered in the field Directory.

Import with USB stick

The PC/LIMS reports are saved on a USB stick by the Titrino plus.

 

1 Connect the USB stick to the PC

tiBase directly imports the PC/LIMS reports from the USB stick.

5.5.5 Import - several USB sticks
How to proceed?

When importing via several USB sticks, an own drive letter is to be assigned
to each stick.

Assign drive letter - Windows XP

 

1 Connect the USB stick to the PC.

 

2 Open the context menu of the Workplace with the right mouse but-
ton.

 

3 Click on the menu item Administration.

The dialog window Computer administration opens.

 

4 Click on Storage device administration.

 

5 With the right mouse button, click on the drive letter of the USB stick
in the list of storage devices.
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6 In the context menu, click on Modify drive letter and paths

The dialog window Modify drive letter and path for 'Name'
opens.

 

7 Click on [Modify...].

 

8 Select a new drive letter in the selection list.

The new drive letter must not have been used. Neither by a USB stick
which is not connected.

 

9 Confirm with [OK].

Note

If the USB stick is used on another PC the drive letter must be checked.

Assign drive letter - Windows Vista

 

1 Connect the USB stick to the PC.

 

2 Click on Start ▶ Computer.

 

3 Click on the menu item Administration

The dialog window Computer administration opens.

 

4 Click on Storage device administration.

 

5 In the list of storage devices with the right mouse button click on the
drive letter of the USB stick.

 

6 In the context menu, click on Modify drive letter and paths

The dialog window Modify drive letter and path for 'Name'
opens.

 

7 Click on [Modify...].

 

8 Select a new drive letter in the selection list.
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The new drive letter must not have been used. Neither by a USB stick
which is not connected.

 

9 Confirm with [OK].

Note

If the USB stick is used on another PC the drive letter must be checked.

Define the properties of the import

 

1 Select program part Configuration.

 

2 In the subwindow Import processes, click on the menu item
Edit ▶ New.

The dialog window Properties Import process opens.

 

3 Enter the name of the import process.

 

4 Click on the symbol .

The dialog window Select directory opens.

 

5 As data source select a path which can access a USB stick

 

6 Click on [Select].

The path is entered in the field Data source.

 

7 Select the database in which the PC/LIMS reports are to be saved.

 

8 Enter a comment (optional).

 

9 If importing the PC/LIMS reports is to run automatically at the start of
tiBase , activate the check box Start automatically.

If the checkbox is deactivated, the PC/LIMS reports have to be imported
manually.

 

10 Activate the option button Delete file if the PC/LIMS reports are to be
deleted in the source directory after the import into the tiBase  data-
base.
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11 Activate the option button Move file if the PC/LIMS reports are to be
moved from the source directory to another directory after the import
into the tiBase  database.

 

12 Click on the symbol .

The dialog window Select directory opens.

 

13 Select the directory (create new), in which the PC/LIMS reports are to
be moved to.

 

14 Click on [Select].

The path is entered in the field Directory.

Import with USB stick

The PC/LIMS reports are saved on a USB stick by the Titrino plus.

 

1 Connect the USB stick to the PC

tiBase directly imports the PC/LIMS reports from the USB stick.

5.5.6 Import protocol - Properties
How to proceed?

1 Select program part Configuration.

 

2 In the subwindow Import protocol, click on the menu item
Edit ▶ Options....

The dialog window Properties Import protocol opens.

 

3 Activate the check box for the required filter options.

 

4 Enter the desired maximum number of log entries.

 

5 Click on [OK].
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5.5.7 Delete import protocol
How to proceed?

1 Select program part Configuration.

 

2 In the subwindow Import protocol, click on the menu item
Edit ▶ Delete all messages.

5.6 Reports

5.6.1 Creating report template
How to proceed?

1 Select program part Database.

 

2 Note

A database must be open in order to carry out subsequent steps.

Click on the menu item Tools ▶ Report templates ▶ New ▶ Form
report… or Tools ▶ Report templates ▶ New ▶ Tabular
Report….

The program window Report template with an empty report tem-
plate opens.

 

3 Click on the menu item File ▶ Page setup… in the program window
Report template.

The dialog window Page setup opens.

 

4 Define desired settings for the report format.

 

5 Click on [OK].

The dialog window Page setup is closed.

 

6 In the program window Report template, click on the menu item
Tools ▶ Options....

The dialog window Options for report templates opens.

 

7 Define desired settings for the report template.
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8 Close the dialog window with [OK].

 

9 Select desired module symbol on the Module bar and place it on the
report template by creating a field with the left mouse button.

The properties window for the corresponding module opens automat-
ically.

 

10 Enter desired settings for the module.

 

11 Click on [OK].

The properties window is closed.

 

12 Repeat steps 7 and 8 for each desired module. 

 

13 Click on the symbol  or the menu item File ▶ Save as....

The dialog window Save report template opens.

 

14 In the field Name enter a name.

 

15 Click on [Save].

The report template is saved under the name entered.

5.6.2 Edit report template
How to proceed?

1 Select program part Database.

 

2 Click on the symbol  or on the menu item Tools ▶ Report tem-
plates ▶ Open….

The program window Open report template opens.

 

3 Open desired report template.

 

4 Click on [Open].

The program window with the selected report template opens.

 

5 Click on the menu item File ▶ Page setup....

The dialog window Page setup opens.
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6 Define desired settings for the report format.

 

7 Close the dialog window with [OK].

 

8 In the program window Report template, click on the menu item
Tools ▶ Options....

The dialog window Options for report templates opens.

 

9 Define desired settings for the report template.

 

10 Close the window with [OK].

Editing existing modules

 

1
Select the symbol  on the module bar and double-click on the
desired module in the report template.

The properties window of the selected module opens automatically.

 

2 Enter desired settings for the module.

 

3 Close the properties window with [OK].

 

4 Repeat steps 1 and 2 for each desired module. 

Creating new modules

 

1 Select desired module symbol on the Module bar and place it on the
report template by creating a field with the left mouse button.

The properties window for the corresponding module opens automat-
ically.

 

2 Define desired setttings for the module.

 

3 Close the properties window with [OK].

 

4 Repeat steps 1 and 2 for each desired new module.

 

5 Click on the symbol  or the menu item File ▶ Save.
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The report template is saved.

5.6.3 Printing determination report 
How to proceed?

1 Select program part Database.

 

2 Click on the symbol  or the menu item File ▶ Open....

The dialog window Open database opens.

 

3 Select desired database or enter name in the field Database name.

 

4 Click on [Open].

The selected database opens and its data sets are displayed in the
Determination overview. The database name is displayed in the title
bar of the program, the number of currently opened databases is dis-
played in the left upper corner of the database symbol.

Note

A maximum of 4 databases can be opened, but only 2 can be dis-
played at the same time. Databases that are open at the time the
program is ended will be automatically opened the next time the
program is started.

 

5 Select desired determinations.

 

6 Click on the menu item File ▶ Print ▶ Report....

The dialog window Report output opens.

 

7 Under Selection, select desired determinations.

 

8 Under Report type, select the option Original report or Report
template.

 

9 Under Output target, enable the check box Printer and/or select
PDF file.
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Note

If several reports are produced simultaneously as a PDF file then an
index will be automatically appended to the file name.

 

10 In the dialog window Report output, click on [OK].

The reports of the selected determination are put out.

5.6.4 Printing determination overview 
How to proceed?

1 Select program part Database.

 

2 Click on the symbol  or the menu item File ▶ Open....

The dialog window Open database opens.

 

3 Select desired database or enter name in the field Database name.

 

4 Click on [Open].

The selected database opens and its data sets are displayed in the
Determination overview. The database name is displayed in the title
bar of the program, the number of currently opened databases is dis-
played in the left upper corner of the database symbol.

Note

A maximum of 4 databases can be opened, but only 2 can be dis-
played at the same time. Databases that are open at the time the
program is ended will be automatically opened the next time the
program is started.

 

5 Select desired determinations.

 

6 Click on menu item File ▶ Print ▶ Determination overview….

The dialog window Print determination overview (PDF) opens.

 

7 Under Selection, select desired determinations.
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8 Under Orientation, select the option Portrait format or Landscape
format.

 

9 Click on [OK].

The determination overview is opened as PDF file.
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